Составьте программу, которая, учитывая наименование года и день недели соответствующий 1 января, выводит на экран наименования месяцев в которых число 13 выпадет на пятницу (программа pascal abc) сроч?

Информатика | 5 - 9 классы

Составьте программу, которая, учитывая наименование года и день недели соответствующий 1 января, выводит на экран наименования месяцев в которых число 13 выпадет на пятницу (программа pascal abc) срочно надо, не понимаю как составить(.

Ответить на вопрос
Ответы (1)
Aibala1lolipop 21 авг. 2020 г., 03:29:18

/ / Можно и без дня недели пятницы / / PascalABC.

NET 3.

2 сборка 1318 / / PascalABC вариант

Var Year, YearCode : integer ;

begin

readln(Year) ; case(Year div 100 mod 4) of

0 : YearCode : = 6 ; 1 : YearCode : = 4 ; 2 : YearCode : = 2 ; 3 : YearCode : = 0 ; end ;

YearCode : = (YearCode + Year mod 100 + Year mod 100 div 4) mod 7 ;

if Year mod 4< ; > ; 0 then begin if (13 + 1 + YearCode) mod 7 = 6 then writeln('Январь') ; end

else if (13 + 1 + YearCode) mod 7 = 0 then writeln('Январь') ;

if Year mod 4< ; > ; 0 then begin if (13 + 4 + YearCode) mod 7 = 6 then writeln('Февраль') ; end

else if (13 + 4 + YearCode) mod 7 = 0 then writeln('Февраль') ;

if (13 + 1 + YearCode) mod 7 = 6 then writeln('Октябрь') ;

if (13 + 2 + YearCode) mod 7 = 6 then writeln('Май') ;

if (13 + 3 + YearCode) mod 7 = 6 then writeln('Август') ;

if (13 + 4 + YearCode) mod 7 = 6 then writeln('Март') ;

if (13 + 4 + YearCode) mod 7 = 6 then writeln('Ноябрь') ;

if (13 + 5 + YearCode) mod 7 = 6 then writeln('Июнь') ;

if (13 + 6 + YearCode) mod 7 = 6 then writeln('Декабрь') ;

if (13 + 6 + YearCode) mod 7 = 6 then writeln('Сентябрь') ;

if (13 + 0 + YearCode) mod 7 = 6 then writeln('Апрель') ;

if (13 + 0 + YearCode) mod 7 = 6 then writeln('Июль') ;

end.

/ / .

NET вариант

uses system ; const Day = 13 ; n = 12 ; Var Year, i : integer ; ars : array[1.

N] of string : = ('Январь', 'Февраль', 'Март', 'Апрель', 'Май', 'Июнь', 'Июль', 'Август', 'Сентябрь', 'Октябрь', 'Ноябрь', 'Декабрь') ; ard : array[1.

N] of DateTime ;

begin

readln(Year) ;

for i : = 1 to n do begin ard[i] : = ard[i].

AddDays(Day - 1) ; ard[i] : = ard[i].

AddMonths(i - 1) ; ard[i] : = ard[i].

AddYears(Year - 1) ; if ard[i].

DayOfWeek.

ToString = 'Friday' then writeln(ars[i]) ; end ;

end.

Пример ввода :

2016

Пример вывода :

Май.

Arina464646 3 нояб. 2020 г., 06:13:30 | 10 - 11 классы

Составьте программу в Pascal ABC которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150?

Составьте программу в Pascal ABC которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150.

Спасибо заранее.

Skunc1 23 нояб. 2020 г., 04:37:00 | 5 - 9 классы

Программа , которая выводит на экран день недели?

Программа , которая выводит на экран день недели.

Четверг.

Lollal1 16 февр. 2020 г., 13:00:11 | 10 - 11 классы

Напишите пожалуйста программу на pascal?

Напишите пожалуйста программу на pascal.

Составьте программу, которая выводит на экран сумму чисел кратных 5 - и от 30 до 60.

Цикл repeat.

Isida78s 12 дек. 2020 г., 05:03:40 | 5 - 9 классы

Составьте программу, которая заполняет массив а[1?

Составьте программу, которая заполняет массив а[1.

10] случайными целыми числами от 0 до 2 и выводит на экран количество элементов, равных 1.

Pascal Abc.

Evashva 22 нояб. 2020 г., 02:20:56 | 5 - 9 классы

Составить программу, которая запрашивает предложение и выводит на экран все его буквы "и"?

Составить программу, которая запрашивает предложение и выводит на экран все его буквы "и".

Программу составить при помощи Pascal ABC.

Sabrinakotsk1 27 сент. 2020 г., 00:02:27 | 5 - 9 классы

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC?

Составить программу, которая выводит на экран в обратном порядке нечетные числа от 29 до 1 в Pascal ABC.

Составить программу, которая выводит на экран сумму нечетных чисел от 1 до 30 в Pascal ABC.

Ivanushun12345 2 июл. 2020 г., 12:04:02 | 5 - 9 классы

Pascal ABC?

Pascal ABC.

Дано натуральное число "n".

Составьте программу которая выводит максимальную цифру этого числа.

Ррпотиаои 24 янв. 2020 г., 19:37:41 | 10 - 11 классы

Составить программу, которая запрашивает сколько раз и какое число необходимо напечатать?

Составить программу, которая запрашивает сколько раз и какое число необходимо напечатать.

И выводит это число на экран заданное количество раз.

В Pascal.

Жранкель 28 февр. 2020 г., 01:03:04 | 5 - 9 классы

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке ?

Составьте программу (в Pascal ABC), которая выводит на экран дату в рамке :

Dalluk 28 окт. 2020 г., 03:16:46 | 5 - 9 классы

Циклы (for and while), помогите составить программу в Pascal ABC, пожалуйста?

Циклы (for and while), помогите составить программу в Pascal ABC, пожалуйста.

Составьте программу, которая выводит на экран количество трехзначных чисел у которых вторая цифра в два раза больше первой, а третья в два раза больше второй.

На этой странице сайта размещен вопрос Составьте программу, которая, учитывая наименование года и день недели соответствующий 1 января, выводит на экран наименования месяцев в которых число 13 выпадет на пятницу (программа pascal abc) сроч? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.