Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа?

Информатика | 5 - 9 классы

Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа.

Ответить на вопрос
Ответы (1)
MariaTauch 21 мар. 2022 г., 00:10:53

Var n, i, d : integer ;

found : boolean ;

begin

d : = 1 ;

found : = false ;

writeln('Введите целое число больше единицы') ;

readln(n) ;

if n mod 2 = 0 then d : = n div 2

else begin i : = (n div 2) - 1 ; while (found = false) and (i > 2) do begin if n mod i = 0 then begin found : = true ; d : = i ; end ; i : = i - 1 ; end ; end ;

if d = 1 then writeln('введённое число оказалось простым')

else writeln('наибольший целый делитель введённого числа равен ', d) ;

end.

Исла 10 янв. 2022 г., 01:32:17 | 1 - 4 классы

Напишите любые 5 программ с циклом со счетчиком в PascalABC?

Напишите любые 5 программ с циклом со счетчиком в PascalABC.

BlaVikunRDiana 19 янв. 2022 г., 01:55:59 | 5 - 9 классы

1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2?

1. составить программу нахождения для заданного натурального числа всех делителей, заканчивающихся на цифру 5 или 2.

Anarhist13 5 мар. 2022 г., 00:14:54 | 5 - 9 классы

Составьте программу, которая выводит целую часть от деления целого числа на m на 6, если оно кратно 6?

Составьте программу, которая выводит целую часть от деления целого числа на m на 6, если оно кратно 6.

199952 21 февр. 2022 г., 22:16:57 | 5 - 9 классы

Создать программу даны два целых числа A и B (A?

Создать программу даны два целых числа A и B (A.

Mrnigritosik12 11 мая 2022 г., 09:55:17 | 10 - 11 классы

Напишите программу, перемножающую целые числа без использования операции « * »?

Напишите программу, перемножающую целые числа без использования операции « * ».

Например, при умножении целых чисел n * m число m надо сложить само с собой n раз (m + m + … + m).

На языке Паскаль.

Dmitriy2005rus 2 мар. 2022 г., 23:03:03 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит н?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , сумму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

(Паскаль).

Волк151 28 мар. 2022 г., 04:22:36 | 5 - 9 классы

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n2)напишите программу, которая спрашивает целые числа а и b и выводит на?

1)напишите программу, которая спрашивает целое число n и считает сумму целых чисел , Муму чётных чисел и сумму нечётных от 1 до n

2)напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b

3) напишите программу, которая спрашивает целые числа а и b и выводит на экран количество чётных и нечётных чисел в диапазоне от а до b

4) напишите программу, которая спрашивает целое число n , целые числа а и b, и выводит на экран n случайных чисел от а до b.

JaneMilkYTber 14 апр. 2022 г., 05:34:57 | 5 - 9 классы

Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа?

Два множества : первое все простые делители некоторого целого числа N и второе все простые делители того же числа.

Вывести на экран делители которые не являются простыми.

(Паскаль).

Poyisotuz 13 февр. 2022 г., 15:46:32 | 5 - 9 классы

Написать программу возведения в квадрат целого числа?

Написать программу возведения в квадрат целого числа.

Vladuk9666 4 июн. 2022 г., 18:31:49 | 5 - 9 классы

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Как вывести функцию сравнения двух чисел в паскале с помощью mod и div не используя IF?

Напишите программу, которая считывает два целых положительных числа aa и bb и выводит наибольшее значение из них.

Вы зашли на страницу вопроса Напишите программу в PascalABC : нахождение наибольшего целого делителя целого числа?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.