Помогитттеееее срочно 13б?

Информатика | 5 - 9 классы

Помогитттеееее срочно 13б!

1 Определить значение переменной S после выполнения следующих команд : S : = 1 ; n : = 3 ; for i : = 1 to n do s : = s + i * i.

2Что выведется на экран в результате выполнения фрагмента программы :

s : = 0 ;

for j : = 10 to 15 do begin s : = s + 2 * j ; write(s) end.

3 Что выведется на экран в результате выполнения фрагмента программы :

p : = 1 ;

for k : = 5 downto 1 do begin p : = p * k ; end ;

write(p).

Ответить на вопрос
Ответы (1)
Krot85 8 мар. 2022 г., 04:00:02

1 : Ну - с, три раза циклом идем начиная с 1 до 3 и получается следующее : Идем первый раз : S : = 1 + 1 * 1 в результате S = 2 ; Идем второй раз : S : = 2 + 2 * 2 в результате S = 6 ; Идем третий раз : S : = 6 + 3 * 3 в результате S = 15 ; Ответ : S = 15 ;

2 : В результате выполнения программы будет выведены 6 чисел которые получились в результате вычисления s : = s + 2 * j ;

Т.

Е. как и в предыдущем задание (1) идем циклом с 10 до 15 и считаем, а после сразу выводим.

S : = 0 + 2 * 10 ; S = 20 ; S : = 20 + 2 * 11 ; S = 42 ; S : = 42 + 2 * 12 ; S = 66 ; S : = 66 + 2 * 13 ; S = 92 ; S : = 92 + 2 * 14 ; S = 120 ; S : = 120 + 2 * 15 ; S = 150 ;

3 : крч все тоже самое цикл и т.

Д. Ответ : 5 20 60 120 120.

Ника1576 24 янв. 2022 г., 12:26:04 | 10 - 11 классы

Два фрагмента программы записанный на языке ПаскальBeginK : = 5 ; N : = 0 ;For i : = 1 to K do ;BeginN : = i + K + N ;N : = n - 5 ;End ;K : = N ;End?

Два фрагмента программы записанный на языке Паскаль

Begin

K : = 5 ; N : = 0 ;

For i : = 1 to K do ;

Begin

N : = i + K + N ;

N : = n - 5 ;

End ;

K : = N ;

End.

Чему равно значение переменной K после выполнения?

NikitaTehnik 13 янв. 2022 г., 18:05:18 | 5 - 9 классы

Дан фрагмент программы :s : = 0 ;for i : = 1 to 10 do s : = s + 2 ;Чему будет равно значение S после его выполнения ?

Дан фрагмент программы :

s : = 0 ;

for i : = 1 to 10 do s : = s + 2 ;

Чему будет равно значение S после его выполнения ?

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Diarajusupova 5 февр. 2022 г., 13:35:23 | 5 - 9 классы

Задание 2?

Задание 2.

Определи значения переменной с после выполнения фрагмента алгоритма a : = 15

b : = 30

b : = a * 2 - b / 2 ;

if a>b then

c : = 3 * bb - a / 3

else

c : = 3 * a - 4 * b ;

задание 3.

Каково значение примет переменная у после выполнения фрагмента программы

y : = 1

x : = 15

while x>5 do begin

x : = x - 3 ; y : = y * x

end

задание 5

переведи десятичное число 231 (10) степени в двоичную и шеснадцатиричную систему счисления

задание 6

переведи двоичное число 1001101(2) в десятичную систему счисления.

MikeEnd 20 янв. 2022 г., 20:48:17 | 10 - 11 классы

Определить значения переменных после выполнения фрагментов программы y : = 1 ; for k : = 1 to 3 do y : = y + k ; y : = y * 10?

Определить значения переменных после выполнения фрагментов программы y : = 1 ; for k : = 1 to 3 do y : = y + k ; y : = y * 10.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Малой2000 12 мар. 2022 г., 05:10:32 | студенческий

А как быть с этим?

А как быть с этим?

Определите пожалуйста, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 120 :

var i, k : integer ;

function F(x : integer) : integer ;

begin if x < 1 then F : = 1 else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin i : = 0 ; readln(K) ; while F(i) < K do i : = i + 1 ; writeln(i) ;

end.

Anyasmeshko 25 февр. 2022 г., 01:48:42 | 10 - 11 классы

Помоги мне решать это, кто ответил спасибо большоое) Определить значение переменной XX после выполнения следующей программыProgramm AA ;varxx, i, j, k : integer ;beginxx : = 0 ;for i : = 1 to 2 dofor ?

Помоги мне решать это, кто ответил спасибо большоое) Определить значение переменной XX после выполнения следующей программы

Programm AA ;

var

xx, i, j, k : integer ;

begin

xx : = 0 ;

for i : = 1 to 2 do

for J : = 1 to i + 1 do

for k : = 1 to j + 1 do xx : = xx + 1.

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Artur123456783316 2 мар. 2022 г., 13:46:25 | 5 - 9 классы

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования ПаскальVar s, k, x : integer ;begins : = 1 ;x : = 2 ;for k : = 1 to 9 dos : = s * x?

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования Паскаль

Var s, k, x : integer ;

begin

s : = 1 ;

x : = 2 ;

for k : = 1 to 9 do

s : = s * x ;

writeln(s) ;

end.

Вы зашли на страницу вопроса Помогитттеееее срочно 13б?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.