Два фрагмента программы записанный на языке ПаскальBeginK : = 5 ; N : = 0 ;For i : = 1 to K do ;BeginN : = i + K + N ;N : = n - 5 ;End ;K : = N ;End?

Информатика | 10 - 11 классы

Два фрагмента программы записанный на языке Паскаль

Begin

K : = 5 ; N : = 0 ;

For i : = 1 to K do ;

Begin

N : = i + K + N ;

N : = n - 5 ;

End ;

K : = N ;

End.

Чему равно значение переменной K после выполнения?

Ответить на вопрос
Ответы (1)
Катюша148 24 янв. 2022 г., 12:26:08

N : = i + k + n = 1 + 5 + 0 = 6

n : = 6 - 5 = 1

k : = n = 1.

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

MikeEnd 20 янв. 2022 г., 20:48:17 | 10 - 11 классы

Определить значения переменных после выполнения фрагментов программы y : = 1 ; for k : = 1 to 3 do y : = y + k ; y : = y * 10?

Определить значения переменных после выполнения фрагментов программы y : = 1 ; for k : = 1 to 3 do y : = y + k ; y : = y * 10.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Arjaa 17 февр. 2022 г., 08:53:17 | студенческий

Функция F(n), где n – натуральное число, задана следующим образом :Паскальfunction F(n : integer) : integer ;begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;end ;Чему будет рав?

Функция F(n), где n – натуральное число, задана следующим образом :

Паскаль

function F(n : integer) : integer ;

begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;

end ;

Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(6)?

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Doooooos2016 24 мар. 2022 г., 08:38:40 | 10 - 11 классы

СрочноProgram sredarifment ;Var a : array[1?

Срочно

Program sredarifment ;

Var a : array[1.

10] of real ;

i, k : integer ;

C, S, sred : real ;

Begin

For i : = 1 to 10 do begin write ('a[', i, '] = ') ; readln (a[i]) ; end ;

write('введите C : ') ; readln (C) ;

For i : = 1 to 10 do begin If a[i]>C then begin S = S + a[i] ; K = K + 1 ; end ; end ;

sred = S / k ;

Writeln('среднее арифметическое чисел, превосходящих ', C, ' равно ', sred) ;

End.

Помогите чтобы программа запускалась.

Выходит что не верно.

Тонечка121 8 мар. 2022 г., 04:00:01 | 5 - 9 классы

Помогитттеееее срочно 13б?

Помогитттеееее срочно 13б!

1 Определить значение переменной S после выполнения следующих команд : S : = 1 ; n : = 3 ; for i : = 1 to n do s : = s + i * i.

2Что выведется на экран в результате выполнения фрагмента программы :

s : = 0 ;

for j : = 10 to 15 do begin s : = s + 2 * j ; write(s) end.

3 Что выведется на экран в результате выполнения фрагмента программы :

p : = 1 ;

for k : = 5 downto 1 do begin p : = p * k ; end ;

write(p).

Artur123456783316 2 мар. 2022 г., 13:46:25 | 5 - 9 классы

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования ПаскальVar s, k, x : integer ;begins : = 1 ;x : = 2 ;for k : = 1 to 9 dos : = s * x?

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования Паскаль

Var s, k, x : integer ;

begin

s : = 1 ;

x : = 2 ;

for k : = 1 to 9 do

s : = s * x ;

writeln(s) ;

end.

Вы перешли к вопросу Два фрагмента программы записанный на языке ПаскальBeginK : = 5 ; N : = 0 ;For i : = 1 to K do ;BeginN : = i + K + N ;N : = n - 5 ;End ;K : = N ;End?. Он относится к категории Информатика, для 10 - 11 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.