А как быть с этим?

Информатика | студенческий

А как быть с этим?

Определите пожалуйста, количество чисел K, для которых следующая программа выведет такой же результат, что и для K = 120 :

var i, k : integer ;

function F(x : integer) : integer ;

begin if x < 1 then F : = 1 else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin i : = 0 ; readln(K) ; while F(i) < K do i : = i + 1 ; writeln(i) ;

end.

Ответить на вопрос
Ответы (1)
3443жирафик 12 мар. 2022 г., 05:10:36

Var i, k : integer ;

function F(x : integer) : integer ;

begin

if x < 1 then

F : = 1

else F : = F(x - 1) + 3 * F(x - 2) ;

end ;

begin

i : = 0 ;

readln(K) ;

while F(i) < K do

i : = i + 1 ;

writeln(i) ;

end.

ОТВЕТ : 220.

Екатерина29051999 2 янв. 2022 г., 14:32:50 | 10 - 11 классы

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :var a, b : integer ;begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; wr?

Определите, какое число будет напечатано на экране в результате выполнения следующей программы :

var a, b : integer ;

begin a : = 0 ; b : = 2 ; while b < 32 do begin a : = a + 1 ; b : = b * 2 ; end ; writeln(a) ;

end.

Bdot 4 февр. 2022 г., 06:35:56 | 10 - 11 классы

65) (Д?

65) (Д.

Ф. Муфаззалов, Уфа) Какое число будет напечатано в результате выполнения программы :

var i, k : integer ;

function f(x : integer) : integer ;

var m : integer ;

begin

if x < 10 then f : = x

else begin

m : = f(x div 10) ;

if m < x mod 10 then

f : = x mod 10

else f : = m ;

end ;

end ;

begin

k : = 0 ;

for i : = 1000 to 9999 do

if f(i mod 100) = 1 then

if f(i div 100) = f(i mod 100) then

k : = k + 1 ;

writeln(k) ;

end.

Объясните, пожалуйста.

Nastjakijam 28 янв. 2022 г., 23:03:19 | 10 - 11 классы

Ниже записана программа?

Ниже записана программа.

Получив на вход число , эта программа

печатает два числа, a и b.

Укажите наибольшее из чисел , при вводе которых алгоритм печатает сначала 2, а потом 8.

Var x, a, b : integer ;

begin

readln(x) ;

a : = 0 ; b : = 0 ;

while x > 0 do begin

a : = a + 1 ;

b : = b + (x mod 100) ;

x : = x div 100 ;

end ;

writeln(a) ; write(b) ;

end.

Татьяна110 5 февр. 2022 г., 03:48:09 | 5 - 9 классы

Помогите найти ошибку (Информатика, Паскаль)?

Помогите найти ошибку (Информатика, Паскаль).

Var s, k, a : integer ;

Begin

s : = 0 ;

k : = 0 ;

Read(a) ;

while a0 do

Begin

if a mod 8 = 0 then

Begin

s : = s + a ;

k : = k + 1 ;

end ;

Readln(a) ;

end ;

var y : real ;

begin

y : = s / k ;

Read(s) ;

if s>0 then

Writeln(y)

else

Writeln('NO')

end ;

end.

Сурок228 2 февр. 2022 г., 14:17:32 | студенческий

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)var n, s : integerbeginn : = 0 ;s : = 402 ;while s>0 dobegins : = s - 10 ;n : = ?

Определите число : которое будет напечатано в результате выполнения программы (с помощью языка программирования Паскаль)

var n, s : integer

begin

n : = 0 ;

s : = 402 ;

while s>0 do

begin

s : = s - 10 ;

n : = n + 3

end ;

write(n)

end.

Arjaa 17 февр. 2022 г., 08:53:17 | студенческий

Функция F(n), где n – натуральное число, задана следующим образом :Паскальfunction F(n : integer) : integer ;begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;end ;Чему будет рав?

Функция F(n), где n – натуральное число, задана следующим образом :

Паскаль

function F(n : integer) : integer ;

begin if n > 1 then F : = 2 * n + F(n - 2) + F(n - 3) else F : = n + 5 ;

end ;

Чему будет равно значение, вычисленное алгоритмом при выполнении вызова F(6)?

Agent2013 10 мар. 2022 г., 07:17:40 | студенческий

Дайте ответ пожалуйста?

Дайте ответ пожалуйста!

Ниже записана программа.

Получив на вход число , эта программа печатает два числа, и .

Укажите наименьшее из таких чисел , при вводе которых алгоритм печатает сначала 3, а потом10.

Var x, a, b : integer ;

begin readln(x) ; a : = 0 ; b : = 1 ; while x > 0 do begin a : = a + 1 ; b : = b * (x mod 8) ; x : = x div 8 ; end ; writeln(a) ; write(b) ;

end.

Arzni 4 февр. 2022 г., 15:08:15 | 10 - 11 классы

Перевод кода паскаль в c + +2)var i, sum : integer ;n : real ;beginsum : = 0 ;for i : = 1 to 15 dobeginreadln(n) ;if n = trunc(n) then sum : = sum + 1 ;end ;writeln(sum) ;end?

Перевод кода паскаль в c + +

2)var i, sum : integer ;

n : real ;

begin

sum : = 0 ;

for i : = 1 to 15 do

begin

readln(n) ;

if n = trunc(n) then sum : = sum + 1 ;

end ;

writeln(sum) ;

end.

2

Var

a1, b2, c, d : integer ;

begin

write('Введите числа через пробел : ') ;

read(a1) ;

for d : = 2 to 10 do begin

read(b2) ;

if b2>a1 then inc(c) ;

a1 : = b2 ;

end ;

if c = 9 then writeln('Да') else writeln('Нет') ;

end.

Damirmuhamediar 22 янв. 2022 г., 23:48:51 | 10 - 11 классы

Запишите значение переменной y, полученное в результате работы следующей программы?

Запишите значение переменной y, полученное в результате работы следующей программы.

Текст программы приведён на трёх языках программирования.

Var y, i : integer ;

Begin

y : = 5 ;

For i : = 1 to 3 do

y : = y + 5 * i ;

Writeln(y) ;

End.

Artur123456783316 2 мар. 2022 г., 13:46:25 | 5 - 9 классы

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования ПаскальVar s, k, x : integer ;begins : = 1 ;x : = 2 ;for k : = 1 to 9 dos : = s * x?

Определите, что будет напечатано в результате выполнения следующего алгоритма, записанного на языке программирования Паскаль

Var s, k, x : integer ;

begin

s : = 1 ;

x : = 2 ;

for k : = 1 to 9 do

s : = s * x ;

writeln(s) ;

end.

Вопрос А как быть с этим?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для студенческий. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.