Дано натуральное число ?

Информатика | 5 - 9 классы

Дано натуральное число .

Определить есть ли в нем цифра а Написать с постусловием язык Паскаля !

Ответить на вопрос
Ответы (1)
Наиль1111111 28 мая 2020 г., 19:24:25

/ / Язык.

Паскаля.

Язык Паскаля, Карл!

/ / Pascal ABC.

NET v3.

1 сборка 1172

Var

a, b, c : integer ;

d : boolean ;

begin

d : = false ;

readln(a) ;

readln(b) ;

repeat c : = a mod 10 ; a : = a div 10 ; if c = b then d : = true ;

until (c = b) or (a = 0) ;

if d = true then writeln('Есть') else writeln('Нет') ;

end.

Пример ввода :

34457

8

Пример вывода :

Нет.

Плацебо 12 сент. 2020 г., 08:15:50 | 10 - 11 классы

Написать программу, Паскаль?

Написать программу, Паскаль.

Дано натуральное число N.

Вычислить S = 1!

+ 2! + 3!

+ . + n!

(n> ; = 1) Решить через repeat (с постусловием).

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Myrick 10 авг. 2020 г., 07:02:32 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти сумму цифр числа.

(Написать программу на языке Паскаль).

Raikiss 11 февр. 2020 г., 12:36:35 | 10 - 11 классы

1)Даны натуральные числа n и k?

1)Даны натуральные числа n и k.

Определить k - ю справа цифру числа n.

2)Дан целочисленный массив A.

Найти в нем два наименьших элемента.

ПАСКАЛЬ!

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

КРОЛЛЬ 17 февр. 2020 г., 04:49:02 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить, есть ли в нем цифра равная а (а вводится с клавиатуры).

Sofiykas 5 июн. 2020 г., 20:18:17 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить число состоящее из m последних чётных цифр числа n.

Написать программу на Паскале только на Паскале.

Карие111 2 июн. 2020 г., 10:01:48 | 5 - 9 классы

Дано целое число?

Дано целое число.

Определить сколько в нем цифр 5.

Написать программу в Паскаль АВС.

Катюшка170212 27 сент. 2020 г., 04:27:12 | 5 - 9 классы

Написать программу в паскале?

Написать программу в паскале.

Дано натуральное число Х.

Найти сумму квадратов чётных цифр в числе.

Вы зашли на страницу вопроса Дано натуральное число ?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.