Дано натуральное число?

Информатика | 5 - 9 классы

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Ответить на вопрос
Ответы (1)
Shipaklyak 1 сент. 2020 г., 01:35:13

Var n, i, k : Integer ;

Begin

Read(n) ;

for i : = 1 to n do if (n mod i = 0) and (i mod 2 < ; > ; 0) then k : = k + 1 ;

Writeln(k) ;

end.

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Antonkhvorov 20 июн. 2020 г., 12:56:51 | 10 - 11 классы

1) дано натуральное а?

1) дано натуральное а.

Верно ли, что данное число состоит из 3 цифр?

2) дано натуральное число.

Верно ли, что в данном числе четыре цифры?

3) Даны два натуральных числа.

Определить в каком числе первая цифра больше.

4) Дано натуральное n.

Найти количество 6, входящих в данное число.

Нужно решить в программе паскаль.

Если поможет, то мы учим цикл в паскале, div, mod.

VoinVasia 4 дек. 2020 г., 06:25:41 | 10 - 11 классы

Написать код программы в паскале для задачи : Дано натуральное число n?

Написать код программы в паскале для задачи : Дано натуральное число n.

Вычислить(см.

Картинку).

Mur4ik313 23 июн. 2020 г., 08:38:00 | 5 - 9 классы

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей?

Дано натуральное число : а)получить все его делители б)найти сумму его делителей в)найти сумму его четных делителей г)определить количество его нечетных делителей е)определить количество его делителей.

Сколько из них четных?

Ж)найти количество его делителей, больших d" На ТУРБО ПАСКАЛЕ СРОЧНО!

Schura97 3 июл. 2020 г., 10:20:09 | 10 - 11 классы

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N?

Помогите написать программу на PascalABCNET ВХОДНЫЕ ДАННЫЕ Задано натуральное число N.

ВЫХОДНЫЕ ДАННЫЕ Определите количество нулей в его записи.

Sofiykas 5 июн. 2020 г., 20:18:17 | 10 - 11 классы

Даны натуральные числа m и n?

Даны натуральные числа m и n.

Получить число состоящее из m последних чётных цифр числа n.

Написать программу на Паскале только на Паскале.

Доббик 4 окт. 2020 г., 05:44:07 | 10 - 11 классы

ПАСКАЛЬ, ИНФОРМАТИКА?

ПАСКАЛЬ, ИНФОРМАТИКА.

П о м о г и т е Дано натуральное число.

Найти количество нечетных цифр в нем.

Солнце12 12 авг. 2020 г., 08:04:02 | 5 - 9 классы

Написать программу на языке паскаль Определить является ли число четным или нечетным?

Написать программу на языке паскаль Определить является ли число четным или нечетным.

Иосиф2 8 апр. 2020 г., 23:56:33 | 10 - 11 классы

1) Написать программу, находящую для натурального числа все его натуральные делители?

1) Написать программу, находящую для натурального числа все его натуральные делители.

2) Написать программу, вычисляющую наибольший общий делитель двух натуральных чисел.

Катюшка170212 27 сент. 2020 г., 04:27:12 | 5 - 9 классы

Написать программу в паскале?

Написать программу в паскале.

Дано натуральное число Х.

Найти сумму квадратов чётных цифр в числе.

Вы зашли на страницу вопроса Дано натуральное число?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 5 - 9 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.