Помогите изменить так, чтобы не было ошибки?

Информатика | 10 - 11 классы

Помогите изменить так, чтобы не было ошибки.

Прошу :

#include

int sum( int x, int y) ;

{ int s ; s = x + y ; return s ;

}

int main()

{ int x, y, z ; scanf("%d%d%d", &x, &y, &z) ; z = sum(100, 5) ; printf("%d", z) ;

}

.

Вот комментарий :

cpp : 3 : error : syntax error before `{' token

cpp : 5 : error : ISO C + + forbids declaration of `s' with no type

cpp : 5 : error : `x' was not declared in this scope

cpp : 5 : error : `y' was not declared in this scope

cpp : 6 : error : syntax error before `return'.

Ответить на вопрос
Ответы (1)
Мега15 13 дек. 2020 г., 06:44:34

#include

using namespace std ;

int sum( int x, int y)

{

return x + y ;

}

int main()

{

int x, y, z ;

scanf("%d%d", &x, &y) ;

z = sum(x, y) ;

printf("%d", z) ;

}

Пример :

100 5

105.

Лё8а 5 нояб. 2020 г., 07:42:59 | 10 - 11 классы

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * )?

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * ).

84193135 11 июн. 2020 г., 00:41:12 | 10 - 11 классы

Язык С?

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Koloverdova87 28 окт. 2020 г., 19:50:09 | 10 - 11 классы

Объясните пожалуйста как такой ответ выходит?

Объясните пожалуйста как такой ответ выходит?

#include< ; stdio.

H> ; #include< ; conio.

H> ; int main() { int i = 0 ; int s = 0 ; while(i< ; 4) { s + = i ; i + + ; printf("%d", i) ; } getch() ; } что программа выводит на экран?

Ответ : 6.

Kristinaberestenko 3 окт. 2020 г., 07:16:51 | 5 - 9 классы

1. Написать функцию, которая вычисляет минимум из четырёх чисел?

1. Написать функцию, которая вычисляет минимум из четырёх чисел.

2. Написать функцию, которая вычисляет минимум из двух чисел.

В чём ошибка?

1. / / public static int min(int a, int b, int c, int d) {

int m4 ;

if ( a < ; b & ; & ; a < ; c & ; & ; a < ; d) m4 = a ;

else if (b < ; a & ; & ; b < ; c & ; & ; b < ; d)

m4 = b ;

else if (c < ; a & ; & ; c < ; b & ; & ; c < ; d)

m4 = c ;

else if (d < ; a & ; & ; d < ; b & ; & ; d < ; c)

m4 = d ;

else

m4 = 0 ;

System.

Out. println("Use different numbers") ;

return m4 ;

}

2.

/ / public static int min(int a, int b)

{

int m2 ; if (a < ; b)

m2 = a ;

else

m2 = b ;

return m2 ;

}.

Kiamovalina 21 окт. 2020 г., 18:41:46 | 10 - 11 классы

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i?

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i] ; cin > ; > ; m ; for (int i = 0 ; i < ; m ; i + + ) cin > ; > ; array_m[i] ; for (int i = 0 ; i < ; n ; i + + ) { int check = 1 ; for (int j = 0 ; j < ; m ; j + + ) if (array_n[i] = = array_m[j]) check = 0 ; if(check = = 1) cout < ; < ; array_n[i] < ; < ; " " ; } } сделать так чтобы числа которые будет выводить эта программа были отсортированы от большего к меньшему (С + + ).

Katusha3007 9 апр. 2020 г., 15:19:22 | 10 - 11 классы

Довольно глупый вопрос?

Довольно глупый вопрос.

Предположим я создаю mprog.

Cpp и там обращаюсь к функции через имеющийся prog.

H (#include "prog.

H"), сама функция лежит в prog.

Cpp. Выходит примерно вот что : = = = = = = = = = = = = = = = = prog.

Cpp = = = = = = = = = = = = = = #include "prog.

H" int prog (int num) { / * Функция.

* / } = = = = = = = = = prog.

H = = = = = = = = = = #ifndef prog #define prog int prog (int) ; #endif = = = = = = = mprog.

Cpp = = = = = #include < ; iostream> ; #include "prog.

H" int main () { int nFGA ; prog (nFGA) ; return 0 ; } Я так понимаю, ошибок нет и они связаны.

Как теперь это запустить?

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Полинка1547 12 дек. 2020 г., 05:06:46 | 5 - 9 классы

Умоляю , Пожалуйста ?

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

Yulduzikcom 12 дек. 2020 г., 04:28:21 | 10 - 11 классы

Задача по теме рандомиз и сранд :Составьте программу на языке С + + для решения одного из вариантов заданий?

Задача по теме рандомиз и сранд :

Составьте программу на языке С + + для решения одного из вариантов заданий.

Программа должна иметь пользовательское меню, которое позволяет : заполнить массив и при этом вывести его на экран, выполнить операции над массивом и просмотреть результаты, закрыть программу.

Вариант 6 : Одномерный массив из 16 элементов случайным образом заполняется целыми числами из диапазона [ - 240.

180].

Найти сумму четных отрицательных и сумму нечетных положительных элементов массива.

Начал писать :

#include

#include

#include

#include

#include

#include

int main (void)

{ int x[16] ; int t ; randomize() ; x = random(180) - 240 ; / / for (t = 0 ; t < 16 ; + + t) scanf("%d ", x[t]) ; for (t = 0 ; t < 16 ; + + t) printf("%d ", x[t]) ; return 0 ;

}

Пишет ошибку :

12 14 E : \ 1 Ó×ÅÁÀ \ 5ñåìåñòð \ ïðîãðàììû \ ïð4.

1. cpp [Error] 'randomize' was not declared in this scope

13 13 E : \ 1 Ó×ÅÁÀ \ 5ñåìåñòð \ ïðîãðàììû \ ïð4.

1. cpp [Error] 'random' was not declared in this scope

Не могу дальше этого места пройти.

Можно при помощи srand, если вам будет проще.

Dfcjhgv 17 дек. 2020 г., 12:19:52 | 10 - 11 классы

500 Internal Server Error как его исправить?

500 Internal Server Error как его исправить.

На этой странице сайта вы найдете ответы на вопрос Помогите изменить так, чтобы не было ошибки?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.