Объясните пожалуйста как такой ответ выходит?

Информатика | 10 - 11 классы

Объясните пожалуйста как такой ответ выходит?

#include< ; stdio.

H> ; #include< ; conio.

H> ; int main() { int i = 0 ; int s = 0 ; while(i< ; 4) { s + = i ; i + + ; printf("%d", i) ; } getch() ; } что программа выводит на экран?

Ответ : 6.

Ответить на вопрос
Ответы (1)
Parashakn62 28 окт. 2020 г., 19:50:13

С каждой итерацией цикла, кпеременной s прибавляется значение переменной i, которая увеличивается на 1, цикл идет, пока истинно условие i < ; 4, в итоге имеем :

s = 0 + 1 + 2 + 3 = 6.

Лё8а 5 нояб. 2020 г., 07:42:59 | 10 - 11 классы

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * )?

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * ).

84193135 11 июн. 2020 г., 00:41:12 | 10 - 11 классы

Язык С?

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Alfiya001 24 сент. 2020 г., 07:03:19 | 10 - 11 классы

Как преобразовать символ char в переменную int на языке с (не с + + )?

Как преобразовать символ char в переменную int на языке с (не с + + )?

Например char c ; int x ; чтобы 'c' = x ; Спасибо заранее.

Gaitobe 11 июн. 2020 г., 08:25:09 | 10 - 11 классы

Напишите программирование С#(си - шарп)?

Напишите программирование С#(си - шарп).

Составить программу возведения заданного числа в третью степень, имеющую следующую закономерность :

1³ = 1

2³ = 3 + 5

3³ = 7 + 9 + 11

4³ = 13 + 15 + 17 + 19

5³ = 21 + 23 + 25 + 27 + 29 Вот написала : using System ;

using System.

Collections.

Generic ;

using System.

Linq ;

using System.

Text ; namespace ConsoleApplication11

{

class Program { public int GetThird(int num)

{ int result = 0 ; int kv = num * num ; if (num % 2 = = 0) { for (int i = num / 2 ; i > ; 0 ; i - - ) { result + = kv - i * 2 + 1 ; } for (int i = 0 ; i < ; num / 2 ; i + + ) { result + = kv + i * 2 + 1 ; } } else { for (int i = (num - 1) / 2 ; i > ; 0 ; i - - ) { result + = kv - i * 2 ; } result + = kv ; for (int i = 0 ; i < ; (num - 1) / 2 ; i + + ) { result + = kv + i * 2 + 2 ; } } return result ; } static void Main(string[] args) { Console.

WriteLine("Введите натуральноe числo ") ; Console.

Write("result = ") ; int a = int.

Parse(Console.

ReadLine()) ; Console.

Write("c = ") ; int b = int.

Parse(Console.

ReadLine()) ; Console.

WriteLine("", b) ; Console.

Read() ; } }

} Исправьте ошибку.

Kiamovalina 21 окт. 2020 г., 18:41:46 | 10 - 11 классы

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i?

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i] ; cin > ; > ; m ; for (int i = 0 ; i < ; m ; i + + ) cin > ; > ; array_m[i] ; for (int i = 0 ; i < ; n ; i + + ) { int check = 1 ; for (int j = 0 ; j < ; m ; j + + ) if (array_n[i] = = array_m[j]) check = 0 ; if(check = = 1) cout < ; < ; array_n[i] < ; < ; " " ; } } сделать так чтобы числа которые будет выводить эта программа были отсортированы от большего к меньшему (С + + ).

Katusha3007 9 апр. 2020 г., 15:19:22 | 10 - 11 классы

Довольно глупый вопрос?

Довольно глупый вопрос.

Предположим я создаю mprog.

Cpp и там обращаюсь к функции через имеющийся prog.

H (#include "prog.

H"), сама функция лежит в prog.

Cpp. Выходит примерно вот что : = = = = = = = = = = = = = = = = prog.

Cpp = = = = = = = = = = = = = = #include "prog.

H" int prog (int num) { / * Функция.

* / } = = = = = = = = = prog.

H = = = = = = = = = = #ifndef prog #define prog int prog (int) ; #endif = = = = = = = mprog.

Cpp = = = = = #include < ; iostream> ; #include "prog.

H" int main () { int nFGA ; prog (nFGA) ; return 0 ; } Я так понимаю, ошибок нет и они связаны.

Как теперь это запустить?

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Полинка1547 12 дек. 2020 г., 05:06:46 | 5 - 9 классы

Умоляю , Пожалуйста ?

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

Dead2323123 21 дек. 2020 г., 23:49:36 | 5 - 9 классы

12. Определите, что будет напечатано в результате работы следующего фрагмента программы : #include int main(void){ int n, s ; n = 1 ; s = 0 ; while (n < ; = 101 ) { s = s + 7 ; n = n + 1 } printf(″%?

12. Определите, что будет напечатано в результате работы следующего фрагмента программы : #include int main(void){ int n, s ; n = 1 ; s = 0 ; while (n < ; = 101 ) { s = s + 7 ; n = n + 1 } printf(″%d″, s) ; }.

Maxbest228 27 дек. 2020 г., 03:26:26 | 5 - 9 классы

Помогите решить задачу :"Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3?

Помогите решить задачу :

"Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, оканчивающееся на 3.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число — максимальное число, оканчивающееся

на 3.

"

Вот то, что у меня получилось [Язык программирования C + + ] :

#include

#include

using namespace std ;

int main(){ int user_nums[1000] ; int first_stage[1000] ; int second_stage[1000] ; cout.

На этой странице находится вопрос Объясните пожалуйста как такой ответ выходит?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.