Умоляю , Пожалуйста ?

Информатика | 5 - 9 классы

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

Ответить на вопрос
Ответы (2)
Stepkucher 12 дек. 2020 г., 05:06:51

C + +

#include < ; iostream> ;

#include < ; cmath> ;

#include < ; stdio.

H> ;

using namespace std ;

int main() { int a, b, c, d, r, r2, r3 ;

cin > ; > ; a > ; > ; b > ; > ; c > ; > ; d ;

r = min(a, b) ;

r2 = min(r, c) ;

r3 = min(r2, d) ;

cout < ; < ; r3 ; return 0 ;

}

Pascal

program Project1 ;

var a, b, c, d : integer ;

begin

readln (a, b, c, d) ;

if ((a< ; = b) and (a< ; = c) and (a< ; = d)) then begin

writeln (a) ;

end

else if ((b< ; = a) and (b< ; = c) and (b< ; = d)) then begin

writeln (b) ;

end

else if ((c< ; = b) and (c< ; = a) and (c< ; = d)) then begin

writeln (c) ;

end

else begin

writeln (d) ;

end ;

end.

OlyaBlasova 12 дек. 2020 г., 05:06:53

Function min (a, b, c, d : integer) : integer ;

var m1, m2 : integer ;

begin

if a< ; b then m1 : = a else m1 : = b ;

if c< ; d then m2 : = c else m2 : = d ;

if m1< ; m2 then min : = m1 else min : = m2 ;

end ;

var a, b, c, d : integer ;

begin

writeln('Введите 4 числа : ') ;

readln(a, b, c, d) ;

writeln('min = ', min(a, b, c, d)) ;

end.

Пример :

Введите 4 числа :

5 8 3 6

min = 3.

Лё8а 5 нояб. 2020 г., 07:42:59 | 10 - 11 классы

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * )?

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * ).

84193135 11 июн. 2020 г., 00:41:12 | 10 - 11 классы

Язык С?

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Bogafan72 9 апр. 2020 г., 02:49:28 | 10 - 11 классы

Напишите функцию int reverse(int n) (C / C + + ), function reverse (n : integer) : integer (Pascal), которая переставляет цифры числа в обратном порядке ?

Напишите функцию int reverse(int n) (C / C + + ), function reverse (n : integer) : integer (Pascal), которая переставляет цифры числа в обратном порядке .

Формат входных данныхЗадано единственное числоФормат выходных данныхНеобходимо вывести цифры данного числа в обратном порядке.

Alfiya001 24 сент. 2020 г., 07:03:19 | 10 - 11 классы

Как преобразовать символ char в переменную int на языке с (не с + + )?

Как преобразовать символ char в переменную int на языке с (не с + + )?

Например char c ; int x ; чтобы 'c' = x ; Спасибо заранее.

Kristinaberestenko 3 окт. 2020 г., 07:16:51 | 5 - 9 классы

1. Написать функцию, которая вычисляет минимум из четырёх чисел?

1. Написать функцию, которая вычисляет минимум из четырёх чисел.

2. Написать функцию, которая вычисляет минимум из двух чисел.

В чём ошибка?

1. / / public static int min(int a, int b, int c, int d) {

int m4 ;

if ( a < ; b & ; & ; a < ; c & ; & ; a < ; d) m4 = a ;

else if (b < ; a & ; & ; b < ; c & ; & ; b < ; d)

m4 = b ;

else if (c < ; a & ; & ; c < ; b & ; & ; c < ; d)

m4 = c ;

else if (d < ; a & ; & ; d < ; b & ; & ; d < ; c)

m4 = d ;

else

m4 = 0 ;

System.

Out. println("Use different numbers") ;

return m4 ;

}

2.

/ / public static int min(int a, int b)

{

int m2 ; if (a < ; b)

m2 = a ;

else

m2 = b ;

return m2 ;

}.

TheDenJekov 31 янв. 2020 г., 07:20:19 | 10 - 11 классы

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false?

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false.

Задача в Visual Studio, язык c + +.

12345678910180 5 янв. 2020 г., 07:07:16 | 5 - 9 классы

Задача на языке ПаскаляДано натуральное число N?

Задача на языке Паскаля

Дано натуральное число N.

Напишите функцию int MinDigit (int n) (C / C + + ), function MinDigit (n : longint) : integer (Pascal) и int MaxDigit (int n) (C / C + + ), function MaxDigit (n : longint) : integer (Pascal), определяющую наименьшую и наибольшую цифры данного числа.

Формат входных данных

Задано единственное число

Формат выходных данных

Необходимо вывести наименьшую и наибольшую цифры данного числа через пробел.

Kiamovalina 21 окт. 2020 г., 18:41:46 | 10 - 11 классы

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i?

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i] ; cin > ; > ; m ; for (int i = 0 ; i < ; m ; i + + ) cin > ; > ; array_m[i] ; for (int i = 0 ; i < ; n ; i + + ) { int check = 1 ; for (int j = 0 ; j < ; m ; j + + ) if (array_n[i] = = array_m[j]) check = 0 ; if(check = = 1) cout < ; < ; array_n[i] < ; < ; " " ; } } сделать так чтобы числа которые будет выводить эта программа были отсортированы от большего к меньшему (С + + ).

Katusha3007 9 апр. 2020 г., 15:19:22 | 10 - 11 классы

Довольно глупый вопрос?

Довольно глупый вопрос.

Предположим я создаю mprog.

Cpp и там обращаюсь к функции через имеющийся prog.

H (#include "prog.

H"), сама функция лежит в prog.

Cpp. Выходит примерно вот что : = = = = = = = = = = = = = = = = prog.

Cpp = = = = = = = = = = = = = = #include "prog.

H" int prog (int num) { / * Функция.

* / } = = = = = = = = = prog.

H = = = = = = = = = = #ifndef prog #define prog int prog (int) ; #endif = = = = = = = mprog.

Cpp = = = = = #include < ; iostream> ; #include "prog.

H" int main () { int nFGA ; prog (nFGA) ; return 0 ; } Я так понимаю, ошибок нет и они связаны.

Как теперь это запустить?

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Вы находитесь на странице вопроса Умоляю , Пожалуйста ? из категории Информатика. Уровень сложности вопроса рассчитан на учащихся 5 - 9 классов. На странице можно узнать правильный ответ, сверить его со своим вариантом и обсудить возможные версии с другими пользователями сайта посредством обратной связи. Если ответ вызывает сомнения или покажется вам неполным, для проверки найдите ответы на аналогичные вопросы по теме в этой же категории, или создайте новый вопрос, используя ключевые слова: введите вопрос в поисковую строку, нажав кнопку в верхней части страницы.