Язык С?

Информатика | 10 - 11 классы

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Ответить на вопрос
Ответы (1)
Anastasiyabyko 11 июн. 2020 г., 00:41:14

#include "stdio.

H"

void main()

{ printf("int - %db \ n", sizeof(int)) ; printf("short int - %db \ n", sizeof(short int)) ; printf("long int - %db \ n", sizeof(long int)) ; printf("float - %db \ n", sizeof(float)) ; printf("double - %db \ n", sizeof(double)) ;

}.

Лё8а 5 нояб. 2020 г., 07:42:59 | 10 - 11 классы

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * )?

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * ).

Alfiya001 24 сент. 2020 г., 07:03:19 | 10 - 11 классы

Как преобразовать символ char в переменную int на языке с (не с + + )?

Как преобразовать символ char в переменную int на языке с (не с + + )?

Например char c ; int x ; чтобы 'c' = x ; Спасибо заранее.

Kristinaberestenko 3 окт. 2020 г., 07:16:51 | 5 - 9 классы

1. Написать функцию, которая вычисляет минимум из четырёх чисел?

1. Написать функцию, которая вычисляет минимум из четырёх чисел.

2. Написать функцию, которая вычисляет минимум из двух чисел.

В чём ошибка?

1. / / public static int min(int a, int b, int c, int d) {

int m4 ;

if ( a < ; b & ; & ; a < ; c & ; & ; a < ; d) m4 = a ;

else if (b < ; a & ; & ; b < ; c & ; & ; b < ; d)

m4 = b ;

else if (c < ; a & ; & ; c < ; b & ; & ; c < ; d)

m4 = c ;

else if (d < ; a & ; & ; d < ; b & ; & ; d < ; c)

m4 = d ;

else

m4 = 0 ;

System.

Out. println("Use different numbers") ;

return m4 ;

}

2.

/ / public static int min(int a, int b)

{

int m2 ; if (a < ; b)

m2 = a ;

else

m2 = b ;

return m2 ;

}.

TheDenJekov 31 янв. 2020 г., 07:20:19 | 10 - 11 классы

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false?

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false.

Задача в Visual Studio, язык c + +.

Бомбалейло 31 июл. 2020 г., 22:13:27 | 10 - 11 классы

Написать программы на языке С + +1) С клавиатуры вводится 2 числа - целое и вещественное?

Написать программы на языке С + +

1) С клавиатуры вводится 2 числа - целое и вещественное.

Программа выводит их сумму на экран.

2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран

3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом

4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов.

Nastya292929 26 янв. 2020 г., 03:44:26 | 10 - 11 классы

Int x [3] это это что такое (переменная целого типа, массив целых из трех элементов, функция, указатель на массив)?

Int x [3] это это что такое (переменная целого типа, массив целых из трех элементов, функция, указатель на массив).

Kiamovalina 21 окт. 2020 г., 18:41:46 | 10 - 11 классы

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i?

#include using namespace std ; int main() { const int size = 100 ; int array_n[size] ; int array_m[size] ; int n, m ; cin > ; > ; n ; for (int i = 0 ; i < ; n ; i + + ) cin > ; > ; array_n[i] ; cin > ; > ; m ; for (int i = 0 ; i < ; m ; i + + ) cin > ; > ; array_m[i] ; for (int i = 0 ; i < ; n ; i + + ) { int check = 1 ; for (int j = 0 ; j < ; m ; j + + ) if (array_n[i] = = array_m[j]) check = 0 ; if(check = = 1) cout < ; < ; array_n[i] < ; < ; " " ; } } сделать так чтобы числа которые будет выводить эта программа были отсортированы от большего к меньшему (С + + ).

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Полинка1547 12 дек. 2020 г., 05:06:46 | 5 - 9 классы

Умоляю , Пожалуйста ?

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

Maxbest228 27 дек. 2020 г., 03:26:26 | 5 - 9 классы

Помогите решить задачу :"Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3?

Помогите решить задачу :

"Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, оканчивающееся на 3.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число — максимальное число, оканчивающееся

на 3.

"

Вот то, что у меня получилось [Язык программирования C + + ] :

#include

#include

using namespace std ;

int main(){ int user_nums[1000] ; int first_stage[1000] ; int second_stage[1000] ; cout.

На этой странице сайта размещен вопрос Язык С? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 10 - 11 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.