1. Написать функцию, которая вычисляет минимум из четырёх чисел?

Информатика | 5 - 9 классы

1. Написать функцию, которая вычисляет минимум из четырёх чисел.

2. Написать функцию, которая вычисляет минимум из двух чисел.

В чём ошибка?

1. / / public static int min(int a, int b, int c, int d) {

int m4 ;

if ( a < ; b & ; & ; a < ; c & ; & ; a < ; d) m4 = a ;

else if (b < ; a & ; & ; b < ; c & ; & ; b < ; d)

m4 = b ;

else if (c < ; a & ; & ; c < ; b & ; & ; c < ; d)

m4 = c ;

else if (d < ; a & ; & ; d < ; b & ; & ; d < ; c)

m4 = d ;

else

m4 = 0 ;

System.

Out. println("Use different numbers") ;

return m4 ;

}

2.

/ / public static int min(int a, int b)

{

int m2 ; if (a < ; b)

m2 = a ;

else

m2 = b ;

return m2 ;

}.

Ответить на вопрос
Ответы (1)
Yuna96 3 окт. 2020 г., 07:16:53

Для нахождения минимума из четырёх чисел, можно использовать метод для нахождения минимума из двух чисел.

Таким образом код будет намного яснее и компактнее.

И вместо присваивания значения переменным m4 и m2 лучше сразу возвращать результат.

Static int min2(int a, int b)

{ if(a < ; b) { return a ; } else return b ;

}

static int min4(int a, int b, int c, int d)

{ return min2(min2(a, b), min2(c, d)) ;

}.

Vadya1996 18 сент. 2020 г., 03:20:05 | 10 - 11 классы

Упростить выражения : 1?

Упростить выражения : 1.

(A + B + C)& ; (неA& ; B& ; неС) 2.

(A + B)& ; (неB + A)& ; (неC + B) 3.

(1 + (A + B)) + ((A + C)& ; 1) 4.

(A& ; B& ; неC) + (A& ; B& ; C) + не(A + B) Повышенный уровень (A + B + C)& ; не(A + неB + C).

380999626039 24 дек. 2020 г., 12:42:37 | 10 - 11 классы

Помогите пожалуйста ?

Помогите пожалуйста !

Упростить 1)(A& ; B)v(A& ; неB) 2)(не A& ; B)v(A& ; B) 3)(AvB)& ; (не AvB) 4)(AvB)& ; (AvнеB).

Tanyu17 21 мар. 2020 г., 09:36:19 | 5 - 9 классы

Упростите логические выражения с учетом правильной последовательности выполнения логических операций : (A v ¬A) & ; B A & ; (A v B) & ; (C v ¬B) A & ; ¬B v B & ; C v ¬A & ; ¬B A v ¬A?

Упростите логические выражения с учетом правильной последовательности выполнения логических операций : (A v ¬A) & ; B A & ; (A v B) & ; (C v ¬B) A & ; ¬B v B & ; C v ¬A & ; ¬B A v ¬A & ;

Fefefefe220 15 сент. 2020 г., 09:38:49 | 5 - 9 классы

Построить таблицу истинности Обозначение операций : & ; (Логическое умножение) |(Логическое сложение) ~(Логическое отрицание) (B& ; C)& ; ~(A|B)& ; (A& ; B)?

Построить таблицу истинности Обозначение операций : & ; (Логическое умножение) |(Логическое сложение) ~(Логическое отрицание) (B& ; C)& ; ~(A|B)& ; (A& ; B).

Рат2002 25 сент. 2020 г., 09:21:08 | 10 - 11 классы

Упростите логические выражения 1) (A& ; B) v (ᾹvB) v (C& ; B) = 2) (A& ; B̅) v (A& ; B) v (A& ; C̅) = 3) (A& ; B) v (A& ; B̅) v (Ᾱ& ; C) =?

Упростите логические выражения 1) (A& ; B) v (ᾹvB) v (C& ; B) = 2) (A& ; B̅) v (A& ; B) v (A& ; C̅) = 3) (A& ; B) v (A& ; B̅) v (Ᾱ& ; C) =.

Mumberartem 13 мая 2020 г., 02:55:23 | 5 - 9 классы

! A& ; C& ; ?

! A& ; C& ; !

Bv! A& ; BvA& ; B нужно упростить.

Bokunovaoksana 26 янв. 2020 г., 11:05:42 | 10 - 11 классы

ГДЕ ОШИБКА В КОДЕ?

ГДЕ ОШИБКА В КОДЕ?

ЯЗЫК СИ.

#include #include int main() { system ("chcp 1251 > ; nul") ; printf(" \ n Условие : Напишите программу поиска максимального из четырех чисел с использованием функции поиска большего из двух.

") ; int a, b, c, d ; printf(" \ n \ t Введите 1 число - > ; ") ; scanf("%i", & ; a) ; printf(" \ n \ t Введите 2 число - > ; ") ; scanf("%i", & ; b) ; printf(" \ n \ t Введите 3 число - > ; ") ; scanf("%i", & ; c) ; printf(" \ n \ t Введите 4 число - > ; ") ; scanf("%i", & ; d) ; int chislo(int a, int b) {if (a> ; b) return a ; else return b ; } printf(chislo(chislo(chislo(a, b), c), d)) ; return 0 ; }.

Ytysmes 11 дек. 2020 г., 09:38:53 | 5 - 9 классы

Преобразовать логическое выражение, используя законы логики C& ; DvC& ; D& ; CvD?

Преобразовать логическое выражение, используя законы логики C& ; DvC& ; D& ; CvD.

Brrrrrr10 28 дек. 2020 г., 14:20:55 | 5 - 9 классы

Выбери верный ответ?

Выбери верный ответ.

C∨(D∨M) = C∨D∨M Z∨(D∧M) = Z∨D∨M S& ; (D& ; M) = S& ; D& ; M.

Pushkin2003 21 дек. 2020 г., 15:14:57 | 5 - 9 классы

Найди значение выражения 1& ; 1& ; 1& ; 1& ; 1& ; 1?

Найди значение выражения 1& ; 1& ; 1& ; 1& ; 1& ; 1.

Вопрос 1. Написать функцию, которая вычисляет минимум из четырёх чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.