Задача по теме рандомиз и сранд :Составьте программу на языке С + + для решения одного из вариантов заданий?

Информатика | 10 - 11 классы

Задача по теме рандомиз и сранд :

Составьте программу на языке С + + для решения одного из вариантов заданий.

Программа должна иметь пользовательское меню, которое позволяет : заполнить массив и при этом вывести его на экран, выполнить операции над массивом и просмотреть результаты, закрыть программу.

Вариант 6 : Одномерный массив из 16 элементов случайным образом заполняется целыми числами из диапазона [ - 240.

180].

Найти сумму четных отрицательных и сумму нечетных положительных элементов массива.

Начал писать :

#include

#include

#include

#include

#include

#include

int main (void)

{ int x[16] ; int t ; randomize() ; x = random(180) - 240 ; / / for (t = 0 ; t < 16 ; + + t) scanf("%d ", x[t]) ; for (t = 0 ; t < 16 ; + + t) printf("%d ", x[t]) ; return 0 ;

}

Пишет ошибку :

12 14 E : \ 1 Ó×ÅÁÀ \ 5ñåìåñòð \ ïðîãðàììû \ ïð4.

1. cpp [Error] 'randomize' was not declared in this scope

13 13 E : \ 1 Ó×ÅÁÀ \ 5ñåìåñòð \ ïðîãðàììû \ ïð4.

1. cpp [Error] 'random' was not declared in this scope

Не могу дальше этого места пройти.

Можно при помощи srand, если вам будет проще.

Ответить на вопрос
Ответы (1)
Lvova0682239764 12 дек. 2020 г., 04:28:25

/ / / / / / / / / / / / / / / / / / / / / / / / / / / / / /.

Koloverdova87 28 окт. 2020 г., 19:50:09 | 10 - 11 классы

Объясните пожалуйста как такой ответ выходит?

Объясните пожалуйста как такой ответ выходит?

#include< ; stdio.

H> ; #include< ; conio.

H> ; int main() { int i = 0 ; int s = 0 ; while(i< ; 4) { s + = i ; i + + ; printf("%d", i) ; } getch() ; } что программа выводит на экран?

Ответ : 6.

Lieraievsieiev 2 янв. 2020 г., 16:57:31 | 10 - 11 классы

Составить задачу в Паскале?

Составить задачу в Паскале.

Составьте программу вычисления суммы нечетных элементов одномерного массива А (Т).

Массив заполнить случайным образом.

Menshih5536 22 июн. 2020 г., 02:08:28 | 5 - 9 классы

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9]?

Напишите программу, которая случайным образом заполняет массив из 10 элементов целыми числами из диапазона [ - 6 ; 9].

И вывести все элементы массива на экран.

Anya8a 7 авг. 2020 г., 02:55:25 | 10 - 11 классы

Решите задачи : 1) Составьте программу ввода элементов массива [1?

Решите задачи : 1) Составьте программу ввода элементов массива [1.

8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями.

2) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с четными значениями.

3) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с четными значениями и количество элементов с нечетными значениями.

4) Составьте программу, которая заполняет массив а [1.

10] случайными целыми числами в диапазоне от 1 до 10, затем элементы с четными индексами удваивает, а элементы с нечетными индексами утраивает.

Выведите на экран исходный и полученный массивы.

Katusha3007 9 апр. 2020 г., 15:19:22 | 10 - 11 классы

Довольно глупый вопрос?

Довольно глупый вопрос.

Предположим я создаю mprog.

Cpp и там обращаюсь к функции через имеющийся prog.

H (#include "prog.

H"), сама функция лежит в prog.

Cpp. Выходит примерно вот что : = = = = = = = = = = = = = = = = prog.

Cpp = = = = = = = = = = = = = = #include "prog.

H" int prog (int num) { / * Функция.

* / } = = = = = = = = = prog.

H = = = = = = = = = = #ifndef prog #define prog int prog (int) ; #endif = = = = = = = mprog.

Cpp = = = = = #include < ; iostream> ; #include "prog.

H" int main () { int nFGA ; prog (nFGA) ; return 0 ; } Я так понимаю, ошибок нет и они связаны.

Как теперь это запустить?

Алекс111105 12 окт. 2020 г., 21:47:24 | 5 - 9 классы

Составьте программу, которая заполняет массив a[1?

Составьте программу, которая заполняет массив a[1.

8] случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями.

89132730587 18 нояб. 2020 г., 03:41:12 | 10 - 11 классы

Что не так в программе?

Что не так в программе?

Нужно вывести минимальный элемент, который есть в массиве.

С + +

#include

#include

#include

#include

#include

int main()

{

int a[5], i, min ;

srand (time(0)) ;

printf("a : \ n") ;

for (i = 0 ; i.

Anastasizi 24 сент. 2020 г., 17:33:03 | 10 - 11 классы

C + + Нужно создать одномерный массив A[5] где числа будут введены случайным образом от 0 до 1?

C + + Нужно создать одномерный массив A[5] где числа будут введены случайным образом от 0 до 1.

Я делал вот что у меня получается : #include #include #include using namespace std ; int main () { float A[5] = {} ; srand(time(NULL)) ; for (char i = 0 ; i< ; 5 ; i + + ) { A[i] = (char)rand()%1 ; cout< ; } return 0 ; } Проблема в том, что выводит только нули Помогите пожалуйста.

Maxbest228 27 дек. 2020 г., 03:26:26 | 5 - 9 классы

Помогите решить задачу :"Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3?

Помогите решить задачу :

"Напишите программу, которая в последовательности натуральных чисел определяет максимальное число, оканчивающееся на 3.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

В последовательности всегда имеется число, оканчивающееся на 3.

Количество чисел не превышает 1000.

Введённые числа не превышают 30 000.

Программа должна вывести одно число — максимальное число, оканчивающееся

на 3.

"

Вот то, что у меня получилось [Язык программирования C + + ] :

#include

#include

using namespace std ;

int main(){ int user_nums[1000] ; int first_stage[1000] ; int second_stage[1000] ; cout.

ВероничкаСуПеР1 13 дек. 2020 г., 06:44:30 | 10 - 11 классы

Помогите изменить так, чтобы не было ошибки?

Помогите изменить так, чтобы не было ошибки.

Прошу :

#include

int sum( int x, int y) ;

{ int s ; s = x + y ; return s ;

}

int main()

{ int x, y, z ; scanf("%d%d%d", &x, &y, &z) ; z = sum(100, 5) ; printf("%d", z) ;

}

.

Вот комментарий :

cpp : 3 : error : syntax error before `{' token

cpp : 5 : error : ISO C + + forbids declaration of `s' with no type

cpp : 5 : error : `x' was not declared in this scope

cpp : 5 : error : `y' was not declared in this scope

cpp : 6 : error : syntax error before `return'.

На этой странице находится вопрос Задача по теме рандомиз и сранд :Составьте программу на языке С + + для решения одного из вариантов заданий?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.