Задача : с клавиатуры вводится число от 1 до 1000?

Информатика | 10 - 11 классы

Задача : с клавиатуры вводится число от 1 до 1000.

Программа должна вывести его прописью.

(Написать программу на Паскале).

Ответить на вопрос
Ответы (2)
Egizbaevaadela 10 авг. 2021 г., 20:20:17

Program n1 ;

var m, n : integer ; ms : array[1.

9] of string ; md : array[1.

9] of string ; m1 : array[11.

19] of string ; me : array[1.

9] of string ; flag : boolean ;

begin

flag : = false ; ms[1] : = 'сто' ; ms[2] : = 'двести' ; ms[3] : = 'триста' ; ms[4] : = 'Четыреста' ; ms[5] : = 'пятьсот' ; ms[5] : = 'пятьсот' ; ms[6] : = 'шестьсот' ; ms[7] : = 'семьсот' ; ms[8] : = 'восемьсот' ; ms[9] : = 'девятьсот' ; md[1] : = 'десять' ; md[2] : = 'двадцать' ; md[3] : = 'тридцать' ; md[4] : = 'сорок' ; md[5] : = 'пятьдесят' ; md[6] : = 'шестьдесят' ; md[7] : = 'семьдесят' ; md[8] : = 'восемьдесят' ; md[9] : = 'девяносто' ; m1[11] : = 'одиннадцать' ; m1[12] : = 'двенадцать' ; m1[13] : = 'тринадцать' ; m1[14] : = 'четырнадцать' ; m1[15] : = 'пятнадцать' ; m1[16] : = 'шестнадцать' ; m1[17] : = 'семнадцать' ; m1[18] : = 'восемнадцать' ; m1[19] : = 'девятнадцать' ; me[1] : = 'один' ; me[2] : = 'два' ; me[3] : = 'три' ; me[4] : = 'четыре' ; me[5] : = 'пять' ; me[6] : = 'шесть' ; me[7] : = 'семь' ; me[8] : = 'восемь' ; me[9] : = 'девять' ; write('введите число : ') ; readln(m) ; if (m < 1) or (m > 1000) then writeln('число не входит в заданный интервал') else if m = 1000 then writeln('одна тысяча ') else begin n : = m div 100 ; if n > 0 then begin write(ms[n]) ; flag : = true end ; m : = m mod 100 ; if m = 0 then writeln(' ') else begin if (m > 10) and (m < 20) then begin if flag then write(' ') ; writeln(m1[m]) end else if m > 0 then begin n : = m mod 10 ; m : = m div 10 ; if m > 0 then begin if flag then write(' ') else flag : = true ; Write(md[m]) end ; if n 0 then begin if flag then write(' ') ; write(me[n]) ; end end end end

end.

Сузыкпаевадана 10 авг. 2021 г., 20:20:19

{ - }

const

ch_1 : array[1.

19] of string = ('один', 'два', 'три', 'четыре', 'пять', 'шесть', 'семь', 'восемь', 'девять', 'десять', 'одиннадцать', 'двенадцать', 'тринадцать', 'четырнадцать', 'пятнадцать', 'шестнадцать', 'семнадцать', 'восемнадцать', 'девятнадцать') ;

ch_2 : array [2.

9] of string = ('двадцать', 'тридцать', 'сорок', 'пятьдесят', 'шестьдесят', 'семьдесят', 'восемьдесят', 'девяносто') ;

ch_3 : array [1.

9] of string = ('сто', 'двести', 'триста', 'четыреста', 'пятьсот', 'шестьсот', 'семьсот', 'восемьсот', 'девятьсот') ;

var

n : 0.

1000 ;

begin

repeat

write ('Введите натуральное число, меньшее 1000 : ') ;

readln (n) ;

until n in [1.

999] ;

if n in [100.

999] then write (ch_3[n div 100], ' ') ; if (n mod 100) in [20.

99] then begin write (ch_2[(n mod 100)div 10], ' ') ; if (n mod 10) 0 then write (ch_1[n mod 10]) ; end else if (n mod 100) 0 then write (ch_1[n mod 100]) ;

end.

Karinochka98 1 янв. 2021 г., 20:55:50 | 5 - 9 классы

Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел?

Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел.

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ!

Kolomietsjulia 15 мар. 2021 г., 01:14:00 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Пользователь вводит с клавиатуры число n и программа выдает два числа, сложив которые можно получить это число n.

Нужна полностью вся программа.

ПомогимнеPomogi 29 авг. 2021 г., 13:20:54 | 5 - 9 классы

ПАСКАЛЬ?

ПАСКАЛЬ.

Пользователь вводит с клавиатуры трехзначное число.

Программа должна разбить число по разрядам и вывести в обратном порядке.

(исп.

Функции mod и div).

Полное решение.

Diman17114 29 мая 2021 г., 11:10:09 | 5 - 9 классы

Напишите программу, которая вводит трехзначное число и разбивает его на цифры?

Напишите программу, которая вводит трехзначное число и разбивает его на цифры.

Например, при вводе числа 123 программа должна вывести “1 2 3” (Python).

SofaKo18 30 авг. 2021 г., 22:35:10 | 10 - 11 классы

Вводится десятичное число?

Вводится десятичное число.

Написать программу, которая вычесляет количество десятков и единиц в вводимом числе.

Программа должна вывести на экран сообщение : "в числе десятков = , в числе единиц = ".

Аааа10пвп 6 июл. 2021 г., 23:14:00 | 10 - 11 классы

Вводится десятичное число?

Вводится десятичное число.

Написать программу, которая вычесляет количество десятков и единиц в вводимом числе.

Программа должна вывести на экран сообщение : "в числе десятков = , в числе единиц = ".

Акерке37 7 сент. 2021 г., 16:22:30 | 10 - 11 классы

Написать программу в паскале "даны три числа, вывести большее из них?

Написать программу в паскале "даны три числа, вывести большее из них.

Andreyvorobey1 14 сент. 2021 г., 18:21:31 | 10 - 11 классы

Написать программу в паскале " даны три числа, вывести большее из них"?

Написать программу в паскале " даны три числа, вывести большее из них".

Адскийпес2 22 мая 2021 г., 17:52:48 | 5 - 9 классы

Написать программу удвоения меньшего из двух чисел (числа вводятся с клавиатуры)?

Написать программу удвоения меньшего из двух чисел (числа вводятся с клавиатуры).

OlgaKomarovskaya 21 авг. 2021 г., 11:39:56 | 5 - 9 классы

Написать программу в Паскаль для решения задачи :Найти модуль числа a при условии, что само число a вводится с клавиатуры?

Написать программу в Паскаль для решения задачи :

Найти модуль числа a при условии, что само число a вводится с клавиатуры.

На этой странице находится вопрос Задача : с клавиатуры вводится число от 1 до 1000?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.