Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел?

Информатика | 5 - 9 классы

Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел.

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ!

Ответить на вопрос
Ответы (2)
Ganstagusyoerdusy 1 янв. 2021 г., 20:55:53

Var a, s, i : integer ;

begin

s : = 0 ;

writeln('Введите 10 чисел') ;

for i : = 1 to 10 do

begin

read(a) ;

if a mod 2 = 0 then s : = s + a ;

end ;

writeln('s = ', s) ;

end.

Пример :

Введите 10 чисел

12 45 94 35 20 17 31 57 71 82

s = 208.

N1i2k3e4 1 янв. 2021 г., 20:55:56

#include

int main(){ int result = 0 ; for (int i = 0 ; i < 11 ; i + + ) { std : : cin >> i ; result + = ((i % 2) = = 0) ?

I : 0 ; } std : : cout.

Pahan1312 18 янв. 2021 г., 20:32:48 | 5 - 9 классы

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем?

Программа получает на вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается нулем.

(a = 0 признак окончания ввода , ноль не входит в последовательность).

Программа должна вывести количество и сумму всех чисел последовательности.

0000Neznaika11111111 11 июн. 2021 г., 07:27:40 | 5 - 9 классы

Написать программу которая в последовательности натуральных чисел определяет максимальное число кратно 6?

Написать программу которая в последовательности натуральных чисел определяет максимальное число кратно 6.

Программа получает на вход количество чисел в последовательности а затем сами числа.

Программа должна вывести сумму всех чисел.

Помогите пожалуйста))))И если не трудно то и еще и проверку напишите пожалуйста))).

418269 9 янв. 2021 г., 05:16:24 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5?

Напишите программу, которая в последовательности целых чисел определяет их сумму и количество четных чисел, кратных 5.

Программа получает на вход целые числа, количество введенных чисел неизвестно, последователньость чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность)

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30 000.

Программа должна вывести два числа : сумму последовательности и количество четных чисел, кратных 5.

Пример работы программы :

Входные данные :

4

60

15

0

Выходные данные :

79

1.

Wein1243 24 мар. 2021 г., 10:13:26 | 5 - 9 классы

Напишите программуОпределить кол - во и сумму четных чисел ?

Напишите программу

Определить кол - во и сумму четных чисел .

Последовательность чисел оканчивантся 0.

Программа должна вывести 2 числа , первое : длину, последовательность , второе число : сумму четных чисел

Числа при вводе 4, 60, 15, 0.

Nastya031836 17 окт. 2021 г., 11:41:23 | 5 - 9 классы

Написать программу, которая вычисляет сумму первых n целых положительных четных чисел?

Написать программу, которая вычисляет сумму первых n целых положительных четных чисел.

Количество суммируемых чисел должно вводится во время работы программы.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - Ниже приведен рекомендуемый вид экрана во время работы программы.

Вычисление суммы четных положительных чисел.

Введите количество суммируемых чисел и нажмите - > 12 Сумма первых 12 положительных четных чисел равна 156.

PokemonYouTube 18 авг. 2021 г., 16:12:33 | 5 - 9 классы

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел?

Напишите программу, которая в последовательности целых чисел определяет их количество и сумму четных чисел.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введённые числа по модулю не превышают 30000.

Программа должна вывести два числа : длину последовательности и сумму чётных чисел.

Eotova 24 окт. 2021 г., 16:34:30 | 10 - 11 классы

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел , кратных 9, их сумму и среднее значение по модулю?

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел , кратных 9, их сумму и среднее значение по модулю.

Программа получает на вход целые числа, колличество введнных чисел неизвестно, последовательность чисел заканчиваеться числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30 000.

Программа должна вывести : количество четных чисел, кратных 9, их сумму и среднее значение по модулю.

Kirill221102 24 дек. 2021 г., 17:04:58 | 10 - 11 классы

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3?

Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3.

Программа получает на вход целые числа.

Количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входит в последовательность).

Количество чисел не превышает 1000.

Введенные числа по модулю не превышают 30000.

Программа должна вывести одно число : количество четных чисел, кратных 3.

КатяМай1 29 сент. 2021 г., 12:19:26 | 5 - 9 классы

Вводится натуральное число, не превышающее 1 млрд?

Вводится натуральное число, не превышающее 1 млрд.

Вывести количество четных чисел.

Программа на Pascal.

MrDrosh111 29 авг. 2021 г., 19:10:11 | 5 - 9 классы

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1?

Напишите программу которая в последовательности натуральных чисел определяет сумму всех чисел кратных 7 и оканчивающихся на 1.

Программа получает вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0(0 - признак окончания ввода не входит в последовательность).

Программа должна вывести одно число : сумму всех чисел кратных 7 и оканчивающихся на 1.

Перед вами страница с вопросом Вводится последовательность 10 чисел, программа должна вывести сумму всех четных чисел?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.