Дано натуральное число?

Информатика | 5 - 9 классы

Дано натуральное число.

Определить является ли оно палиндромом.

Написать процедуру получения нового числа.

Паскаль.

Ответить на вопрос
Ответы (2)
Lanadanielyan 25 окт. 2020 г., 13:47:12

Var n, m : integer ;

procedure inverse(a : integer ; var b : integer) ;

begin

b : = 0 ;

while a>0 do

begin

b : = b * 10 + a mod 10 ;

a : = a div 10 ;

end ;

end ;

begin

write('n = ') ;

readln(n) ;

inverse(n, m) ;

if n = m

then writeln('Число - палиндром')

else writeln('Число - не палиндром') ;

end.

Пример :

n = 123321

Число - палиндром.

Artem99999123 25 окт. 2020 г., 13:47:19

Procedure inverse(var a : integer) ;

var i, k : integer ;

begin k : = a ; i : = 0 ; while k>0 do begin i : = i + (k mod 10) ; k : = k div 10 ; if k>0 then i : = i * 10 ; end ; a : = i ;

end ; / / основная программа

var k, n : integer ;

begin write('число : ') ; readln(n) ; k : = n ; inverse(n) ; if k = n then writeln('палиндром') else writeln('не палиндром') ;

end.

Число : 123456754

не палиндром

число : 456898654

палиндром.

Elena1986502 2 июл. 2020 г., 02:58:22 | 5 - 9 классы

Дано число А?

Дано число А.

Определить, является ли оно простым (простое это натуральное число имеющие ровно два различных натуральных делителя : пшеницы и само себя).

Zhuzhechko 28 авг. 2020 г., 06:24:19 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Определить каких цифр в данном числе больше четных или нечетных.

Через Паскаль.

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Ainura20005 28 июл. 2020 г., 12:21:19 | 5 - 9 классы

Программа на языке паскаль?

Программа на языке паскаль.

Дано натуральное N .

Определить, является ли оно простым.

Polyagrig 9 февр. 2020 г., 09:02:45 | 5 - 9 классы

Дано четырехзначное натуральное число?

Дано четырехзначное натуральное число.

Определить является ли сумма первой и последней цифр кратной 3 Паскаль.

Соня183 11 янв. 2020 г., 21:06:13 | 10 - 11 классы

Даны три натуральных числа, являющиеся длинами сторон треугольника?

Даны три натуральных числа, являющиеся длинами сторон треугольника.

Число ввести с клавиатуры.

Определить является ли треугольник прямоугольным, если эти отрезки позволяют его построить.

Написать программу на паскале только на паскале и не на другом языке!

CоNя 6 апр. 2020 г., 17:05:49 | 5 - 9 классы

Дано число?

Дано число.

Определить является ли оно простым.

Программа на паскале.

Напишите через while ИЛИ repeat.

Заранее спасибо).

Ryazanceva0303 28 мая 2020 г., 19:24:24 | 5 - 9 классы

Дано натуральное число ?

Дано натуральное число .

Определить есть ли в нем цифра а Написать с постусловием язык Паскаля !

IrShokkkalkolcha 4 мая 2020 г., 04:31:41 | 1 - 4 классы

Помогите : как Определить, является ли введенное число палиндромом?

Помогите : как Определить, является ли введенное число палиндромом?

Lerchik1204 3 нояб. 2020 г., 02:25:45 | 10 - 11 классы

Дано натуральное число?

Дано натуральное число.

Найти максимальную цифру.

В паскале.

Через процедуры.

На этой странице сайта, в категории Информатика размещен ответ на вопрос Дано натуральное число?. По уровню сложности вопрос рассчитан на учащихся 5 - 9 классов. Чтобы получить дополнительную информацию по интересующей теме, воспользуйтесь автоматическим поиском в этой же категории, чтобы ознакомиться с ответами на похожие вопросы. В верхней части страницы расположена кнопка, с помощью которой можно сформулировать новый вопрос, который наиболее полно отвечает критериям поиска. Удобный интерфейс позволяет обсудить интересующую тему с посетителями в комментариях.