Дан двумерный массив целых чисел?

Информатика | 5 - 9 классы

Дан двумерный массив целых чисел.

Определить сколько раз встречается в каждой строке минимальный элемент, вывести сообщения.

(Паскаль).

Ответить на вопрос
Ответы (1)
Nvs13 19 апр. 2020 г., 09:36:18

КОД в Turbo Pascal

USES CRT ;

VAR A : array[1.

5, 1.

5] of integer ; i, j, min, s : integer ;

BEGIN

CLRSCR ;

Randomize ;

{заполняем массив случайными числами от 0 до 10}

for i : = 1 to 5 do for j : = 1 to 5 do A[i, j] : = random(10) ;

{Выводим массив на экран}

for i : = 1 to 5 do begin for j : = 1 to 5 do Write(A[i, j] : 2, ' ') ; Writeln ; end ;

min : = A[1, 1] ; {Присваиваемминимальному значению первый элемент массива}

{Ищем минимальный элемент в массиве}

for i : = 1 to 5 do for j : = 1 to 5 do if A[i, j]< ; min then min : = A[i, j] ;

Writeln('Минимальный элемент в данном массиве = ', min) ;

{Обнуляем счетчик}

s : = 0 ;

{Считаем сколько минимальных элементов в каждой строке и выводим на экран}

for i : = 1 to 5 do begin for j : = 1 to 5 do if A[i, j] = min then s : = s + 1 ; Writeln('В ', i, ' строке минимальный элемент встечается ', s, ' раз') ; s : = 0 ;

end ;

READLN ;

END.

Lera184567 21 февр. 2020 г., 13:53:50 | 10 - 11 классы

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ?

ТЕМА : ОБРАБОТКА ДВУМЕРНЫХ МАССИВОВ.

ПО ПАСКАЛЬ!

Задание : Дан двумерный массив А состоящий из 4 строк и 5 столбцов .

Найти, сколько положительных элементов содержит данная матрица в каждом столбце.

Judgefrog 11 нояб. 2020 г., 21:58:18 | 10 - 11 классы

Дан двумерный массив a, размером (n´m)?

Дан двумерный массив a, размером (n´m).

Найти минимальный элемент в каждой строке матрицы среди отри­цательных элементов.

Cdtnf07061985 21 янв. 2020 г., 07:30:41 | 10 - 11 классы

Дан двумерный массив 7Х5?

Дан двумерный массив 7Х5.

Найти сумму отрицательных элементов в каждом столбце.

Определить минимальный элмент в 1 - й строке( значение и координаты).

Koshak109 23 сент. 2020 г., 21:31:22 | 10 - 11 классы

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс?

Паскаль абс написать программу вычисления произведения положительных элементов третьей строки двумерного массива целых чисел паскаль абс.

PLEIX 7 февр. 2020 г., 05:27:54 | 5 - 9 классы

Дан двумерный массив?

Дан двумерный массив.

В каждой четной строке определить и вывести количество положительных элементов.

Rakhuba1981 29 апр. 2020 г., 00:46:34 | 5 - 9 классы

Дан целочисленный двумерный массив 6x10?

Дан целочисленный двумерный массив 6x10.

Опишите на русском языке и на языке программирования Паскаль алгоритм вычисления произведения минимальных элементов из каждой строки.

Напечатать значение этого произведения.

Предполагается, что в каждой строке минимальный элемент единственный.

Lizagacenko 27 окт. 2020 г., 19:57:22 | 10 - 11 классы

Помоги пожалуйста?

Помоги пожалуйста!

: * дан двумерный массив вывести на экран все элементы n - й строки массива паскаль.

Sona13950 20 мая 2020 г., 00:30:12 | 5 - 9 классы

(Паскаль) Дан массив вещественных чисел?

(Паскаль) Дан массив вещественных чисел.

Вывести минимальное положительное число.

Катерина706 18 янв. 2020 г., 03:57:13 | 5 - 9 классы

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки.

(паскаль).

Jador1 26 сент. 2020 г., 10:03:20 | 10 - 11 классы

Двумерные массивы?

Двумерные массивы.

Дан двумерный массив чисел.

Первый нечетный элемент каждой строки удвоить (предполагается, что в каждой строке есть нечетный элемент).

На странице вопроса Дан двумерный массив целых чисел? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.