Дан целочисленный двумерный массив 6x10?

Информатика | 5 - 9 классы

Дан целочисленный двумерный массив 6x10.

Опишите на русском языке и на языке программирования Паскаль алгоритм вычисления произведения минимальных элементов из каждой строки.

Напечатать значение этого произведения.

Предполагается, что в каждой строке минимальный элемент единственный.

Ответить на вопрос
Ответы (1)
Kap311 29 апр. 2020 г., 00:46:38

Ну в общих чертах проходиться по каждой строке массива, находить минимальный элемент и на него домножать результат.

Uses crt ;

const n = 6 ; m = 10 ;

var i, j, min, ans : integer ;

a : array[1.

N, 1.

M] of integer ;

begin

ans : = 1 ;

for i : = 1 to n do

begin

for j : = 1 to m do

begin

a[i, j] : = random(1, 20) ;

write(a[i, j] : 3) ;

end ;

writeln ;

end ;

for i : = 1 to n do

begin

min : = a[i, 1] ;

for j : = 2 to m do

if a[i, j]< ; min then

min : = a[i, j] ;

ans : = ans * min ;

end ;

writeln(ans) ;

end.

Nshinshina 29 июн. 2020 г., 05:29:08 | 10 - 11 классы

Определить минимальный элемент двумерного массива?

Определить минимальный элемент двумерного массива.

Напечатать номер строки, содержащей максимальное число минимальных элементов, если такие имеются ; ).

Maxim12003 28 мая 2020 г., 13:08:15 | 5 - 9 классы

Дан целочисленный массив из 40 элементов?

Дан целочисленный массив из 40 элементов.

Элементы массива могут принимать произвольные значения.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит и выводит номер элемента массива, наименее отличающегося от среднего арифметического всех его элементов.

Но лучше на языке Паскаль.

Nastea23 16 июл. 2020 г., 03:52:46 | 10 - 11 классы

Дан двухмерный массив , в каждой его строке найти минимальный элемент?

Дан двухмерный массив , в каждой его строке найти минимальный элемент.

Лида382 19 апр. 2020 г., 09:36:13 | 5 - 9 классы

Дан двумерный массив целых чисел?

Дан двумерный массив целых чисел.

Определить сколько раз встречается в каждой строке минимальный элемент, вывести сообщения.

(Паскаль).

Judgefrog 11 нояб. 2020 г., 21:58:18 | 10 - 11 классы

Дан двумерный массив a, размером (n´m)?

Дан двумерный массив a, размером (n´m).

Найти минимальный элемент в каждой строке матрицы среди отри­цательных элементов.

Kretininpavel 1 авг. 2020 г., 20:43:07 | 5 - 9 классы

Дан целочисленный прямоугольный массив 6x10?

Дан целочисленный прямоугольный массив 6x10.

Опишите в программе "ПаскальАВС" алгоритм вычисления суммы минимальных элементов из каждой строки.

Напечатать значение этой суммы.

Предполагается, что в каждой строке минимальный элемент единственный.

Dianasmirnova 29 мая 2020 г., 16:47:09 | 10 - 11 классы

2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000?

2) Дан целочисленный массив из 20 элементов, все элементы которого – целые числа в интервале от - 1000 до 1000.

Опишите на русском языке или на одном из языков программирования алгоритм, который находит минимальное значение из всех нечетных элементов массива, которые делятся на 5.

Nike0Adidas 27 июл. 2020 г., 04:38:31 | 10 - 11 классы

Дан прямоугольный массив целых положительных чисел 10 х 20?

Дан прямоугольный массив целых положительных чисел 10 х 20.

Опишите на русском языке или на одном из языков программирования алгоритм поиска строки с наименьшей суммой элементов.

Вывести на печать номер строки и сумму ее элементов.

Предполагается, что такая строка единственна.

Помогите пожалуйста составить программу в Паскале!

Jador1 26 сент. 2020 г., 10:03:20 | 10 - 11 классы

Двумерные массивы?

Двумерные массивы.

Дан двумерный массив чисел.

Первый нечетный элемент каждой строки удвоить (предполагается, что в каждой строке есть нечетный элемент).

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

На этой странице находится ответ на вопрос Дан целочисленный двумерный массив 6x10?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.