Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?

Информатика | 5 - 9 классы

Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки.

(паскаль).

Ответить на вопрос
Ответы (1)
Starwarrior1324 18 янв. 2020 г., 03:57:14

Const n = 5 ; m = 5 ;

var a : array[1.

N, 1.

M] of integer ;

i, j, s : integer ;

begin / / Для теста заполним массив сл.

Числами for i : = 1 to n do begin for j : = 1 to m do begin a[i, j] : = random(21) - 10 ; write(a[i, j] : 4) ; end ; writeln ; writeln ; end ; / / сумма всех элементов массива for i : = 1 to n do for j : = 1 to m do s : = s + a[i, j] ;

writeln('сумма всех элементов массива : ', s) ; / / сумма каждой строки

for i : = 1 to n do begin s : = 0 ; for j : = 1 to m do begin s : = s + a[i, j] ; end ; writeln ('Строка : ', i, ' сумма : ', s) ; end ;

end.

Hjfjr 9 дек. 2020 г., 12:11:41 | 10 - 11 классы

Пожалуйста, помогите составить программу в паскале :Для заданного двумерного массива подсчитать сумму элементов в каждой строке?

Пожалуйста, помогите составить программу в паскале :

Для заданного двумерного массива подсчитать сумму элементов в каждой строке.

Сформировать одномерный массив и вывести в нем эти суммы по возрастанию.

Marsovin 7 февр. 2020 г., 08:25:25 | 10 - 11 классы

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел?

Паскаль, составьте программу для двумерного массива : Найти произведение отрицательных элементов указанной строки двумерного массива размером 4 * 5 целых чисел.

Kateprincess 17 февр. 2020 г., 13:34:20 | 5 - 9 классы

1. Нахождение наибольшего элемента главной диагонали?

1. Нахождение наибольшего элемента главной диагонали.

(Паскаль, двумерные массивы ) 2.

Нахождение наименьших элементов в столбцах массива.

(Паскаль, двумерные массивы ).

Lizagacenko 27 окт. 2020 г., 19:57:22 | 10 - 11 классы

Помоги пожалуйста?

Помоги пожалуйста!

: * дан двумерный массив вывести на экран все элементы n - й строки массива паскаль.

Starushka78 21 апр. 2020 г., 19:03:34 | 5 - 9 классы

Надо сделать в паскале Дан двумерный массив 12 элементов?

Надо сделать в паскале Дан двумерный массив 12 элементов.

Заполните массив с клавиатуры вещественными числами(по запросы каждого элемента).

Вычислите сумму элементов данного массива.

Выведите это число на экран.

Dallas333 22 сент. 2020 г., 14:24:14 | 10 - 11 классы

Составить программу на определение суммы элементов массива( одномерный двумерный)?

Составить программу на определение суммы элементов массива( одномерный двумерный).

Jador1 26 сент. 2020 г., 10:03:20 | 10 - 11 классы

Двумерные массивы?

Двумерные массивы.

Дан двумерный массив чисел.

Первый нечетный элемент каждой строки удвоить (предполагается, что в каждой строке есть нечетный элемент).

Linochk552 1 окт. 2020 г., 20:41:06 | 5 - 9 классы

Найти наибольшее значение элементов двумерного массива паскаль?

Найти наибольшее значение элементов двумерного массива паскаль.

Vasyapupkin201 2 июл. 2020 г., 19:43:53 | 5 - 9 классы

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран?

Написать программу вычисления суммы минимальных элементов каждой строки в массиве (6х10) и вывести эту сумму на экран.

Язык Паскаль.

Сладкая897 20 авг. 2020 г., 06:33:45 | 10 - 11 классы

Помогите пожалуйста решить задачи 1?

Помогите пожалуйста решить задачи 1.

Найти сумму элементов двумерного массива у которых номер строки не четный 2.

Вывести на экран элементы двумерного массива у которых n столбца нечетный.

Перед вами страница с вопросом Найдите сумму всех элементов двумерного массива и сумму элементов каждой строки?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 5 - 9 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.