10. 45 Даны первый член и разность арифметическое прогрессии?

Информатика | 5 - 9 классы

10. 45 Даны первый член и разность арифметическое прогрессии.

Написать рекурсивную функцию для нахождения а) n - ого члена прогрессии.

Б) суммы первых n членов прогрессии.

Ответить на вопрос
Ответы (1)
AA12345678 15 дек. 2020 г., 01:33:38

Var a, b : real ; n : integer ;

function arif_mem(a, b : real ; n : integer) : real ;

begin if n = 1 then arif_mem : = a ; if n > ; 1 then arif_mem : = arif_mem(a, b, n - 1) + b ;

end ;

function arif_sum(a, b : real ; n : integer) : real ;

begin if n = 1 then arif_sum : = a ; if n > ; 1 then arif_sum : = arif_sum(a, b, n - 1) + arif_mem(a, b, n) ;

end ;

begin write('введите первый член прогрессии : ') ; readln(a) ; write('введите разность прогрессии : ') ; readln(b) ; write('введите номер члена прогрессии : ') ; readln(n) ; writeln(n, ' - й член прогрессии равен : ', arif_mem(a, b, n) : 8 : 2) ; writeln('сумма ', n, ' членов прогрессии равна : ', arif_sum(a, b, n) : 8 : 2) ;

end.

Kate2005 9 мар. 2020 г., 03:13:55 | 5 - 9 классы

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии?

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии.

K1134fff 1 апр. 2020 г., 03:46:51 | 5 - 9 классы

Вычислить сумму и произведение N членов арифметической прогрессии 2, 5, 8, 11, …?

Вычислить сумму и произведение N членов арифметической прогрессии 2, 5, 8, 11, ….

Stapok12345 31 июл. 2020 г., 01:21:40 | 5 - 9 классы

Задача в паскале абс{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм?

Задача в паскале абс

{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм.

Прогрессии и n - число членов прогрессии вывести на экран n первых членов прогрессии например a = 4

d = 2

n = 5

4 6 8 10 12 14}.

Manehovhannisy 23 сент. 2020 г., 09:05:56 | 10 - 11 классы

Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов?

Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов.

Вывести на экран все члены геом.

Прогрессии и их среднее арифметическое (в паскале).

Pashasid 19 сент. 2020 г., 13:54:29 | 5 - 9 классы

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии?

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии.

Foretaste 22 февр. 2020 г., 11:40:38 | 10 - 11 классы

Составить программу : Получить первые k членов арифметической прогрессии с первым членом, равным сорока , и разностью минус 5?

Составить программу : Получить первые k членов арифметической прогрессии с первым членом, равным сорока , и разностью минус 5.

Оксаночка007 23 сент. 2020 г., 23:20:52 | 10 - 11 классы

Найти сумму n членов арифметической прогрессии, первый член которой равен а, а разность равна q?

Найти сумму n членов арифметической прогрессии, первый член которой равен а, а разность равна q.

Найти третий, тринадцатый и двадцать третий члены прогрессии.

Nataliaprytova 11 мар. 2020 г., 12:25:12 | 10 - 11 классы

Найдите 1543 - й член арифметической прогрессии, если её нулевой член равен 179, а шаг — 2007?

Найдите 1543 - й член арифметической прогрессии, если её нулевой член равен 179, а шаг — 2007.

Никитина111 2 июл. 2020 г., 21:42:59 | 5 - 9 классы

Дана арифметическая прогрессии 2, 6, 10, 14?

Дана арифметическая прогрессии 2, 6, 10, 14.

Записать пронрамму опрлеления номера первого члена прогрессии, превысившего заданное число В.

Вывести искомый номер и все члены прогрессии.

МашkaMilashka 5 февр. 2020 г., 17:39:07 | 5 - 9 классы

Паскаль?

Паскаль.

Составьте программу вычисления суммы 150 первых членов арифметической прогрессии, если a1 = –200 ; d = 0, 2.

( с помощью repeat).

Вы перешли к вопросу 10. 45 Даны первый член и разность арифметическое прогрессии?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.