Задача в паскале абс{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм?

Информатика | 5 - 9 классы

Задача в паскале абс

{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм.

Прогрессии и n - число членов прогрессии вывести на экран n первых членов прогрессии например a = 4

d = 2

n = 5

4 6 8 10 12 14}.

Ответить на вопрос
Ответы (1)
Polinabomeyko 31 июл. 2020 г., 01:21:45

Var a, d : real ; i, n : integer ;

begin write('Введите значение первого члена прогрессии, a = ') ; readln(a) ; write('Введите значение разности прогрессии, d = ') ; readln(d) ; write('Введите количество членов прогрессии, n = ') ; readln(n) ; writeln('Значения членов прогрессии : ') ; for i : = 1 to n do write(a + d * (i - 1), ' ')

end.

Тестовое решение :

Введите значение первого члена прогрессии, a = 4

Введите значение разности прогрессии, d = 2

Введите количество членов прогрессии, n = 6

Значения членов прогрессии :

4 6 8 10 12 14.

Nicto1 15 дек. 2020 г., 01:33:32 | 5 - 9 классы

10. 45 Даны первый член и разность арифметическое прогрессии?

10. 45 Даны первый член и разность арифметическое прогрессии.

Написать рекурсивную функцию для нахождения а) n - ого члена прогрессии.

Б) суммы первых n членов прогрессии.

Anastasyadurnov 19 июл. 2020 г., 21:27:08 | 10 - 11 классы

(Программа Паскаль) 1)Заполните массив элементами арифметической прогрессии?

(Программа Паскаль) 1)Заполните массив элементами арифметической прогрессии.

Её первый элемент и разность нужно ввести с клавиатуры.

2) Заполните массив степенями числа 2( от 2(в первой степени) до 2(в N степени).

Kate2005 9 мар. 2020 г., 03:13:55 | 5 - 9 классы

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии?

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии.

Nata262128 17 авг. 2020 г., 12:31:33 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Надо написать программу на паскале, вот условие : числовой ряд (арифметическая прогрессия) задается двумя числами n и k .

Первое число = n, каждое следующее на k больше предыдущего.

По двум числам n и k вывести первые 100 членов прогрессии.

Manehovhannisy 23 сент. 2020 г., 09:05:56 | 10 - 11 классы

Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов?

Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов.

Вывести на экран все члены геом.

Прогрессии и их среднее арифметическое (в паскале).

Pashasid 19 сент. 2020 г., 13:54:29 | 5 - 9 классы

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии?

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии.

Foretaste 22 февр. 2020 г., 11:40:38 | 10 - 11 классы

Составить программу : Получить первые k членов арифметической прогрессии с первым членом, равным сорока , и разностью минус 5?

Составить программу : Получить первые k членов арифметической прогрессии с первым членом, равным сорока , и разностью минус 5.

Оксаночка007 23 сент. 2020 г., 23:20:52 | 10 - 11 классы

Найти сумму n членов арифметической прогрессии, первый член которой равен а, а разность равна q?

Найти сумму n членов арифметической прогрессии, первый член которой равен а, а разность равна q.

Найти третий, тринадцатый и двадцать третий члены прогрессии.

Никитина111 2 июл. 2020 г., 21:42:59 | 5 - 9 классы

Дана арифметическая прогрессии 2, 6, 10, 14?

Дана арифметическая прогрессии 2, 6, 10, 14.

Записать пронрамму опрлеления номера первого члена прогрессии, превысившего заданное число В.

Вывести искомый номер и все члены прогрессии.

Typoiycenik2 2 сент. 2020 г., 19:04:05 | 5 - 9 классы

Дан массив из 10 элементов?

Дан массив из 10 элементов.

Необходимо заполнить его первыми 10 членами арифметической прогрессии с заданными первым членом прогрессии a и её разностью p.

Формат входных данных С клавиатуры вводятся целые числа a и p (−100≤a, p≤100−100≤a, p≤100).

Формат выходных данных Требуется вывести содержимое массива после заполнения согласно условию задачи.

Элементы должны разделяться пробелами.

На этой странице находится ответ на вопрос Задача в паскале абс{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм?, из категории Информатика, соответствующий программе для 5 - 9 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.