Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов?

Информатика | 10 - 11 классы

Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов.

Вывести на экран все члены геом.

Прогрессии и их среднее арифметическое (в паскале).

Ответить на вопрос
Ответы (1)
VODOLEY2 23 сент. 2020 г., 09:05:57

Program njn ;

uses crt ;

var a : array [1.

100] of integer ; i, p : integer ; s : real ;

begin

clrscr ;

readln(a[1], q, n) ;

s : = 0 ;

p : = a[1] ;

for i : = 2 to n do begin

a[i] : = p * q ;

p : = a[i] ;

end ;

for i : = 1 to n do

writeln(a[i]) ;

for i : = 1 to n do

s : = s + a[i] ;

writeln('Среднее = ', s / n) ;

readln ;

end.

Nicto1 15 дек. 2020 г., 01:33:32 | 5 - 9 классы

10. 45 Даны первый член и разность арифметическое прогрессии?

10. 45 Даны первый член и разность арифметическое прогрессии.

Написать рекурсивную функцию для нахождения а) n - ого члена прогрессии.

Б) суммы первых n членов прогрессии.

Kate2005 9 мар. 2020 г., 03:13:55 | 5 - 9 классы

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии?

Напишите программу в паскале, что бы Найти сумму членов арифметической прогрессии, если известны первый член, знаменатель и число членов прогрессии.

Nata262128 17 авг. 2020 г., 12:31:33 | 5 - 9 классы

Помогите пожалуйста?

Помогите пожалуйста!

Надо написать программу на паскале, вот условие : числовой ряд (арифметическая прогрессия) задается двумя числами n и k .

Первое число = n, каждое следующее на k больше предыдущего.

По двум числам n и k вывести первые 100 членов прогрессии.

Stapok12345 31 июл. 2020 г., 01:21:40 | 5 - 9 классы

Задача в паскале абс{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм?

Задача в паскале абс

{ввести с клавиатуры a - первое число арифметической прогресии и d - разность арифм.

Прогрессии и n - число членов прогрессии вывести на экран n первых членов прогрессии например a = 4

d = 2

n = 5

4 6 8 10 12 14}.

Pashasid 19 сент. 2020 г., 13:54:29 | 5 - 9 классы

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии?

СОСТАВИТЬ ПРОГРАММУ Цифры данного трехзначного числа являются членами арифметической прогрессии.

Foretaste 22 февр. 2020 г., 11:40:38 | 10 - 11 классы

Составить программу : Получить первые k членов арифметической прогрессии с первым членом, равным сорока , и разностью минус 5?

Составить программу : Получить первые k членов арифметической прогрессии с первым членом, равным сорока , и разностью минус 5.

Оксаночка007 23 сент. 2020 г., 23:20:52 | 10 - 11 классы

Найти сумму n членов арифметической прогрессии, первый член которой равен а, а разность равна q?

Найти сумму n членов арифметической прогрессии, первый член которой равен а, а разность равна q.

Найти третий, тринадцатый и двадцать третий члены прогрессии.

Никитина111 2 июл. 2020 г., 21:42:59 | 5 - 9 классы

Дана арифметическая прогрессии 2, 6, 10, 14?

Дана арифметическая прогрессии 2, 6, 10, 14.

Записать пронрамму опрлеления номера первого члена прогрессии, превысившего заданное число В.

Вывести искомый номер и все члены прогрессии.

МашkaMilashka 5 февр. 2020 г., 17:39:07 | 5 - 9 классы

Паскаль?

Паскаль.

Составьте программу вычисления суммы 150 первых членов арифметической прогрессии, если a1 = –200 ; d = 0, 2.

( с помощью repeat).

Crystal21 28 нояб. 2020 г., 21:44:51 | 10 - 11 классы

Составьте программу заполнения одномерного массива А(N)пятью первыми членами геометрической прогрессии(b1 = 2, q = 3)решить в паскале АВС?

Составьте программу заполнения одномерного массива А(N)пятью первыми членами геометрической прогрессии(b1 = 2, q = 3)решить в паскале АВС.

Вопрос Дано : а - первый член геометрической прогрессии, знаменатель - q, n - количество членов?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.