ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000)?

Информатика | 5 - 9 классы

ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000).

Входные данные Вводится натуральное число x.

Выходные данные Выведите наименьший делитель числа x, отличный от 1.

Примеры входные данные 2 выходные данные 2 входные данные 6 выходные данные 2.

Ответить на вопрос
Ответы (1)
Marishka916808 16 нояб. 2020 г., 15:25:55

Program n ;

uses crt ;

var i, x : integer ;

begin

writeln('Введите число') ; readln(x) ;

i : = 2 ;

while (x mod i)< ; > ; 0 do i : = i + 1 ;

writeln(i) ;

end.

Www1955 6 дек. 2020 г., 22:51:23 | 5 - 9 классы

Даны два натуральных числа n и m?

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

Входные данные Вводятся два числа.

Выходные данные Выведите ответ на задачу.

(Примеры : входные данные - 2, 8.

Выходные - 1).

P. S.

Решить надо в Паскаль АБЦ!

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

Halmetova2000 3 мар. 2020 г., 05:26:02 | 5 - 9 классы

Решить в Паскаль АБЦ?

Решить в Паскаль АБЦ!

Даны два натуральных числа n и m.

Если одно из них делится на другое нацело, выведите 1, иначе выведите любое другое целое число.

"Входные данные" Вводятся два числа.

"Выходные данные" Выведите ответ на задачу.

(Примеры : входные - 2, 8.

Выходные - 1).

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Irenaz 29 мар. 2020 г., 08:01:21 | 5 - 9 классы

Задача №334?

Задача №334.

Остаток Входные данные Вводятся 4 числа : a, b, c и d.

Выходные данные Выведите все числа на отрезке от a до b, дающие остаток c при делении на d.

Если таких чисел не существует, то ничего выводить не нужно.

Примеры входные данные 2 5 0 2 выходные данные 2 4 входные данные 2 7 9 14 выходные данные.

Букава 5 июн. 2020 г., 07:46:55 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Викуляsv 12 янв. 2020 г., 08:29:06 | 5 - 9 классы

Входные данные Вводятся целые числа a и b?

Входные данные Вводятся целые числа a и b.

Гарантируется, что a не превосходит b.

Выходные данные Выведите все числа на отрезке от a до b, являющиеся полными квадратами.

Если таких чисел нет, то ничего выводить не нужно.

Примеры входные данные 1 1 выходные данные 1 входные данные 2 8 выходные данные 4 Заранее спасибо.

Гмпспмш 23 февр. 2020 г., 21:01:58 | 5 - 9 классы

Программирование на C + + Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000)?

Программирование на C + + Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 < ; = x < ; = 30000).

Входные данные Вводится натуральное число x.

Выходные данные Выведите наименьший делитель числа x, отличный от 1.

Saiaanowa 4 окт. 2020 г., 13:20:39 | 5 - 9 классы

Дано двузначное число?

Дано двузначное число.

Найдите число десятков в нем.

Входные данные Вводится двухзначное число.

Выходные данные Выведите ответ на задачу.

Akolesova2002 30 нояб. 2020 г., 01:46:11 | 5 - 9 классы

Дано натуральное число N?

Дано натуральное число N.

Напишите функцию (Pascal), вычисляющую сумму цифр числа N.

Входные данные

Задано единственное число N

Выходные данные

Необходимо вывести сумму цифр числа N.

Примеры

входные данные

12

выходные данные

3

ПРОГРАММА БЫЛА, НО ВВОДИЛ 12 И ВЫВОДИЛ ВМЕСТО 3, 0.

Вопрос ПРОШУ ПОМОГИТЕ ОЧЕНЬ СРОЧНО Найдите самый маленький натуральный делитель числа x, отличный от 1 (2 &lt ; = x &lt ; = 30000)?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.