Напишите алгоритм нахождения максимального числа в массиве сгенерированного из случайных чисел?

Информатика | 5 - 9 классы

Напишите алгоритм нахождения максимального числа в массиве сгенерированного из случайных чисел.

Ответить на вопрос
Ответы (1)
Сая9 20 дек. 2020 г., 18:17:01

Program dataArray ; const N = 10 ; type x = array [1.

N] of integer ; var a : x ; i : integer ; max : integer ; imax : integer ; begin randomize ; for i : = 1 to N do begin a[i] : = - 50 + random(101) ; write (A[i] : 5) end ; writeln ; imax : = 1 ; max : = A[1] ; for i : = 2 to N do if max< ; a[i] then begin max : = a[i] ; imax : = i end ; writeln ('Максимальный элемент в массиве(матрице) = ', max : 5) ; writeln ('Его индекс в матрице = ', imax : 5) ; end.

Katrin2008 19 июл. 2020 г., 23:46:05 | 10 - 11 классы

ПАСКАЛЬ АБС?

ПАСКАЛЬ АБС!

СРОЧНО!

ПОМОГИТЕ ПОЖАЛУЙСТА!

1. напишите программу формирования массива размером 5 * 5 с помощью датчика случайных чисел.

Замените в нем нечетные значения элементов максимальным.

Выведите на экран исходный и измененный массивы.

2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чисел.

Naos1640316 27 мая 2020 г., 12:26:13 | 5 - 9 классы

Напишите краткий алгоритм нахождения минимального элемента в одномерном массиве?

Напишите краткий алгоритм нахождения минимального элемента в одномерном массиве.

Tati888 4 нояб. 2020 г., 10:55:12 | 5 - 9 классы

Составить алгоритм нахождения суммы цифр числа?

Составить алгоритм нахождения суммы цифр числа.

Напишите на С + +.

Рома127 11 апр. 2020 г., 09:47:12 | 10 - 11 классы

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов?

Посчитать сумму элементов массива, заполненного случайными числами, и произведение максимального и минимального элементов.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

Julian1011 28 дек. 2020 г., 07:36:18 | 5 - 9 классы

Дан целочисленный А[1?

Дан целочисленный А[1.

10], заполненный датчиком случайных чисел найти максимальный элемент массива.

AlinkaDJ2002 21 сент. 2020 г., 13:19:36 | 5 - 9 классы

Напишите программу в поскаль , для нахождения максимального числа из 5 чисел?

Напишите программу в поскаль , для нахождения максимального числа из 5 чисел.

Ghjk894 3 дек. 2020 г., 09:06:46 | 5 - 9 классы

Сгенерировать 100 случайных чисел в диапозоне от 10 до 20, вычеслить сумму четных чисел?

Сгенерировать 100 случайных чисел в диапозоне от 10 до 20, вычеслить сумму четных чисел.

Pasha1417 26 апр. 2020 г., 04:55:31 | 10 - 11 классы

Помогите c С#?

Помогите c С#!

На основании алгоритмов напишите программу поиска максимального элемента в массиве из 10 элементов.

22021977 29 дек. 2020 г., 06:05:16 | 5 - 9 классы

Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от - 50 до 50?

Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от - 50 до 50.

(Паскаль).

Вы перешли к вопросу Напишите алгоритм нахождения максимального числа в массиве сгенерированного из случайных чисел?. Он относится к категории Информатика, для 5 - 9 классов. Здесь размещен ответ по заданным параметрам. Если этот вариант ответа не полностью вас удовлетворяет, то с помощью автоматического умного поиска можно найти другие вопросы по этой же теме, в категории Информатика. В случае если ответы на похожие вопросы не раскрывают в полном объеме необходимую информацию, то воспользуйтесь кнопкой в верхней части сайта и сформулируйте свой вопрос иначе. Также на этой странице вы сможете ознакомиться с вариантами ответов пользователей.