Сгенерировать 100 случайных чисел в диапозоне от 10 до 20, вычеслить сумму четных чисел?

Информатика | 5 - 9 классы

Сгенерировать 100 случайных чисел в диапозоне от 10 до 20, вычеслить сумму четных чисел.

Ответить на вопрос
Ответы (1)
Lera3105 3 дек. 2020 г., 09:06:49

Program p1 ;

const n = 100 ;

var a : array[1.

100]of integer ;

i, s : integer ;

begin

randomize ;

for i : = 1 to n do

begin

a[i] : = random(10, 20) ;

end ;

for i : = 1 to n do

begin

if a[i] mod 2 = 0 then s : = s + a[i] ;

end ;

Writeln('Сумма чётных чисел = ', s) ;

end.

Звезды 14 янв. 2020 г., 08:51:21 | 5 - 9 классы

Вычеслите сумму квадратов всех четных чисел от1 до n?

Вычеслите сумму квадратов всех четных чисел от1 до n.

Czar98 6 янв. 2020 г., 15:05:24 | 10 - 11 классы

В одномерном массиве, заполненном случайными числами посчитать сумму и количество четных чисел?

В одномерном массиве, заполненном случайными числами посчитать сумму и количество четных чисел.

Массив размером 20.

Tmisha 1 дек. 2020 г., 22:31:59 | 10 - 11 классы

Сформировать массив из n случайных чисел на промежутке [ - 50 ; 50]?

Сформировать массив из n случайных чисел на промежутке [ - 50 ; 50].

Найти сумму четных чисел.

Надежда19841 23 июл. 2020 г., 09:17:50 | 10 - 11 классы

Дан одномерный массив целых чисел?

Дан одномерный массив целых чисел.

Найти сумму всех четных элементов массива, стоящих на четных местах (имеющих четные номера).

Массив задается с помощью генератора случайных чисел.

Если можно с блок - схемой.

ЭмИлЬ1234 19 апр. 2020 г., 01:00:14 | 10 - 11 классы

Найти сумму двухзначных четных чисел?

Найти сумму двухзначных четных чисел.

AiavodYanova 13 окт. 2020 г., 17:56:55 | 10 - 11 классы

Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio)?

Написать программу, которая генерирует и выводит на экран массив с с 10 случайных чисел в диапазоне от - 100 до 100, и выводит сумму четных чисел (в Visual Studio).

Vorobevnikolay 10 окт. 2020 г., 05:48:29 | 10 - 11 классы

С помощью гениратора случайных чисел получить 12 чисел из диапозона от 0 до 8 и вывести на экран только числа больше 5, а также подсчитать кол - во выведенных чисел?

С помощью гениратора случайных чисел получить 12 чисел из диапозона от 0 до 8 и вывести на экран только числа больше 5, а также подсчитать кол - во выведенных чисел.

Random.

Illaykorm 6 окт. 2020 г., 01:03:42 | 5 - 9 классы

Напишите программу, которая в последовательности натуральных чисел определяет сумму четных чисел?

Напишите программу, которая в последовательности натуральных чисел определяет сумму четных чисел.

Программа получает на вход количество чисел в последовательности, а сами числа задаются случайным образом.

Количество чисел не превышает 100.

Введённые числа не превышают 50.

Программа должна вывести исходные числа и число - сумму четных чисел.

С ОБЪЯСНЕНИЕМ ОТВЕТА, спасибо.

Medved31 18 дек. 2020 г., 11:27:32 | 5 - 9 классы

Сумма первых n четных чисел?

Сумма первых n четных чисел.

Sava150603 20 дек. 2020 г., 18:16:58 | 5 - 9 классы

Напишите алгоритм нахождения максимального числа в массиве сгенерированного из случайных чисел?

Напишите алгоритм нахождения максимального числа в массиве сгенерированного из случайных чисел.

На этой странице находится вопрос Сгенерировать 100 случайных чисел в диапозоне от 10 до 20, вычеслить сумму четных чисел?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 5 - 9 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.