Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от - 50 до 50?

Информатика | 5 - 9 классы

Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от - 50 до 50.

(Паскаль).

Ответить на вопрос
Ответы (1)
Bablo444 29 дек. 2020 г., 06:05:20

1. Вот так это можно решить "по - современному".

/ / PascalABC.

NET 3.

2, сборка 1353 от 27.

11. 2016 / / Внимание!

Если программа не работает, обновите версию!

Begin var a : = ArrRandom(ReadInteger('n = '), - 50, 50) ; a.

Println ; Writeln('Max = ', a.

Max)

end.

Пример

n = 13 - 11 16 - 24 5 5 3 42 45 - 46 45 22 43 - 4

Max = 45

2.

А так учат в большинстве школ.

Const nn = 100 ;

var a : array[1.

Nn] of integer ; i, n, max : integer ;

begin Write('n = ') ; Read(n) ; randomize ; max : = - 100 ; for i : = 1 to n do begin a[i] : = Random(101) - 50 ; Write(a[i], ' ') ; if a[i]> ; max then max : = a[i] end ; Writeln ; Writeln('Max = ', max)

end.

Artiomkonopli 27 сент. 2020 г., 07:42:34 | 1 - 4 классы

Найти максимальный элемент массива X(10)?

Найти максимальный элемент массива X(10).

Помогите написать программу в паскале пожалуйста.

Rord2014 16 нояб. 2020 г., 12:22:12 | 5 - 9 классы

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе?

Написать на Паскале программу нахождения суммы, произведения и среднего значения элементов массива, кол - во элементов ввести в программе.

FroZen007 14 нояб. 2020 г., 19:08:11 | 10 - 11 классы

Напишите программу пожалуйста в паскалепроизведение элементов массива, расположенных между максимальным и минимальным элементами ?

Напишите программу пожалуйста в паскале

произведение элементов массива, расположенных между максимальным и минимальным элементами ;

Vanoli4 11 февр. 2020 г., 07:27:15 | 10 - 11 классы

Написать программу на С + + или паскаль?

Написать программу на С + + или паскаль.

Помогите пожалуйста!

В одномерном массиве, состоящем из n вещественных элементов, вычислить : - максимальный элемент массива ; - сумма элементов массива, расположенных до последнего положительного элемента .

Сжать массив, удалив из него все элементы, модуль которых находится в интервале (a.

B). Освободившийся в конце массива элементы заполнить нулями.

MAXCHEBOTKOV 30 янв. 2020 г., 14:37:22 | 5 - 9 классы

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов?

Написать программу Заполнить массив из 15 элементов случайными числами ( - 20 ; 80) Посчитать сумму всех элементов массива Посчитать количество отрицательных элементов.

Mmtrr 6 сент. 2020 г., 12:50:34 | 10 - 11 классы

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива?

Написать алгоритмы нахождения суммы, произведения всех элементов массива и поиска максимального элемента массива.

Egordudukalov 25 июл. 2020 г., 15:02:43 | 5 - 9 классы

Написать программу для нахождения произведения элементов массива?

Написать программу для нахождения произведения элементов массива.

SpiderMan1997 3 авг. 2020 г., 10:04:59 | 10 - 11 классы

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве?

Написать в программу в паскале (сразу все) - найти максимальный и минимальный элемент в массиве.

Элина26 14 февр. 2020 г., 12:25:31 | 10 - 11 классы

Помогите, пожалуйста?

Помогите, пожалуйста!

Выполнение в ПАСКАЛЕ.

Составьте ПРОГРАММУ для нахождения ИНДЕКСА первого положительного элемента массива из 10 элементов, заданных случайным образом.

Andriymama 19 апр. 2020 г., 21:15:08 | 5 - 9 классы

Программу в паскале?

Программу в паскале.

Составить программу нахождения произведения положительных чисел одномерного массива В(10), элементы которого задаются датчиком случайных чисел.

На странице вопроса Написать программу по нахождению максимального элемента если элементы массива заполнены случайными числами в интервале от - 50 до 50? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.