В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных?

Информатика | 5 - 9 классы

В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных.

Ответить на вопрос
Ответы (1)
Наташа1234562 1 мая 2021 г., 09:35:32

Program zadacha ;

vara : array[1.

1000] of integer ; i, n, pol, otr : integer ; beginwriteln('vvedite kol - vo elementov massiva') ; readln(n) ; pol : = 0 ; otr : = 0 ;

for i : = 1 to n do begin a[i] : = random(1000) - 300 ; write(a[i] : 6) ; end ;

for i : = 1 to n doif a[i] > 0 then beginpol : = pol + 1 ; end ;

for i : = 1 to n doif a[i] < 0 then beginotr : = otr + 1 ; end ; writeln() ; writeln('polojitelnih chisel ', pol, ' otricatelnih chisel ', otr) ; end.

Fait2016 21 янв. 2021 г., 20:55:06 | 5 - 9 классы

Из элементов массива A, состоящего из 10 элементов, заполненный случайным образом, сформировать массив B по следующему правилу : положительные элементы перенести в массив b без изменений, а отрицатель?

Из элементов массива A, состоящего из 10 элементов, заполненный случайным образом, сформировать массив B по следующему правилу : положительные элементы перенести в массив b без изменений, а отрицательные заменить их модулем.

Распечатать оба массива.

Subaru04 14 мая 2021 г., 10:31:45 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу?

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу.

1120031 2 февр. 2021 г., 23:50:02 | 10 - 11 классы

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа?

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа.

Подсчитайте сумму положительных элементов массива и произведение отрицательных.

Затем сформируйте новый массив В (К) из массива А (К), в котором все положительные элементы замените на произведение отрицательных, а отрицательные на сумму положительных.

Zorjanamarhity 7 апр. 2021 г., 00:47:48 | 10 - 11 классы

Дан одномерный массив, который содержит не более 60 вещественных чисел, среди которых есть положительные, отрицательные и нули?

Дан одномерный массив, который содержит не более 60 вещественных чисел, среди которых есть положительные, отрицательные и нули.

Переставить элементы массива так, чтобы сначала шли нули, потом отрицательные, а затем положительные элементы массива.

Sasha1326 10 апр. 2021 г., 18:46:02 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале?

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале.

DawydenkoMarina2017 2 сент. 2021 г., 02:51:11 | 5 - 9 классы

Задан одномерный массив из н чисел сосчитать количество элементов массива положительных отрицательных и нулевых?

Задан одномерный массив из н чисел сосчитать количество элементов массива положительных отрицательных и нулевых.

196226c 11 мар. 2021 г., 10:46:16 | 5 - 9 классы

Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов?

Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов.

Iluza11897 4 мая 2021 г., 00:02:24 | 5 - 9 классы

Составить программу которая все отрицательные элементы массива удваивает а положительные утраивает?

Составить программу которая все отрицательные элементы массива удваивает а положительные утраивает.

Пожалуйста.

Voropaevanasty 31 авг. 2021 г., 14:35:02 | 10 - 11 классы

Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы?

Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы.

Трцляля 19 июн. 2021 г., 22:17:00 | 10 - 11 классы

Составить программу на паскале?

Составить программу на паскале.

Сформировать двумерный массив, состоящий из положительных и отрицательных элементов.

Заменить положительные элементы - единицей, а отрицательные - нулем.

На этой странице сайта вы найдете ответы на вопрос В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 5 - 9 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.