Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов?

Информатика | 5 - 9 классы

Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов.

Ответить на вопрос
Ответы (2)
Lexa3228 11 мар. 2021 г., 10:46:22

Program n1 ;

const n = 6 ;

var a : array [1.

N] of integer ;

i, sum : integer ;

begin

sum : = 0 ;

for i : = 1 to n do

begin write('введите ', i, ' число : ') ; readln(a[i]) ;

end ;

writeln('вывод отриц.

Элементов : ') ;

for i : = 1 to n do if a[i]> = 0 then sum : = sum + a[i] else writeln(a[i]) ;

writeln('сумма положительных : ', sum) ;

end.

Sahadmit 11 мар. 2021 г., 10:46:25

Вроде так, это бэйсик.

Sp1997 21 мая 2021 г., 06:45:10 | 10 - 11 классы

Заменить все положительные элементы массива на максимальный элемент массива ?

Заменить все положительные элементы массива на максимальный элемент массива .

Напишите программу в ПАСКАЛЬ.

Subaru04 14 мая 2021 г., 10:31:45 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу?

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу.

AlinaK31 26 июн. 2021 г., 16:04:22 | 5 - 9 классы

Составьте программу ввода элементов массива a[1?

Составьте программу ввода элементов массива a[1.

15] с клавиатуры и вывода на экран элементов со значениями кратными 5.

1120031 2 февр. 2021 г., 23:50:02 | 10 - 11 классы

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа?

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа.

Подсчитайте сумму положительных элементов массива и произведение отрицательных.

Затем сформируйте новый массив В (К) из массива А (К), в котором все положительные элементы замените на произведение отрицательных, а отрицательные на сумму положительных.

ЮрийРусинов 6 мар. 2021 г., 03:10:38 | 5 - 9 классы

Информатика?

Информатика.

Pascal ABC.

Составьте программу ввода элементов массива d [1.

6] с клавиатуры и вывода на экран элементов с положительными значениями.

Gapeev2004 1 мая 2021 г., 09:35:26 | 5 - 9 классы

В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных?

В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных.

Sasha1326 10 апр. 2021 г., 18:46:02 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале?

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале.

Vlados7887 20 авг. 2021 г., 13:45:39 | 5 - 9 классы

Написать программу к задаче : Завести в программе массив под именем TOR из 7 элементов, элементы массива TOR[2, 1, 2, 1, 2, 1, 2], вывести элементы массива на экран и подсчитать сумму элементов массив?

Написать программу к задаче : Завести в программе массив под именем TOR из 7 элементов, элементы массива TOR[2, 1, 2, 1, 2, 1, 2], вывести элементы массива на экран и подсчитать сумму элементов массива.

Выучить определения массива.

Oooooo4 11 июл. 2021 г., 05:44:33 | 10 - 11 классы

Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран?

Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран.

Iluza11897 4 мая 2021 г., 00:02:24 | 5 - 9 классы

Составить программу которая все отрицательные элементы массива удваивает а положительные утраивает?

Составить программу которая все отрицательные элементы массива удваивает а положительные утраивает.

Пожалуйста.

Вы открыли страницу вопроса Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.