Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале?

Информатика | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале.

Ответить на вопрос
Ответы (1)
Чёрнаякиса 10 апр. 2021 г., 18:46:06

Const handsfree = false ;

var a : array[1.

100] of real ; i, n : integer ; sum_pos, sum_neg : real ; k_pos, k_neg : integer ;

begin {ввод массива} if handsfree then n : = random(20) + 5 else begin write('n = ') ; readln(n) ; end ; writeln('Данные массива : ') ; for i : = 1 to n do begin if handsfree then begin a[i] : = random(100) - 50 ; write(a[i], ' ') ; end else readln(a[i]) ; end ; writeln() ; {подсчет} sum_pos : = 0 ; k_pos : = 0 ; sum_neg : = 0 ; k_neg : = 0 ; for i : = 1 to n do begin if a[i] > ; 0 then begin sum_pos : = sum_pos + a[i] ; k_pos : = k_pos + 1 ; end ; if a[i] < ; 0 then begin sum_neg : = sum_neg + a[i] ; k_neg : = k_neg + 1 ; end ; end ; writeln('average (positives) = ', sum_pos / k_pos) ; writeln('average (negatives) = ', sum_neg / k_neg) ;

end.

Sp1997 21 мая 2021 г., 06:45:10 | 10 - 11 классы

Заменить все положительные элементы массива на максимальный элемент массива ?

Заменить все положительные элементы массива на максимальный элемент массива .

Напишите программу в ПАСКАЛЬ.

Subaru04 14 мая 2021 г., 10:31:45 | 10 - 11 классы

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу?

Найти средние арифметические положительных и отрицательных элементов массива Паскаль написать программу.

375259554592 3 мая 2021 г., 18:19:52 | 10 - 11 классы

Pascal?

Pascal.

1. Найти среднее арифметическое положительных элементов двумерного массива.

Cfif453206 3 февр. 2021 г., 17:05:16 | 5 - 9 классы

ПАСКАЛЬ СОСТАВИТЬ ПРОГРАММУ Найти среднее арифметическое элементов массива А(5), состоящего из целых чисел, вводимых с клавиатуры?

ПАСКАЛЬ СОСТАВИТЬ ПРОГРАММУ Найти среднее арифметическое элементов массива А(5), состоящего из целых чисел, вводимых с клавиатуры.

Nastya27082004 19 июл. 2021 г., 23:33:58 | 5 - 9 классы

Вычислить среднее арифметическое положительных элементов массива?

Вычислить среднее арифметическое положительных элементов массива.

196226c 11 мар. 2021 г., 10:46:16 | 5 - 9 классы

Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов?

Написать программу вывода на экран отрицательных элементов массива и суммы положительных элементов.

Cv3322 10 авг. 2021 г., 20:22:50 | 5 - 9 классы

Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива?

Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.

Мила973 11 дек. 2021 г., 10:24:30 | 10 - 11 классы

Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива?

Напишите на Паскале программу, которая запрашивает с клавиатуры массив из N чисел, а затем выводит среднее арифметическое всех элементов массива.

БердниковаСонечка 15 сент. 2021 г., 01:35:45 | 5 - 9 классы

Найти среднее арифметическое элементов в первом столбце в двумерном массиве?

Найти среднее арифметическое элементов в первом столбце в двумерном массиве.

Паскаль.

Миха329 15 дек. 2021 г., 00:23:36 | студенческий

Составить программу на языке Паскаль?

Составить программу на языке Паскаль.

А) Вычислить среднее арифметическое элементов массива А(20) равных за данному числу а.

Б) Вычислить произведение модулей элементов массива А(20).

На этой странице находится вопрос Найти средние арифметические положительных и отрицательных элементов массива, написать программу в паскале?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.