Из элементов массива A, состоящего из 10 элементов, заполненный случайным образом, сформировать массив B по следующему правилу : положительные элементы перенести в массив b без изменений, а отрицатель?

Информатика | 5 - 9 классы

Из элементов массива A, состоящего из 10 элементов, заполненный случайным образом, сформировать массив B по следующему правилу : положительные элементы перенести в массив b без изменений, а отрицательные заменить их модулем.

Распечатать оба массива.

Ответить на вопрос
Ответы (1)
Msmarypon 21 янв. 2021 г., 20:55:10

Var

a, b : array [1.

10] of integer ;

i : integer ;

begin

for i : = 1 to 10 do a[i] : = random(1001) - 1000 ;

for i : = 1 to 10 do b[i] : = abs(a[i]) ;

for i : = 1 to 10 do write(a[i], ' ') ;

writeln ;

for i : = 1 to 10 do write(b[i], ' ') ;

end.

Foorgyinfifcio 16 янв. 2021 г., 11:06:03 | 5 - 9 классы

В одномерном массиве случайных чисел заменить все отрицательные элементы на их модуль?

В одномерном массиве случайных чисел заменить все отрицательные элементы на их модуль.

1120031 2 февр. 2021 г., 23:50:02 | 10 - 11 классы

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа?

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа.

Подсчитайте сумму положительных элементов массива и произведение отрицательных.

Затем сформируйте новый массив В (К) из массива А (К), в котором все положительные элементы замените на произведение отрицательных, а отрицательные на сумму положительных.

Gapeev2004 1 мая 2021 г., 09:35:26 | 5 - 9 классы

В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных?

В массиве, состоящем из положительных и отрицательных чисел, определить, сколько элементов положительных и сколько элементов отрицательных.

Oooooo4 11 июл. 2021 г., 05:44:33 | 10 - 11 классы

Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран?

Написать программу, которая заменяет все отрицательные элементы массива их модулями и выводит измененный массив на экран.

Қауын 22 сент. 2021 г., 21:36:57 | 10 - 11 классы

Дан массив x1, x2, … x15?

Дан массив x1, x2, … x15.

Все отрицательные элементы массива заменить на 1, а положительные элементы массива заменить на 5.

Вывести на печать полученный массив.

Voropaevanasty 31 авг. 2021 г., 14:35:02 | 10 - 11 классы

Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы?

Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы.

Vik7777777 11 нояб. 2021 г., 14:11:36 | 10 - 11 классы

Сформировать массив размером 4Х4, заполнить случайными числами от 0 до 100 , распечатать элементы массива( по строкам), найти сумму всех элементов, среднее арифметическое всех элементовПрограмма в пас?

Сформировать массив размером 4Х4, заполнить случайными числами от 0 до 100 , распечатать элементы массива( по строкам), найти сумму всех элементов, среднее арифметическое всех элементов

Программа в паскале , 10 класс.

Fasber 1 нояб. 2021 г., 21:48:16 | 5 - 9 классы

Нужна помощь?

Нужна помощь!

1. Заполнить массив из 13 целых элементов случайными числами из диапазона от 5 до 15.

Обеспечить вывод исходного массива на экран.

Подсчитать произведение четных элементов массива.

2. Дан массив из 7 вещественных элементов.

Обеспечить заполнение массива с клавиатуры.

Преобразовать массив : всем положительным элементам присвоить значение 100.

Обеспечить вывод получившегося массива на экран.

3. Дан массив из 10 вещественных элементов.

Обеспечить заполнение массива с клавиатуры.

Подсчитать сумму отрицательных элементов массива, стоящих на четных местах.

Алексей982 24 сент. 2021 г., 09:33:56 | 5 - 9 классы

Сформировать массив А из 30 случайных чисел в интервале от - 50 до 50, найти максимальный элемент массива и увеличить все элементы массива на величину максимального?

Сформировать массив А из 30 случайных чисел в интервале от - 50 до 50, найти максимальный элемент массива и увеличить все элементы массива на величину максимального.

Трцляля 19 июн. 2021 г., 22:17:00 | 10 - 11 классы

Составить программу на паскале?

Составить программу на паскале.

Сформировать двумерный массив, состоящий из положительных и отрицательных элементов.

Заменить положительные элементы - единицей, а отрицательные - нулем.

Если вам необходимо получить ответ на вопрос Из элементов массива A, состоящего из 10 элементов, заполненный случайным образом, сформировать массив B по следующему правилу : положительные элементы перенести в массив b без изменений, а отрицатель?, относящийся к уровню подготовки учащихся 5 - 9 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.