Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы?

Информатика | 10 - 11 классы

Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы.

Ответить на вопрос
Ответы (1)
Звверь777 31 авг. 2021 г., 14:35:04

Var a : array [1.

10] of integer ;

i, max : integer ;

begin

for i : = 1 to 10 do

readln a[i] ;

max : = a[1] ;

for i : = 2 to 10 do

if a[i]> max then max : = a[i] ;

for i : = 1 to 10 do begin

if a[i]>0 then a[i] : = max ;

if a[i] >0 then a[i] : = i ;

end ;

for i : = 1 to 10 do

writeln( a[i]) ;

end.

1. Заполняем массив из 10 элементов

2 Считаем условно что первый элемент максимальный

3 В цикле начиная со второго элемента находим максимальный элемент

4 Осуществляем преобразования в цикле с учётом условия

5 Раз у нас задача на замену то осуществляем вывод массива чтобы просмотреть его элементы.

Foorgyinfifcio 16 янв. 2021 г., 11:06:03 | 5 - 9 классы

В одномерном массиве случайных чисел заменить все отрицательные элементы на их модуль?

В одномерном массиве случайных чисел заменить все отрицательные элементы на их модуль.

Sp1997 21 мая 2021 г., 06:45:10 | 10 - 11 классы

Заменить все положительные элементы массива на максимальный элемент массива ?

Заменить все положительные элементы массива на максимальный элемент массива .

Напишите программу в ПАСКАЛЬ.

1120031 2 февр. 2021 г., 23:50:02 | 10 - 11 классы

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа?

Введите с клавиатуры одномерный массив А (К), элементами которого являются положительные и отрицательные числа.

Подсчитайте сумму положительных элементов массива и произведение отрицательных.

Затем сформируйте новый массив В (К) из массива А (К), в котором все положительные элементы замените на произведение отрицательных, а отрицательные на сумму положительных.

Муъмин 7 июл. 2021 г., 22:24:43 | 5 - 9 классы

1. В одномерном массиве произвольных чисел А(10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов?

1. В одномерном массиве произвольных чисел А(10) положительные элементы уменьшить в двое, а отрицательные элементы заменить на значения их индексов.

2. Дан массив из N элементов.

Найти сумму элементов с четными номерами и отдельно – с нечетными номерами.

Zorjanamarhity 7 апр. 2021 г., 00:47:48 | 10 - 11 классы

Дан одномерный массив, который содержит не более 60 вещественных чисел, среди которых есть положительные, отрицательные и нули?

Дан одномерный массив, который содержит не более 60 вещественных чисел, среди которых есть положительные, отрицательные и нули.

Переставить элементы массива так, чтобы сначала шли нули, потом отрицательные, а затем положительные элементы массива.

SerhioMe 24 февр. 2021 г., 17:07:13 | 10 - 11 классы

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа?

Введите с клавиатуры одномерный массив S(K), элементами которого являются положительные и отрицательные числа.

Найдите среднее арифметическое значение среди последних 9 - ти элементов массива, максимум среди первых 5 - ти элементов.

Замените в массиве все элементы, которые больше найденного среднего арифметического - на максимум.

DawydenkoMarina2017 2 сент. 2021 г., 02:51:11 | 5 - 9 классы

Задан одномерный массив из н чисел сосчитать количество элементов массива положительных отрицательных и нулевых?

Задан одномерный массив из н чисел сосчитать количество элементов массива положительных отрицательных и нулевых.

Tawron 28 мая 2021 г., 05:15:11 | 10 - 11 классы

Тема : Одномерные массивы?

Тема : Одномерные массивы.

Вариант 10 Pascal : 1.

Дан одномерный массив, который содержит не более 50 целых чисел.

Заменить каждый элемент массива суммой соседних индексов.

Если соседних элементов нет, то число оставить без изменения.

2. Дан одномерный массив, который содержит не более 40 целых чисел.

Найти сумму отрицательных элементов, которые расположены между максимальным и минимальным элементом.

3. Дан одномерный массив, который содержит не более 60 символов.

Ответить на вопрос, есть ли среди данных символов сочетание «…».

Oleftina2005 19 июн. 2021 г., 10:01:42 | 10 - 11 классы

Задан одномерный массив X1, X2, …, XN ?

Задан одномерный массив X1, X2, …, XN .

Фрагмент алгоритма определяет Выберите один ответ : индекс первого отрицательного элемента индекс минимального элемента массива индекс последнего отрицательного элемента минимальный элемент массива количество отрицательных элементов.

Қауын 22 сент. 2021 г., 21:36:57 | 10 - 11 классы

Дан массив x1, x2, … x15?

Дан массив x1, x2, … x15.

Все отрицательные элементы массива заменить на 1, а положительные элементы массива заменить на 5.

Вывести на печать полученный массив.

На этой странице находится вопрос Дан одномерный массив заменить все положительные элементы на максимальное среди них все отрицательные элементы массива на их индексы?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.