Дана строка, состоящая из русскиз слов?

Информатика | 10 - 11 классы

Дана строка, состоящая из русскиз слов.

Вывести множество чётных позиций, на которых стоят гласные буквы.

P. S.

Решение в Pascal abc или напишите на листе, пришлите фото с решением, пожалуйста.

Ответить на вопрос
Ответы (1)
Чапик 15 сент. 2020 г., 01:10:40

Var s, gl : string ; i : integer ; ps : set of integer ;

begin gl : = 'аеёийоуыэюя' ; write('строка : ') ; readln(s) ; ps : = [] ; i : = 2 ; repeat if pos(s[i], gl)> ; 0 then ps : = ps + [i] ; i : = i + 2 ; until i> ; length(s) ; write('множество четных позиций с гласными : ') ; foreach i in ps do write(i, ' ') ;

end.

Результат работы :

строка : Это строка для проверки

множество четных позиций с гласными : 20 18 10 8 14.

Nfd 1 июн. 2020 г., 18:38:57 | 10 - 11 классы

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква?

Помогите пожалуйста составить программу на ''Pascal ABC'') Дана строка, содержащая текст на русском языке, и некоторая буква.

Подсчитать, сколько слов начинается с указанной буквы.

Lenusik190893 17 дек. 2020 г., 08:11:07 | 5 - 9 классы

Помогите сделать в pascal abc?

Помогите сделать в pascal abc.

Дана строка.

Укажите те слова, которые содержат хотя бы одну букву к.

Nastena5252 20 июн. 2020 г., 13:16:29 | 5 - 9 классы

PASCAL ABC Символьный тип данных?

PASCAL ABC Символьный тип данных.

Вывести на экран все латинские буквы, коды которых чётные и кратны 5.

Рокера 11 февр. 2020 г., 20:01:37 | 10 - 11 классы

Вывести из строки гласные буквы и их кол - вона языке Pascal, прошу помогите ?

Вывести из строки гласные буквы и их кол - во

на языке Pascal, прошу помогите !

Maxorliov 22 апр. 2020 г., 20:47:12 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Помогите решить задачу в Pascal.

"С клавиатуры вводятся два слова.

Требуется найти множество гласных букв , которые входят в первое слово , но не входят во второе слово.

" Помогите срочно , пожалуйста, в PASCAL!

Qazxswedc2014 11 июл. 2020 г., 02:56:10 | 10 - 11 классы

Программа в Pascal ABC?

Программа в Pascal ABC.

С клавиатуры вводится два слова.

Надо вывести на экран те буквы, которые есть и в одном и во втором слове (печатать буквы без повторений).

Ромочка13 26 авг. 2020 г., 23:58:54 | 10 - 11 классы

Дана строка, состоящая из слов?

Дана строка, состоящая из слов.

Вывести слова, которые повторяются хотя бы один раз.

Паскаль.

Nikiton0200 28 нояб. 2020 г., 13:18:54 | 5 - 9 классы

Дана строка ?

Дана строка .

Написать программу, которая подсчитывает количество символов "?

" (pascal abc) помогите пожалуйста!

Kristi1617 20 июл. 2020 г., 11:55:34 | 5 - 9 классы

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL?

Дана строка символов состоящая из букв и цифр определить сумму всех цифр в этой сроке и количество прописных заглавных букв на PASCAL.

Vanchezzz178 8 нояб. 2020 г., 03:19:26 | 10 - 11 классы

Решите задачу по инфе пожалуста?

Решите задачу по инфе пожалуста.

Дано слово, состоящее из чётного числа букв, вывести буквы, стоящие на чётных местах.

На странице вопроса Дана строка, состоящая из русскиз слов? из категории Информатика вы найдете ответ для уровня учащихся 10 - 11 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.