Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих?

Информатика | 10 - 11 классы

Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих.

Формат входных данных Первая строка входных данных содержит строку s, вторая строка содержит строку t.

Обе строки состоят только из строчных латинских букв.

1 < ; = длина строк < ; = 1, 000.

Формат выходных данных Выведите ответ к задаче.

Ответить на вопрос
Ответы (1)
Kantargi79 18 окт. 2020 г., 00:26:11

/ / PascalABC.

NET 3.

2, сборка 1353 от 27.

11. 2016 / / Внимание!

Если программа не работает, обновите версию!

Function MaxSubstr(s1, s2 : string) : string ;

begin var a : = new integer[s1.

Length + 1, s2.

Length + 1] ; var u : = 0 ; var v : = 0 ; for var i : = 0 to s1.

Length - 1 do for var j : = 0 to s2.

Length - 1 do if s1[i + 1] = s2[j + 1] then begin a[i + 1, j + 1] : = a[i, j] + 1 ; if a[i + 1, j + 1]> ; a[u, v] then begin u : = i + 1 ; v : = j + 1 end end ; Result : = s1.

Substring(u - a[u, v], a[u, v])

end ;

begin var s : = 'trapperkaperkatrter' ; var t : = 'appekaperspamer' ; Writeln(MaxSubstr(s, t))

end.

Dimamakarenkorus 23 июл. 2020 г., 01:13:36 | 10 - 11 классы

Напишите программу, которая подсчитывает сумму всех цифр в данной строке?

Напишите программу, которая подсчитывает сумму всех цифр в данной строке.

Например, в строке "Sochi - 2014" сумма цифр равна 7.

Формат входных данных

Одна строка, возможно с пробелами, буквами, цифрами и спецсимволами.

Формат результата

Одно число — сумма цифр в строке.

Для Python.

Ilmatrastamp 24 апр. 2020 г., 12:12:22 | 5 - 9 классы

Дана строка, состоящая из заглавных английских букв и цифр?

Дана строка, состоящая из заглавных английских букв и цифр.

Вывести первый символ строки.

Входные данные : В единственной строке входного потока дана строка символов, длина которой не превышает 255.

Выходные данные : В выходной поток вывести единственный символ.

Пример входного файла (input.

Txt) : KDSFJHGLKDJGHLSUIRH5HGUHG58H.

Пример выходного файла (output.

Txt) : K.

Vikulumitrofsa 25 авг. 2020 г., 23:07:41 | 5 - 9 классы

У Азизхана есть строка S?

У Азизхана есть строка S.

Его интересует сколько есть подстрок четной длины у строки S, которые являются палиндромами.

Одинаковые подстроки начинающие с разных позиций считаются разными.

Формат входных данных Единственная строка входного файла содержит одну строку S состоящее из строчных букв английского алфавита (1 < ; = длина S < ; = 100000).

Формат выходных данных Выведите ответ к задаче.

Помагите плиз.

Atey94033 9 апр. 2020 г., 22:40:15 | 5 - 9 классы

Дается последовательность из N чисел?

Дается последовательность из N чисел.

Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных Первая строка входного файла содержит целое число N (1 < ; = N < ; = 100000).

В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.

Формат выходных данных Выведите ответ к задаче.

Джувия5Локсар 20 июл. 2020 г., 11:06:48 | 5 - 9 классы

1. Даны две строки?

1. Даны две строки.

Написать программу для вывода на экран слова полученного из суммы двух первых букв каждой строки.

2. Дана строка.

Определить есть ли в данной строке буква h.

Slameman20141 7 июл. 2020 г., 16:31:54 | 10 - 11 классы

Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания?

Добрый вечер )) Помогите пожалуйста решит данную задачу)) Задача на множества : Дана строка из букв латинского алфавита, цифр, русских букв и знаков препинания.

Вырезать из строки цифры и записать их а отдельную строку в том же порядке, в каком они были расположены в исходной.

Вывести на печать содержимое полученных строк.

Входные данные : исходная строка

Vv1, 32qq1 / 4b5b45!

Выходные данные : две полученные строки

13214545

Vv, qq / bb45!

За ране спасибо!

Iuriks11 5 июл. 2020 г., 06:10:57 | 5 - 9 классы

Даны две строки?

Даны две строки.

Определите, является ли первая строка подстрокой второй строки.

Vovago30 18 июн. 2020 г., 16:57:55 | 10 - 11 классы

Заданы две строки А и В?

Заданы две строки А и В.

Можно ли переставить буквы в одном из слов так , чтобы слова стали одинаковыми?

Формат входных данных первая строка входного файла содержит строку A состоящую из строчных букв английского алфавита (1< ; = |B|< ; = 1000).

Вторая строка содержит строку B в таком же формате формат выходных данных.

Цунаде 25 дек. 2020 г., 17:36:17 | 5 - 9 классы

Задача C?

Задача C.

Делители Дано целое число N.

Вам нужно определить количество его делителей Формат входных данных Единственная строка входного файла содержит целое число N (1 < ; = N < ; = 10 ^ 12) Формат выходных данных Выведите ответ к задаче.

Oklubkova 10 дек. 2020 г., 09:26:25 | 5 - 9 классы

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел?

Напишите программу, которая выбирает максимальное и минимальное из пяти введённых чисел.

Входные данные

Входная строка содержит 5 целых чисел, разделённых пробелами.

Выходные данные

В первой строке нужно вывести минимальное из введённых чисел, во второй строке – максимальное.

Примеры

входные данные

1 2 3 4 5

выходные данные

1

5

На паскале.

Вы зашли на страницу вопроса Вам даны две строки s и t, определите длину наибольшей строки, которая встречается в обеих?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.