Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Информатика | 5 - 9 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Формат входных данных Задано единственное число N.

Формат выходных данных Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Ответить на вопрос
Ответы (1)
2002мама 25 авг. 2020 г., 16:21:59

Var

i, n : integer ;

begin

readln(n) ;

for i : = 1 to n - 1 do write(i * i : 5) ;

end.

Kartashovaa79 11 окт. 2020 г., 06:44:01 | 10 - 11 классы

Дано два натуральных числа N и M?

Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел.

Незначащих нулей в найденном числе быть не должно.

Формат входных данных : Входной файл INPUT.

TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.

Формат выходных данных : Выходной файл OUTPUT.

TXT должен содержать найденное наименьшее число.

Лиина97 4 июн. 2020 г., 15:25:51 | 10 - 11 классы

Задается целое число N?

Задается целое число N.

Нужно вывести количество четных делителей числа N.

Формат входных данных Единственная строка входного файла содержит единственное целое число N(1< ; = N< ; = 1000) Формат выходных данных выведите ответ к задаче.

Doroshenko2002 5 февр. 2020 г., 23:51:13 | 10 - 11 классы

Помогите написать программу на PascalABCNET Дано сначала число n, а затем n натуральных чисел, не превосходящих 100?

Помогите написать программу на PascalABCNET Дано сначала число n, а затем n натуральных чисел, не превосходящих 100.

Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.

ВХОДНЫЕ ДАННЫЕ В первой строке вводится одно число n — натуральное, не превосходящее 10000.

Во второй строке вводятся n натуральных чисел, не превосходящих 100.

ВЫХОДНЫЕ ДАННЫЕ Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Tany3077 11 нояб. 2020 г., 16:26:38 | 10 - 11 классы

Вывести точные квадраты натуральных чисел, не превосходящие данного числа Nна языке VBA?

Вывести точные квадраты натуральных чисел, не превосходящие данного числа N

на языке VBA.

Yanova777 14 авг. 2020 г., 14:48:36 | 10 - 11 классы

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?

Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Borodyha123 28 дек. 2020 г., 21:12:44 | 10 - 11 классы

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу ?

Составить программу нахождения для заданного натурального числа всех делителей, кратных числу .

Формат входных данных

Входной файл содержит числа , ().

Формат выходных данных

Выведите искомые делители.

Примеры :

Вход6 3

Выход3 6.

Virus1420 1 окт. 2020 г., 07:10:54 | 5 - 9 классы

Вычислите сумму данных N натуральных чисел?

Вычислите сумму данных N натуральных чисел.

Входные данные Вводится число N, а затем N чисел, сумму которых необходимо вычислить.

Выходные данные Выведите единственное число - сумму введенных чисел.

В Pascal ABC.

Ilililililil 19 окт. 2020 г., 06:29:49 | 5 - 9 классы

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ?

ЛЮДИ ДОБРЫЕ ПОМОГИТЕ!

25баллов Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N.

Входные данные Задано единственное целое число N Выходные данные Необходимо вывести все точные квадраты натуральных чисел, не превосходящие данного числа N.

Примеры входные данные 15 выходные данные 1 4 9.

Fokin05 29 апр. 2020 г., 09:31:01 | 10 - 11 классы

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100?

Дано сначала число n, а затем n натуральных чисел, не превосходящих 100.

Выведите на экран в порядке возрастания только те из них, которые встречаются в данной последовательности ровно один раз.

ВХОДНЫЕ ДАННЫЕ В первой строке вводится одно число n — натуральное, не превосходящее 10000.

Во второй строке вводятся n натуральных чисел, не превосходящих 100.

ВЫХОДНЫЕ ДАННЫЕ Выведите в порядке возрастания те из них, которые встречаются в последовательности ровно один раз.

Клубничка311 29 дек. 2020 г., 21:54:23 | 5 - 9 классы

Дано натуральное трёхзначное число n?

Дано натуральное трёхзначное число n.

Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

Вопрос Выведите все точные квадраты натуральных чисел, не превосходящие данного числа N?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.