Дано целое число?

Информатика | 10 - 11 классы

Дано целое число.

Подсчитать в нём произведение цифр, которые расположены на нечётных позициях.

Ответить на вопрос
Ответы (1)
Yugura4927 26 сент. 2020 г., 18:57:26

Здесь пришлось учитывать положительные и отрицательные числа, т.

К. длина строки с отрицательным числом включает в себя и знак минус.

Поэтому в некоторых местах программы я добавлю пояснение.

Var n, p : integer ; s : string ;

begin

write ('Введите число : ') ;

readln (n) ; if n< ; 0 then n : = - n ; / / отрицательное число переделываем в положительное, чтобы "длина строки" ниже не получилась больше количества цифр в числе str(n, s) ; / / преобразуем число в строку, чтобы узнать длину числа (количество цифр) if (length(s) mod 2) = 0 thenn : = n div 10 ; / / проверяем длину числа на четность.

Так как нам нужны цифры с НЕЧЕТНЫХ мест, убираем из числа последнюю цифру, которая стоит на ЧЕТНОМ месте : p : = 1 ; while n> ; = 1 do begin / / организуем цикл ПОКА число не станет меньше единицы (в цикле мы будем отрезать от него по две цифры) p : = p * (n mod 10) ; / / произведение умножаем на последнюю цифру числа (остаток от деления числа на 10) n : = n div 100 ; / / отрезаем от числа 2 последние цифры.

(в последней итерации цикла оно примет вид 0, 0х, т.

Е. будет больше 0, но меньше 1) end ; writeln ; writeln ('Произведение цифр, которые расположены на нечётных позициях, = ', p) ;

end.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Проимер :

Введите число : - 2323

Произведение цифр, которые расположены на нечётных позициях, = 4.

Kseniya123 15 нояб. 2020 г., 14:54:27 | 10 - 11 классы

1. Дано целое число А?

1. Дано целое число А.

Определить количество цифр в числе, которые больше 6.

Pascal.

Wowwic200 11 окт. 2020 г., 16:06:25 | 5 - 9 классы

Составить программу?

Составить программу.

Дано натуральное число n.

Подсчитать количество цифр этого числа.

Alexlexay 25 мая 2020 г., 14:22:31 | 10 - 11 классы

Подсчитать количество (сумму)цифр в записи целого неотрицательного числа?

Подсчитать количество (сумму)цифр в записи целого неотрицательного числа.

(в паскале авс).

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Mazepa1605 31 мая 2020 г., 08:40:24 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите среднее арифметическое нечётных цифр числа.

Яблако 26 мар. 2020 г., 21:52:46 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Определите количество нечётных цифр в данном числе.

(Pascal).

Dobro96 8 апр. 2020 г., 11:09:31 | 10 - 11 классы

Дан массив А целых чисел?

Дан массив А целых чисел.

Подсчитать в нём количество элементов, лежащих в диапазоне [0, 10].

Помогите пожалуйста.

Яна509 23 окт. 2020 г., 14:42:39 | 1 - 4 классы

Дано четырёхзначное число определить является ли нечётным произведение его цифр?

Дано четырёхзначное число определить является ли нечётным произведение его цифр.

Ilyamatveev2020 9 июн. 2020 г., 18:02:10 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите среднее арифметическое нечётных цифр числа.

Клубничка311 29 дек. 2020 г., 21:54:23 | 5 - 9 классы

Дано натуральное трёхзначное число n?

Дано натуральное трёхзначное число n.

Найдите сумму и произведение цифр в нём.

Формат входных данных

Вводится целое число n (100≤n≤999)

Формат выходных данных

Требуется вывести сумму и произведение его цифр через пробел.

Перед вами страница с вопросом Дано целое число?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.