Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Информатика | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Ответить на вопрос
Ответы (1)
Islam57 21 мар. 2020 г., 13:20:25

Uses crt ;

var i, s, a, b, c, ch, o : integer ;

begin

o : = 0 ;

writeln(' Vvedite chislo ' ) ;

readln(ch) ;

for i : = 100 to 999 do

begin

a : = i div 100 ;

b : = (i div 10) mod 10 ;

c : = i mod 10 ;

if ((a + b + c) = ch) then

begin

inc(o) ;

writeln(i) ;

end ;

end ;

if o = 0 then writeln('error !

') ;

readln ;

end.

Artemeva03 17 сент. 2020 г., 23:03:19 | 10 - 11 классы

Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа?

Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа.

Free pascal.

Kseniya123 15 нояб. 2020 г., 14:54:27 | 10 - 11 классы

1. Дано целое число А?

1. Дано целое число А.

Определить количество цифр в числе, которые больше 6.

Pascal.

Nastenkasergee 11 сент. 2020 г., 21:40:15 | 10 - 11 классы

Программу на Си?

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

Edikpro002701 8 авг. 2020 г., 06:55:49 | 10 - 11 классы

Ввести с клавиатуры трехзначное число и корень квадратный из суммы цифр этого числаpascal?

Ввести с клавиатуры трехзначное число и корень квадратный из суммы цифр этого числа

pascal.

Умник2002 3 авг. 2020 г., 04:33:03 | 5 - 9 классы

Дано трехзначное и четырехзначное число?

Дано трехзначное и четырехзначное число.

В каком числе сумма цифр больше?

Напишите, пожалуйста, программу для Pascal.

ABC.

Mysterium 25 июл. 2020 г., 15:46:22 | 10 - 11 классы

1. Дано трехзначное число?

1. Дано трехзначное число.

Написать программу (Pascal), которая «переставляет» первую цифру числа на самое последнее место.

Pinilopa1 28 февр. 2020 г., 11:46:17 | 1 - 4 классы

Даны целое трехзначное число N и цедое число k?

Даны целое трехзначное число N и цедое число k.

Написать программу, подсчитывающую сумму цифр числа N, которые больше k.

Vladik310800 5 янв. 2020 г., 14:22:54 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найдите сумму его цифр.

Мухтар7 11 авг. 2020 г., 21:59:02 | 5 - 9 классы

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые?

Дано трехзначное число Напишите программу которая определяет есть ли среди цифр заданного целого трехзначного числа одинаковые.

Alinplwww16 16 сент. 2020 г., 17:12:24 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найти число, полученное при перестановке первой и последней

цифр заданного числа.

Pascal.

Вы зашли на страницу вопроса Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?, который относится к категории Информатика. По уровню сложности вопрос соответствует учебной программе для учащихся 10 - 11 классов. В этой же категории вы найдете ответ и на другие, похожие вопросы по теме, найти который можно с помощью автоматической системы «умный поиск». Интересную информацию можно найти в комментариях-ответах пользователей, с которыми есть обратная связь для обсуждения темы. Если предложенные варианты ответов не удовлетворяют, создайте свой вариант запроса в верхней строке.