Дано целое число N?

Информатика | 10 - 11 классы

Дано целое число N.

Определите среднее арифметическое нечётных цифр числа.

Ответить на вопрос
Ответы (1)
Valeraignor911 31 мая 2020 г., 08:40:28

Program lol (input, output) ;

var a, n, b, i, p, s, m : integer ;

c : real ;

begin

read (n) ;

a : = n ;

b : = 0 ;

c : = 0 ;

I : = 0 ;

p : = 1 ;

while a < ; > ; 0 do begin

a : = a div 10 ;

b : = b + 1 ;

end ;

while b < ; > ; 0 do

begin

p : = 1 ;

for m : = 1 to b do

p : = p * 10 ;

s : = (n mod p) div (p div 10) ;

if (s mod 2) < ; > ; 0 then

begin

c : = c + s ;

I : = I + 1 ;

end ; b : = b - 1 ;

end ;

c : = c / I ;

writeln (c) ;

end.

Mogetta 19 окт. 2020 г., 11:02:34 | 5 - 9 классы

Здравствуйте)Вводится натуральное число?

Здравствуйте)Вводится натуральное число.

Определить среднее арифметическое его цифр.

Pascal) не могли бы помочь?

Bitcher 16 нояб. 2020 г., 02:20:12 | 5 - 9 классы

Паскаль?

Паскаль.

1 дано целое число N.

Вычислить среднее арифметическое всех чисел из диапазона от 1 до N.

2 дано целое число N.

Вывести на экран все нечётные числа из диапахона от 1 до N.

Вычислить их сумму.

Kostinsania 29 сент. 2020 г., 03:36:04 | 10 - 11 классы

Помогите плиз к понедельнику решить эту мега сложную задачу)Дано целое число K определите среднее арифметическое делителей данного числа PASCAL?

Помогите плиз к понедельнику решить эту мега сложную задачу)Дано целое число K определите среднее арифметическое делителей данного числа PASCAL.

Kindr1 20 мар. 2020 г., 03:01:11 | 10 - 11 классы

1)Дано натуральное число?

1)Дано натуральное число.

Определить : а)произведение его цифр ; б)среднее арифметическое его цифр.

2)Даны целые числа p и q.

Получить все делители числа q, взаимно простые с p.

Сделайте пожалуйста на языке с#.

Аринка091297 26 окт. 2020 г., 04:57:21 | 10 - 11 классы

Даны два числа?

Даны два числа.

Найти среднее арифметическое их квадратов и среднее арифметическое их модулей.

Яблако 26 мар. 2020 г., 21:52:46 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Определите количество нечётных цифр в данном числе.

(Pascal).

Levashova2004 24 февр. 2020 г., 14:59:01 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите, кратна ли числу К сумма цифр в числе.

Яна509 23 окт. 2020 г., 14:42:39 | 1 - 4 классы

Дано четырёхзначное число определить является ли нечётным произведение его цифр?

Дано четырёхзначное число определить является ли нечётным произведение его цифр.

Ilyamatveev2020 9 июн. 2020 г., 18:02:10 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите среднее арифметическое нечётных цифр числа.

Katerinazam 26 сент. 2020 г., 18:57:19 | 10 - 11 классы

Дано целое число?

Дано целое число.

Подсчитать в нём произведение цифр, которые расположены на нечётных позициях.

На этой странице находится вопрос Дано целое число N?, относящийся к категории Информатика. По уровню сложности данный вопрос соответствует знаниям учащихся 10 - 11 классов. Здесь вы найдете правильный ответ, сможете обсудить и сверить свой вариант ответа с мнениями пользователями сайта. С помощью автоматического поиска на этой же странице можно найти похожие вопросы и ответы на них в категории Информатика. Если ответы вызывают сомнение, сформулируйте вопрос иначе. Для этого нажмите кнопку вверху.