Дано целое число N?

Информатика | 10 - 11 классы

Дано целое число N.

Определите среднее арифметическое нечётных цифр числа.

Ответить на вопрос
Ответы (1)
RockScar04 9 июн. 2020 г., 18:02:15

/ / PascalABC.

NET 3.

1, сборка 1239 от 08.

05. 2016

begin var n : = ReadInteger('n = ') ; var k : = 0 ; var s : = 0 ; while n> ; 0 do begin var d : = n mod 10 ; if n.

IsOdd then begin s + = d ; Inc(k) end ; n : = n div 10 end ; if k> ; 0 then Writeln('Cреднее значение нечетных цифр равно ', s / k) else Writeln('В числе нет нечетных цифр')

end.

Тестовое решение

n = 734522

Cреднее значение нечетных цифр равно 5.

Mogetta 19 окт. 2020 г., 11:02:34 | 5 - 9 классы

Здравствуйте)Вводится натуральное число?

Здравствуйте)Вводится натуральное число.

Определить среднее арифметическое его цифр.

Pascal) не могли бы помочь?

Bitcher 16 нояб. 2020 г., 02:20:12 | 5 - 9 классы

Паскаль?

Паскаль.

1 дано целое число N.

Вычислить среднее арифметическое всех чисел из диапазона от 1 до N.

2 дано целое число N.

Вывести на экран все нечётные числа из диапахона от 1 до N.

Вычислить их сумму.

Kostinsania 29 сент. 2020 г., 03:36:04 | 10 - 11 классы

Помогите плиз к понедельнику решить эту мега сложную задачу)Дано целое число K определите среднее арифметическое делителей данного числа PASCAL?

Помогите плиз к понедельнику решить эту мега сложную задачу)Дано целое число K определите среднее арифметическое делителей данного числа PASCAL.

Kindr1 20 мар. 2020 г., 03:01:11 | 10 - 11 классы

1)Дано натуральное число?

1)Дано натуральное число.

Определить : а)произведение его цифр ; б)среднее арифметическое его цифр.

2)Даны целые числа p и q.

Получить все делители числа q, взаимно простые с p.

Сделайте пожалуйста на языке с#.

Аринка091297 26 окт. 2020 г., 04:57:21 | 10 - 11 классы

Даны два числа?

Даны два числа.

Найти среднее арифметическое их квадратов и среднее арифметическое их модулей.

Mazepa1605 31 мая 2020 г., 08:40:24 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите среднее арифметическое нечётных цифр числа.

Яблако 26 мар. 2020 г., 21:52:46 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Определите количество нечётных цифр в данном числе.

(Pascal).

Levashova2004 24 февр. 2020 г., 14:59:01 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите, кратна ли числу К сумма цифр в числе.

Яна509 23 окт. 2020 г., 14:42:39 | 1 - 4 классы

Дано четырёхзначное число определить является ли нечётным произведение его цифр?

Дано четырёхзначное число определить является ли нечётным произведение его цифр.

Katerinazam 26 сент. 2020 г., 18:57:19 | 10 - 11 классы

Дано целое число?

Дано целое число.

Подсчитать в нём произведение цифр, которые расположены на нечётных позициях.

На этой странице вы найдете ответ на вопрос Дано целое число N?. Вопрос соответствует категории Информатика и уровню подготовки учащихся 10 - 11 классов классов. Если ответ полностью не удовлетворяет критериям поиска, ниже можно ознакомиться с вариантами ответов других посетителей страницы или обсудить с ними интересующую тему. Здесь также можно воспользоваться «умным поиском», который покажет аналогичные вопросы в этой категории. Если ни один из предложенных ответов не подходит, попробуйте самостоятельно сформулировать вопрос иначе, нажав кнопку вверху страницы.