Помогите написать программу на Паскале 1?

Информатика | 10 - 11 классы

Помогите написать программу на Паскале 1.

Написать функцию, подсчитывающую количество единиц в числе и с её помощью определить, в каком из двух чисел единиц больше.

Ответить на вопрос
Ответы (1)
AmerikaRon 19 авг. 2020 г., 19:20:25

Var s, s2 : string ;

function one(s : string) : integer ;

var

i, c : integer ;

begin c : = 0 ; for i : = 1 to length(s) do if (s[i] = '1') then c : = c + 1 ; result : = c ;

end ;

begin writeln('Введите первое число : ') ; readln(s) ; writeln('Введите второе число : ') ; readln(s2) ; if(one(s) > ; one(s2)) then write('В первом числе больше единиц') else write('Во втором числе больше единиц') ;

end.

MaksimKM 2 июл. 2020 г., 05:05:14 | 10 - 11 классы

Помогите пожалуйста составить программу на языке Pascal?

Помогите пожалуйста составить программу на языке Pascal!

Даны три числа, написать программу, подсчитывающую количество чисел, равных нулю.

Zvyagincevay 3 окт. 2020 г., 11:38:46 | 10 - 11 классы

1. Написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел?

1. Написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел.

2. Написать программу для нахождения числа отрицательных элементов в массиве из 10 знаковых чисел.

3. Написать программу для замены всех четных элементов массива из 10 беззнаковых чисел единицами 4.

Написать программу для замены всех нулевых элементов массива из 10 знаковых чисел единицами.

5. Написать программу для замены всех троек в массиве из 10 беззнаковых чисел пятерками.

NikitaNikitaNikita12 24 дек. 2020 г., 23:55:10 | 5 - 9 классы

Написать программу на паскале, которая вычислит точки пересечения двух функций?

Написать программу на паскале, которая вычислит точки пересечения двух функций.

Sofyadog 25 мая 2020 г., 07:21:44 | 10 - 11 классы

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел?

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел.

Написать в паскале.

Nastya132000 1 сент. 2020 г., 01:35:08 | 5 - 9 классы

Дано натуральное число?

Дано натуральное число.

Определить количество его нечетных делителей.

Написать программу паскаль).

Lerstweretina 11 апр. 2020 г., 14:38:14 | 10 - 11 классы

6. Написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел?

6. Написать программу для нахождения числа нечетных элементов в массиве из 10 беззнаковых чисел.

7. Написать программу для нахождения числа отрицательных элементов в массиве из 10 знаковых чисел 8.

Написать программу для замены всех четных элементов массива из 10 беззнаковых чисел единицами.

9. Написать программу для замены всех нулевых элементов массива из 10 знаковых чисел единицами 10.

Написать программу для замены всех троек в массиве из 10 беззнаковых чисел пятерками.

Viktoriuakr 27 июл. 2020 г., 23:03:20 | 10 - 11 классы

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше?

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше.

Нахождение количество цифр числа оформить в виде функции

Решение на паскале, написать программу.

Snkurmanov 19 июл. 2020 г., 00:07:53 | 10 - 11 классы

Помогите пожалуйста написать программу на Паскале (цикл с параметром) Напишите программу, подсчитывающую количество чисел из промежутка от 2 до 50, кратных 5 и 8, а также выводящую эти числа?

Помогите пожалуйста написать программу на Паскале (цикл с параметром) Напишите программу, подсчитывающую количество чисел из промежутка от 2 до 50, кратных 5 и 8, а также выводящую эти числа.

Мигка1 9 мар. 2020 г., 17:58:22 | 5 - 9 классы

Написать функцию, подсчитывающую количество цифр целого числа?

Написать функцию, подсчитывающую количество цифр целого числа.

Используя ее, определить, в каком из двух данных чисел больше цифр.

Kimkai1998 29 нояб. 2020 г., 04:03:18 | 5 - 9 классы

Написать программу которая может подсчитать количество различных чисел?

Написать программу которая может подсчитать количество различных чисел.

Паскаль.

Числа рандомные!

Перед вами страница с вопросом Помогите написать программу на Паскале 1?, который относится к категории Информатика. Уровень сложности соответствует учебной программе для учащихся 10 - 11 классов. Здесь вы найдете не только правильный ответ, но и сможете ознакомиться с вариантами пользователей, а также обсудить тему и выбрать подходящую версию. Если среди найденных ответов не окажется варианта, полностью раскрывающего тему, воспользуйтесь «умным поиском», который откроет все похожие ответы, или создайте собственный вопрос, нажав кнопку в верхней части страницы.