Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше?

Информатика | 10 - 11 классы

Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше.

Нахождение количество цифр числа оформить в виде функции

Решение на паскале, написать программу.

Ответить на вопрос
Ответы (1)
23ту 27 июл. 2020 г., 23:03:26

Function len(a : integer) : byte ;

begin result : = Length(IntToStr(a)) ;

end ;

var a, b : integer ;

begin for i : byte : = 1 to 5 do / / Убрав цикл, можно сэкономить память, не знаю насчёт ресурсов ЦП, но с циклом красивее begin readln(a) ; if (len(a) > ; len(b)) then b : = a ; end ; writeln(b) ;

end.

Coololenrogat 24 дек. 2020 г., 19:54:37 | 5 - 9 классы

Составить программу, подсчитывающую количество цифр числа n, сумму его цифр и определяющую его первую цифру?

Составить программу, подсчитывающую количество цифр числа n, сумму его цифр и определяющую его первую цифру.

Plyutadianka 10 мар. 2020 г., 10:38:09 | 10 - 11 классы

Двно целое число n?

Двно целое число n.

Составить программу нахождения количества цифр числа.

Winterbottom 13 июн. 2020 г., 22:55:51 | 5 - 9 классы

Дано целое число N?

Дано целое число N.

Составить программу нахождения количества цифр числа (Pascal ABC).

Wowwic200 11 окт. 2020 г., 16:06:25 | 5 - 9 классы

Составить программу?

Составить программу.

Дано натуральное число n.

Подсчитать количество цифр этого числа.

Polkapetrova200 13 мая 2020 г., 23:33:15 | 10 - 11 классы

Составить программу , определяющую в каком из данных двух чисел больше четных цифр, пожалуйста?

Составить программу , определяющую в каком из данных двух чисел больше четных цифр, пожалуйста.

Natalihar 16 апр. 2020 г., 09:03:30 | 5 - 9 классы

Написать программу с исаользованием функции?

Написать программу с исаользованием функции.

Дано N целых чисел.

Подсчитеть количество чисел, в записи которых нет цифры 8.

Zhazira2000 17 мая 2020 г., 22:26:20 | 5 - 9 классы

Помогите написать программу на Паскале : Найдите количество четных цифр в десятичной записи числа?

Помогите написать программу на Паскале : Найдите количество четных цифр в десятичной записи числа.

Troshchilova04 2 окт. 2020 г., 11:15:20 | 5 - 9 классы

Составьте программу нахождения количество цифр натурального числа n?

Составьте программу нахождения количество цифр натурального числа n.

Kenzzo 24 нояб. 2020 г., 17:16:23 | 5 - 9 классы

Написать программу которая считает количество цифр в числе и их сумму?

Написать программу которая считает количество цифр в числе и их сумму.

Паскаль.

Число вводится с клавиатуры.

Макс1242 30 авг. 2020 г., 06:54:32 | 5 - 9 классы

Помогите написать программу на языке Паскаль?

Помогите написать программу на языке Паскаль.

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4.

Программа получает на вход количество чисел в последовательности, а затем сами числа.

Кто правильно напишет поставлю лучшее решение!

Если вам необходимо получить ответ на вопрос Составить программу, определяющую, в каком из данных 5 чисел количество цифр больше?, относящийся к уровню подготовки учащихся 10 - 11 классов, вы открыли нужную страницу. В категории Информатика вы также найдете ответы на похожие вопросы по интересующей теме, с помощью автоматического «умного» поиска. Если после ознакомления со всеми вариантами ответа у вас остались сомнения, или полученная информация не полностью освещает тематику, создайте свой вопрос с помощью кнопки, которая находится вверху страницы, или обсудите вопрос с посетителями этой страницы.