Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел?

Информатика | 10 - 11 классы

Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел.

Написать в паскале.

Ответить на вопрос
Ответы (2)
Albinagerasimova 25 мая 2020 г., 07:21:48

Var s1, s2 : string ;

begin ;

writeln('Введите исходные знаки') ;

readln(s1) ;

readln(s2) ;

if ((s1< ; > ; ' - ') and (s1< ; > ; ' + ')) or ((s2< ; > ; ' - ') and (s2< ; > ; ' + ')) then

begin ;

writeln('Ошибка') ;

exit ;

end ;

if ((s1 = ' + ') and (s2 = ' + ')) or ((s1 = ' - ') and (s2 = ' - ')) then writeln(' + ') else writeln(' - ') ;

end.

С числами :

var a, b : integer ;

begin ;

writeln('Делимое : ') ;

readln(a) ;

writeln('Делитель') ;

readln(b) ;

if b = 0 then

begin ;

writeln('Нельзя делить на ноль.

Если это, конечно, не JavaScript.

') ;

exit ;

end ;

if a = 0 then

begin ;

writeln('0') ;

exit ;

end ;

if ((a> ; 0) and (b> ; 0)) or ((a< ; 0) and (b< ; 0)) then writeln(' + ') else writeln(' - ') ;

end.

S9ba1 25 мая 2020 г., 07:21:54

Var a, b : real ;

begin Write('Введите через пробел два числа : ') ; Read(a, b) ; if b = 0 then Writeln('Результат деления не определен') else if a * b> ; 0 then Writeln('Частное a / b имеет положительный знак') else if a = 0 then Writeln('Частное a / b равно нулю') else Writeln('Частное a / b имеет отрицательный знак')

end.

Тестовое решение :

Введите через пробел два числа : 8 - 4

Частное a / b имеет отрицательный знак.

Яна89011 31 окт. 2020 г., 17:17:10 | 5 - 9 классы

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел?

Написать программу в паскале определяющую и выводящую наибольшее из трех чисел.

Dasa1110268 27 апр. 2020 г., 20:03:36 | 1 - 4 классы

Написать программу, которая запрашивает ввод двух целых чисел и проделывает над ними операции умножения и деления?

Написать программу, которая запрашивает ввод двух целых чисел и проделывает над ними операции умножения и деления.

Аліна199922 3 авг. 2020 г., 03:20:05 | 10 - 11 классы

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения?

Написать программу для нахождения произведения двух целых чисел х и у без использования операции умножения.

Паскаль.

Frol12112001 9 окт. 2020 г., 04:36:25 | 5 - 9 классы

Требутся ввести 20 чисел и посчитать сумму этих чисел?

Требутся ввести 20 чисел и посчитать сумму этих чисел.

Мы проходим сейчас язык паскалия и этт нужно написаьь в программе чтоб оеа работала.

Olesay3478 23 июл. 2020 г., 16:15:24 | 5 - 9 классы

Найти сумму двух чисел А и Б написать код программы на языке паскаль?

Найти сумму двух чисел А и Б написать код программы на языке паскаль.

Смышлённый 30 окт. 2020 г., 17:54:32 | 5 - 9 классы

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел?

Написать программу в паскале которая будет вводить целые числа до 0, подсчитать среднее арифметическое этих чисел.

Daiyanakz2 1 дек. 2020 г., 17:21:39 | 5 - 9 классы

Написать программу для нахождения суммы первых пяти нечетных чисел (Паскаль)?

Написать программу для нахождения суммы первых пяти нечетных чисел (Паскаль).

Leonid1bmx 8 окт. 2020 г., 12:20:21 | 5 - 9 классы

Написать в Паскале, с клавиатуры набрать 15 чисел, программа считает сумму четных чисел?

Написать в Паскале, с клавиатуры набрать 15 чисел, программа считает сумму четных чисел.

Nurtjt99 9 дек. 2020 г., 14:45:10 | 5 - 9 классы

1. Найти среднее арифметическое и среднее геометрическое двух чисел?

1. Найти среднее арифметическое и среднее геометрическое двух чисел.

Написать программу (Паскаль).

Белый1нигер 19 авг. 2020 г., 19:20:21 | 10 - 11 классы

Помогите написать программу на Паскале 1?

Помогите написать программу на Паскале 1.

Написать функцию, подсчитывающую количество единиц в числе и с её помощью определить, в каком из двух чисел единиц больше.

Вопрос Написать программу определения знака результата деления двух чисел в зависимости от знаков этих чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 10 - 11 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.