Program naim4 ;var a, b, c, d, min : real ; begin ;writeln('введите 4 числа') ;readln ;min : = a ;if b < ; min then min : = b ;if c < ; min then min : = c ;if d < ; min then min : = d ;writeln('?

Информатика | 5 - 9 классы

Program naim4 ;

var a, b, c, d, min : real ; begin ;

writeln('введите 4 числа') ;

readln ;

min : = a ;

if b < ; min then min : = b ;

if c < ; min then min : = c ;

if d < ; min then min : = d ;

writeln('минимальное ', min) ;

readln ;

end.

Нужно найти минимальное число из 4 данных.

Что не так?

Ответить на вопрос
Ответы (1)
Liyaparf03 22 апр. 2020 г., 02:55:12

4 строка, там нужно

readln(a, b, c, d) ;

Nastya2551 8 нояб. 2020 г., 03:34:06 | 10 - 11 классы

Объясните, пожалуйста, как будет работать программа, если в 8 строке будет i : = ivar a : array [1?

Объясните, пожалуйста, как будет работать программа, если в 8 строке будет i : = i

var a : array [1.

5] of integer ;

i, min, max, x : integer ;

begin

for i : = 1 to 5 do begin a[i] : = random(10) ; writeln(a[i]) ; end ;

max : = a[1] ;

min : = a[1] ;

for i : = i to 5 do begin

if a[i]> ; max then max : = a[i] ;

if a[i]< ; min then min : = a[i] ;

end ;

writeln('max = ', max) ;

writeln('min = ', min) ;

end.

Bagira17 2 мая 2020 г., 03:43:31 | 5 - 9 классы

Помогите плиииз))) Надо написать блок - схему на эту программу?

Помогите плиииз))) Надо написать блок - схему на эту программу.

Program a2 ; var a, b, c, min : real ; begin Writeln (‘Введите три числа’) ; readln (а, b, с) ; min : = а ; If b< ; min then min : = b ; if c< ; min then min : = c ; writeln (‘min = ' , min) ; end.

Annhomak 1 мая 2020 г., 13:17:57 | 5 - 9 классы

Это правильно ?

Это правильно ?

Это информатика 9 класс.

Задача.

Среди 4 чисел найти максимум и минимум :

program zadacha ;

var

a, b, c, d, max, min : real ;

begin

writeln('vvedite kofficient a, b, c, d') ;

If a> ; b then max : = a else min : = b ;

If c> ; d then max : = c else min : = d ;

If a> ; c then max : = a else min : = c ;

end.

Suadelle 15 окт. 2020 г., 20:27:26 | 10 - 11 классы

Program z6_2 ; uses crt ; const n = 6 ; var a : array[1?

Program z6_2 ; uses crt ; const n = 6 ; var a : array[1.

6]of real ; i : integer ; begin clrscr ; Writeln('введите элемент массива') ; for i : = 1 to 6 do readln (a[i]) ; if min min : = a[i] ; writeln ('min = ', min : 7 : 3) ; Repeat until keypressed ; end.

Подскажите где ошибка В Pascal Текст : Составить программу, которая выводит на экран минимальный элемент массива Х и его индекс Х = {1, 3, 5, 2, - 12, 0}.

Marta134 18 сент. 2020 г., 05:01:56 | 10 - 11 классы

Program pr ; var mas : array[1?

Program pr ; var mas : array[1.

10] of integer ; i, min, ind : integer ; Begin randomize ; For i : = 1 to 10 do Begin mas[i] : = Random(100) ; write(mas[i], ' ') ; End ; writeln() ; min : = mas[1] ; For i : = 1 to 10 do Begin If (min> ; mas[i]) then End ; write('Минимальный элемент массива : ', min) ; End.

Что не верно?

Вот задача : Дан одномерный массив А длиной N.

Определить, на какой позиции нахо - дится минимальный элемент массива.

MAX30rus 19 авг. 2020 г., 08:02:09 | 10 - 11 классы

Найти max{min(a, b), min(c, d)} Написать на Паскале?

Найти max{min(a, b), min(c, d)} Написать на Паскале.

Оператор if без всяких function.

AsyaAsyaasya 25 сент. 2020 г., 00:37:57 | 10 - 11 классы

СРОЧНО?

СРОЧНО!

Даны различные действительные числа x, y, z, d.

Найти max (min (x, y), min (x, z), min (z, d)).

Решить в Делфи 7.

Зая1983 4 авг. 2020 г., 20:11:01 | 10 - 11 классы

Найти max{min{ a, b }, min{c , d }} на языке c?

Найти max{min{ a, b }, min{c , d }} на языке c.

Zaika220681 25 нояб. 2020 г., 06:38:19 | 10 - 11 классы

Выдает ошибку Операция > ; не может быть применена к типам boolean и integer Program qq ; var a, b, c, max, min, med : integer ; begin writeln ('введите три числа') ; read (a, b, c) ; if c> ; b>?

Выдает ошибку Операция > ; не может быть применена к типам boolean и integer Program qq ; var a, b, c, max, min, med : integer ; begin writeln ('введите три числа') ; read (a, b, c) ; if c> ; b> ; a then begin max : = c ; med : = b ; min : = a ; End ; if b> ; a> ; c then begin max : = b ; med : = a ; min : = c ; End ; if a> ; c> ; b then begin max : = a ; med : = c ; min : = b ; End ; writeln ('наибольшее число', max) ; writeln ('среднее число', med) ; writeln ('наименьшее число', min) ; End.

GioZam 1 дек. 2020 г., 11:19:33 | 10 - 11 классы

Задание :Ввести массив в данную программуvarn, i, a, min : integer ;beginreadln(n) ;min : = 30001 ;for i : = 1 to n dobeginreadln(a) ;if (a mod 10 = 4) and (a < min) thenmin : = a ;end ;writeln(min)en?

Задание :

Ввести массив в данную программу

var

n, i, a, min : integer ;

begin

readln(n) ;

min : = 30001 ;

for i : = 1 to n do

begin

readln(a) ;

if (a mod 10 = 4) and (a < min) then

min : = a ;

end ;

writeln(min)

end.

На этой странице находится вопрос Program naim4 ;var a, b, c, d, min : real ; begin ;writeln('введите 4 числа') ;readln ;min : = a ;if b &lt ; min then min : = b ;if c &lt ; min then min : = c ;if d &lt ; min then min : = d ;writeln('?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.