Задача 1?

Информатика | 5 - 9 классы

Задача 1.

Введено число.

Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе Задача 2.

Введено три числа.

Определить количество четных из них, больших пяти Задача 3.

Введено трехзначное число, вывести это число с отсортированными по порядку цифрами.

Ответить на вопрос
Ответы (1)
Danelka25 22 окт. 2020 г., 01:06:21

Задача 1.

Var a, k, l, m : Integer ;

begin

s : = 0 ;

writeln ('Введите число') ;

readln(a) ;

if (a> ; = 10) and (a< ; = 999) then

k : = a div 100 ;

l : = k div 10 ;

m : = a mod 10 ;

s : = k + m + l ;

writeln ('Сумма цифр в числе равна', s) ;

end.

Задача 2.

Var i, a, s : Integer ;

begin

s : = 0 ;

for i : = 1 to 3 do

begin

writeln ('Введите число №', i) ;

readln(a) ;

if (a> ; 5) and (a mod 5 = 0) then

inc(s) ;

end ;

writeln('Количество четных чисел, которые делятся на 5 - ', s) ;

end.

Задача 3

var a, b, c, d, max, med, min : Integer ;

begin

writeln ('Введите число') ;

readln(a) ;

b : = a div 100 ;

c : = b div 10 ;

d : = a mod 10 ;

if (b< ; c) and (b< ; d) then

min : = b ;

if (c< ; b) and (c< ; d) then

min : = c ;

if (d< ; c) and (d< ; b) then

min : = d ;

if (b> ; c) and (b> ; d) then

max : = b ;

if (c> ; b) and (c> ; d) then

max : = c ;

if (d> ; c) and (d> ; b) then

max : = d ;

if (b> ; c) and (b< ; d) or(b< ; c) and (b> ; d)then

med : = b ;

if (c> ; b) and (c< ; d) or(c< ; b) and (c> ; d)then

med : = c ;

if (d> ; c) and (d< ; b) or(d< ; c) and (d> ; b)then

med : = d ;

writeln(min, med, max) ;

end.

Tltgorod 27 мар. 2020 г., 12:10:50 | 5 - 9 классы

По заданному трехзначному числу вывести на экран число состоящее из этих цифр, но в обратном порядке Задача в паскале Помогите с решением?

По заданному трехзначному числу вывести на экран число состоящее из этих цифр, но в обратном порядке Задача в паскале Помогите с решением.

Alisa16 10 дек. 2020 г., 02:58:32 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Akdjsfw 30 янв. 2020 г., 17:02:43 | 5 - 9 классы

Введено трехзначное число?

Введено трехзначное число.

Если сумма его цифр нечетна, то увеличить число вдвое.

Помогите пожалуйста.

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Лили20151 10 сент. 2020 г., 02:02:35 | 5 - 9 классы

Составить программу по задаче :Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное"?

Составить программу по задаче :

Дано целое число, если число трехзначное, то вывести цифры этого числа, иначе вывести текст "число не трехзначное".

Inessik 16 апр. 2020 г., 08:23:38 | 10 - 11 классы

С клавиатуры вводится трёхзначное число?

С клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

DanielRuss 2 апр. 2020 г., 04:07:08 | 10 - 11 классы

Клавиатуры вводится трёхзначное число?

Клавиатуры вводится трёхзначное число.

Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях.

Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».

Yuliyaplavskay 30 апр. 2020 г., 13:30:11 | 5 - 9 классы

С клавиатуры вводятся числа, определить сумму и количество, пока не введено 98?

С клавиатуры вводятся числа, определить сумму и количество, пока не введено 98.

Аленький 16 сент. 2020 г., 03:07:40 | 10 - 11 классы

Помогите, пожалуйста, написать программы на Паскале?

Помогите, пожалуйста, написать программы на Паскале.

Задачи : 1.

Сгенерировать случайное число, вывести на экран это число, а также сумму и произведение его цифр.

2. Вводятся целые числа до первого числа, которое меньше двух.

Определить, сколько простых чисел было введено.

Marina19998 8 янв. 2020 г., 17:51:43 | 5 - 9 классы

Задача введите 3 числа четные числа возвести в квадрат нечётное оставить без изменений программа (паскаль)?

Задача введите 3 числа четные числа возвести в квадрат нечётное оставить без изменений программа (паскаль).

На этой странице сайта размещен вопрос Задача 1? из категории Информатика с правильным ответом на него. Уровень сложности вопроса соответствует знаниям учеников 5 - 9 классов. Здесь же находятся ответы по заданному поиску, которые вы найдете с помощью автоматической системы. Одновременно с ответом на ваш вопрос показаны другие, похожие варианты по заданной теме. На этой странице можно обсудить все варианты ответов с другими пользователями сайта и получить от них наиболее полную подсказку.