Всем привет?

Информатика | 10 - 11 классы

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Ответить на вопрос
Ответы (1)
Reina86 2 окт. 2020 г., 01:37:08

/ / 2)

var a : integer ; m : array[0.

9] of integer ;

begin read(a) ; while a > ; 0 do begin m[a mod 10] : = m[a mod 10] + 1 ; if m[a mod 10] > ; = 2 then begin write('Есть') ; break ; end ; a : = a div 10 ; end ; if a = 0 then write('Нет') ;

end.

1)

var a, s, i : integer ;

begin read(a) ; s : = 0 ; while a > ; 0 do begin s : = s + a mod 10 ; a : = a div 10 ; end ; write(s) ;

end.

Opsdas 15 июн. 2020 г., 23:25:08 | 10 - 11 классы

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом?

Ввести целое число и определить верно ли что в его записи есть две одинаковые цифры стоящие рядом.

Написать программу в Паскале без массивов.

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Дживс 14 сент. 2020 г., 21:37:14 | 5 - 9 классы

Составьте программу вычисления суммы цифр двузначного числа а?

Составьте программу вычисления суммы цифр двузначного числа а.

Значение а введите с клавиатуры Пример ввода : 35 Пример вывода : Сумма цифр числа 35 равна 8.

Alisa16 10 дек. 2020 г., 02:58:32 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Zdance 8 июн. 2020 г., 08:11:47 | 10 - 11 классы

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания?

Ввести целое число и определить верно ли что все его цифры расположены в порядке возрастания.

Milana4569 25 авг. 2020 г., 21:39:45 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Но нужно сделать программу так чтобы она работала с любым числом.

Kcy81 12 июл. 2020 г., 17:04:03 | 5 - 9 классы

Ввести целое число и определить, верно ли, что все его цифры четные?

Ввести целое число и определить, верно ли, что все его цифры четные.

(Кумир).

Levashova2004 24 февр. 2020 г., 14:59:01 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите, кратна ли числу К сумма цифр в числе.

Qwedcbydd 22 окт. 2020 г., 01:06:19 | 5 - 9 классы

Задача 1?

Задача 1.

Введено число.

Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе Задача 2.

Введено три числа.

Определить количество четных из них, больших пяти Задача 3.

Введено трехзначное число, вывести это число с отсортированными по порядку цифрами.

Котубийца 1 авг. 2020 г., 08:24:58 | 5 - 9 классы

Задача по информатике?

Задача по информатике.

Найти сумму цифр данного целого числа.

Программа.

Паскаль.

На этой странице находится ответ на вопрос Всем привет?, из категории Информатика, соответствующий программе для 10 - 11 классов. Чтобы посмотреть другие ответы воспользуйтесь «умным поиском»: с помощью ключевых слов подберите похожие вопросы и ответы в категории Информатика. Ответ, полностью соответствующий критериям вашего поиска, можно найти с помощью простого интерфейса: нажмите кнопку вверху страницы и сформулируйте вопрос иначе. Обратите внимание на варианты ответов других пользователей, которые можно не только просмотреть, но и прокомментировать.