Ввести целое число и найти сумму его цифр?

Информатика | 5 - 9 классы

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Ответить на вопрос
Ответы (1)
Katik03 10 дек. 2020 г., 02:58:38

Var i, number : integer ;

sum : real ;

begin

sum : = 0.

0 ;

write('write number : ') ; readln(number) ;

while( number > ; 0 ) do

begin

sum : = sum + ( number mod 10 ) ; number : = number div 10 ;

end ;

writeln(sum) ;

end.

Adelisamolkova 1 февр. 2020 г., 17:37:02 | 10 - 11 классы

В Паскале?

В Паскале!

Ввести целое число и найти сумму его цифр 1) Ввести целое Число - 1234 - Сумма цифр числа равна 10 2) Ввести целое число и определить, верно ли, что в его записи есть 2 одинаковые цифры.

Пример.

Введите целое число - 1234 - НЕТ 1224 - ДА.

Помогите пожалуйста!

))).

Дживс 14 сент. 2020 г., 21:37:14 | 5 - 9 классы

Составьте программу вычисления суммы цифр двузначного числа а?

Составьте программу вычисления суммы цифр двузначного числа а.

Значение а введите с клавиатуры Пример ввода : 35 Пример вывода : Сумма цифр числа 35 равна 8.

Milana4569 25 авг. 2020 г., 21:39:45 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Но нужно сделать программу так чтобы она работала с любым числом.

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Nastenkasergee 11 сент. 2020 г., 21:40:15 | 10 - 11 классы

Программу на Си?

Программу на Си.

Найти все трехзначные числа, сумма цифр которых равна данному целому числу.

ЕкАтЕрИнА01 22 авг. 2020 г., 08:19:51 | 5 - 9 классы

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа?

С клавиатуры вводится любое целое трёхзначное число, найти сумму цифр этого числа.

(Dev C + + ).

Fatik41 21 мар. 2020 г., 13:20:24 | 10 - 11 классы

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу?

Найдите все трехзначные числа, сумма цифр которых равна данному целому числу.

(pascal).

Катюшка365 20 сент. 2020 г., 10:36:16 | 5 - 9 классы

Ввести натуральное число и найти сумму цифр?

Ввести натуральное число и найти сумму цифр.

На языке питон прошу.

Levashova2004 24 февр. 2020 г., 14:59:01 | 10 - 11 классы

Дано целое число N?

Дано целое число N.

Определите, кратна ли числу К сумма цифр в числе.

Котубийца 1 авг. 2020 г., 08:24:58 | 5 - 9 классы

Задача по информатике?

Задача по информатике.

Найти сумму цифр данного целого числа.

Программа.

Паскаль.

Вы открыли страницу вопроса Ввести целое число и найти сумму его цифр?. Он относится к категории Информатика. Уровень сложности вопроса – для учащихся 5 - 9 классов. Удобный и простой интерфейс сайта поможет найти максимально исчерпывающие ответы по интересующей теме. Чтобы получить наиболее развернутый ответ, можно просмотреть другие, похожие вопросы в категории Информатика, воспользовавшись поисковой системой, или ознакомиться с ответами других пользователей. Для расширения границ поиска создайте новый вопрос, используя ключевые слова. Введите его в строку, нажав кнопку вверху.