Введено трехзначное число?

Информатика | 5 - 9 классы

Введено трехзначное число.

Если сумма его цифр нечетна, то увеличить число вдвое.

Помогите пожалуйста.

Ответить на вопрос
Ответы (1)
Anarhict596 30 янв. 2020 г., 17:02:45

Var n, x, y : integer ;

begin

readln(n) ;

y : = n ;

while y> ; 0 do begin x : = x + n mod 10 ; y : = y div 10 ; end ;

if x mod 2 = 0 then n : = n * 2 ;

writeln('Ответ : ', n) ;

end.

Ignatyev20002 2 апр. 2020 г., 19:32:32 | 5 - 9 классы

Трехзначное число, кратно ли сумма его цифр 6?

Трехзначное число, кратно ли сумма его цифр 6.

Alisa16 10 дек. 2020 г., 02:58:32 | 5 - 9 классы

Ввести целое число и найти сумму его цифр?

Ввести целое число и найти сумму его цифр.

Пример : Введите целое число : 1234 Сумма цифр числа 1234 равна 10.

Podgornyyn 25 нояб. 2020 г., 03:16:45 | 10 - 11 классы

Вводится целое положительное число?

Вводится целое положительное число.

Найти наименьшую нечетную цифру в числе.

Если в числе нет нечетных цифр, то вывести надпись "В числе нет нечетных цифр".

Gosha8 2 окт. 2020 г., 01:37:03 | 10 - 11 классы

Всем привет?

Всем привет!

Помогите пожалуйста по информатике.

Задача : ввести целое число и найти сумму его цифр.

Пример : введите целое число : 1234.

Сумма цифр числа 1234 равна 10.

Задача : сумма цифр ввести целое число и определить верно ли, что в его записи есть 2 одинаковые цифры.

Пример : введите целое число 1234 нет введите целое число 1224 да.

Умник2002 3 авг. 2020 г., 04:33:03 | 5 - 9 классы

Дано трехзначное и четырехзначное число?

Дано трехзначное и четырехзначное число.

В каком числе сумма цифр больше?

Напишите, пожалуйста, программу для Pascal.

ABC.

Устланная 24 апр. 2020 г., 04:09:29 | 10 - 11 классы

Pascal ?

Pascal .

Введено трёхзначное число.

Если сумма его цифр нечетна, но увеличить чисто вдвое.

Vladik310800 5 янв. 2020 г., 14:22:54 | 5 - 9 классы

Дано трехзначное число?

Дано трехзначное число.

Найдите сумму его цифр.

Qwedcbydd 22 окт. 2020 г., 01:06:19 | 5 - 9 классы

Задача 1?

Задача 1.

Введено число.

Известно, что оно может быть равно от 10 до 999, определить сумму цифр в этом числе Задача 2.

Введено три числа.

Определить количество четных из них, больших пяти Задача 3.

Введено трехзначное число, вывести это число с отсортированными по порядку цифрами.

Неумная 6 дек. 2020 г., 11:29:40 | 5 - 9 классы

Дано число?

Дано число.

Определить чему равна сумма нечетных цифр в этом числе.

Андрейкораблёв1456 19 мар. 2020 г., 19:40:55 | 5 - 9 классы

Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста?

Сумма и произведение цифр случайного трехзначного числа Число вводится с клавиатуры В паскале сделайте пожалуйста.

На странице вопроса Введено трехзначное число? из категории Информатика вы найдете ответ для уровня учащихся 5 - 9 классов. Если полученный ответ не устраивает и нужно расшить круг поиска, используйте удобную поисковую систему сайта. Можно также ознакомиться с похожими вопросами и ответами других пользователей в этой же категории или создать новый вопрос. Возможно, вам будет полезной информация, оставленная пользователями в комментариях, где можно обсудить тему с помощью обратной связи.