Задание : Написать программу вычисляющую сумму четырех чисел?

Информатика | 5 - 9 классы

Задание : Написать программу вычисляющую сумму четырех чисел.

(PascalABC) Решение : Program sum ; Var a, b, c, d, summa : Integer ; Begin Readln(a, b, c, d) ; summa : = a + b + c + d Writeln('Ответ равен : ', summa) ; End.

На предпоследней строчке(перед End) выдает ошибку - встречено writeln а ожидалось ' ; ' Что не так?

Ответить на вопрос
Ответы (1)
Veronica771 3 сент. 2020 г., 23:45:40

В строчке перед writeln пропущена ' ; '.

Valyaandrosova 10 мая 2020 г., 02:35:19 | 10 - 11 классы

ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ Изменить программу которая ниже так, чтобы в ней подсчитывалось и выдавалось ?

ПРОГРАММИРОВАНИЕ В ПАСКАЛЬ Изменить программу которая ниже так, чтобы в ней подсчитывалось и выдавалось !

ОДНОВРЕМЕННО!

3 ответа, A НЕ 3 РАЗНЫЕ ПРОГРАММЫ а) количество цифр числа ; б) произведение цифр, больших 0 ; в) сумма цифр, меньших 3.

ПРОГРАММА.

Ввести с клавиатуры натуральное число.

Найти сумму его цифр.

Решение : Programm Sum ; Var chislo ; word ; {число, введенное с клавиатуры} tchifra, Summa : integer ; {tchifra - правая цифра}} begin Write ('введи число') ; Readln (chislo) ; Summa : = 0 ; Repeat tchifra : - chislo mod 10 ; {скопировали правую цифру} Summa : = Summa + tchifra ; chislo : = chislo div 10 {оставили от числа левую часть} Until chislo = 0 ; {выход из цикла, если нет больше цифр} Writeln ('сумма цифр = ', Summa) ; Readln end.

Учени10101010101010 15 дек. 2020 г., 09:59:59 | 5 - 9 классы

Прошу вас, помогите?

Прошу вас, помогите!

Решается оценка!

Найдите ошибки в программе 1)Program z1 ; var a : integer ; begin a : = 10 ; while a< ; 5 do writeln(a) ; a : = a + 1 ; End.

2)Program z2 ; var a, s : integer ; begin a : = 1 ; s : = 0 ; while a< ; 10 do begin s : = s + a / 2 ; end ; writeln(s) ; end.

Vfrc01112004 24 июл. 2020 г., 20:16:09 | 10 - 11 классы

Объяснить, что означает каждая строчка : Program sum_mas ; uses Crt ; Var i : integer ; sum : real ; M : array[1?

Объяснить, что означает каждая строчка : Program sum_mas ; uses Crt ; Var i : integer ; sum : real ; M : array[1.

5] of Real ; begin WriteLn('Введите число m[', i, '] = ') ; readln(m[i]) ; end ; Sum : = 0 ; For i : = 1 to 5 do Sum : = sum + m[i] ; Writeln('сумма = ', sum) ; readln ; end.

140568 18 дек. 2020 г., 17:35:00 | 10 - 11 классы

Составьте блок - схему по готовой программе?

Составьте блок - схему по готовой программе.

PROGREM summa ; VAR A, S : REAL ; BEGIN S ; = 0 ; A : = 0.

2 ; WHILE A< ; = 2 DO BEGIN S : = S + A ; A : = A + 0.

1 ; END ; WRITELN('СУММА = ', S : 15 : 2) ; END.

14013 10 мая 2020 г., 01:22:45 | 10 - 11 классы

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе?

Объяснить, в чем заключается синтаксическая ошибка (или ошибки) в приведенной программе.

Написать тот вариант программы, который, по Вашему мнению, будет правильным.

Program My_Error ; Var X, Y, Сумма : Integer ; Begin WriteLn( Введите значение X) ; ReadLn(X) ; WriteLn( Введите значение Y) ; ReadLn(Y) ; Сумма = X + Y ; WriteLn(Сумма) End.

Katya284 22 мая 2020 г., 22:41:49 | 5 - 9 классы

В данном фрагменте программы : program error ; begin SuMmA : = 25 - 14 ; end?

В данном фрагменте программы : program error ; begin SuMmA : = 25 - 14 ; end.

Ошибкой является : а)некорректное имя программы б) не определённое имя переменной в) некорректное имя переменной г) запись арифметического выражения?

P. S.

Мне кажется, что это ответ б).

Ema999 27 апр. 2020 г., 17:11:38 | 5 - 9 классы

Как записать программу сложения чисел 2 + 3 в Паскаль ?

Как записать программу сложения чисел 2 + 3 в Паскаль ?

Program summa ; var a, b, c : integer ; begin Что нужно дальше ?

AvEnTaDoR005 25 сент. 2020 г., 12:43:18 | 5 - 9 классы

Program TELESHOP ; var x : real ; begin writeln ('?

Program TELESHOP ; var x : real ; begin writeln ('.

') ; write ('.

') ; write ('.

') ; readln (x) ; if x< ; = 1 then begin if x = 1 then begin writeln ('.

') ; writeln ('.

') ; end else begin writeln ('.

') ; end ; * else begin writeln ('.

') ; end end.

* - место ошибки.

"встречено 'else', а ожидалось оператор" Вопрос : в чем ошибка?

Spasibo123 5 февр. 2020 г., 18:45:06 | 10 - 11 классы

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End?

Что напечатает данная программа : Var x : = Integer Begin x : = 2 WriteLn('x + 1 = ', x) End.

Sashakolesnsk2 20 дек. 2020 г., 18:01:57 | 10 - 11 классы

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3?

Найди ошибку в программе Program a1 ; Var a : integer ; b : real ; begin a : = 100 ; b : = 2, 5 ; writeln (a, b) ; a : = a + b / 3.

5 ; writeln (a) ; end.

Вопрос Задание : Написать программу вычисляющую сумму четырех чисел?, расположенный на этой странице сайта, относится к категории Информатика и соответствует программе для 5 - 9 классов. Если ответ не удовлетворяет в полной мере, найдите с помощью автоматического поиска похожие вопросы, из этой же категории, или сформулируйте вопрос по-своему. Для этого ключевые фразы введите в строку поиска, нажав на кнопку, расположенную вверху страницы. Воспользуйтесь также подсказками посетителей, оставившими комментарии под вопросом.