Дано целое двузначное число М?

Информатика | 10 - 11 классы

Дано целое двузначное число М.

Разработайте схему алгоритма, который вычисляет сумму всех двузначных чисел, начиная с числа М.

Используйте цикл ПОКА.

Желательно на языке Паскаль.

Ответить на вопрос
Ответы (1)
Маришка1996 13 февр. 2020 г., 03:12:23

Схема и программа вместе :

Program sum ;

var M, b, c : integer ;

begin

writeln('Введите число от 10 до 99 : ') ;

readln(M) ;

c : = M ;

if (M< ; 10) or (M> ; 99) then b : = 0

else

while (M< ; 100) do

begin

b : = b + M ;

inc(M) ;

end ;

writeln('Сумма всех двухзначных чисел начиная от ', c, ' : ', b) ;

end.

Gukaf4 14 апр. 2020 г., 04:16:55 | 10 - 11 классы

1) Определить, является ли заданное целое число а двузначным числом?

1) Определить, является ли заданное целое число а двузначным числом.

(Разветвляющийся алгоритм) 2) Вывести все нечетные однозначные числа.

(Цикл) 3) Найти сумму нечетных элементов одномерного массива.

(Массив) все в паскале.

Vodoleichik 4 янв. 2020 г., 10:58:46 | 5 - 9 классы

Алгоритм и программа вычисления суммы 2 нечетных двузначных чисел пока сумма не станет 150 ?

Алгоритм и программа вычисления суммы 2 нечетных двузначных чисел пока сумма не станет 150 .

Используя цикл с "параметром" "ДО".

Spider145 21 апр. 2020 г., 21:48:28 | 10 - 11 классы

Цикл с параметром в паскале?

Цикл с параметром в паскале.

Найти все двузначные числа, в записи которых есть цифра 5.

Gevork65 8 июл. 2020 г., 03:50:21 | 10 - 11 классы

Циклы с постусловиями?

Циклы с постусловиями.

Разработать схему алгоритма и написать программный код на языке Паскаль.

Используя оператор Repeat Until.

Kilmetova72 17 сент. 2020 г., 02:04:14 | 5 - 9 классы

Домашнее задание :1?

Домашнее задание :

1.

Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр.

2. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет число, образованное перестановкой цифр исходного числа.

3. Запишите на языке Паскаль программу, которая для произвольного трехзначного числа определяет сумму его цифр.

Corut 23 нояб. 2020 г., 04:08:31 | 5 - 9 классы

Найти сумму всех двузначных чисел?

Найти сумму всех двузначных чисел.

Решить используя цикл с параметром.

(Паскаль).

Nastya69691 18 июл. 2020 г., 21:57:02 | 10 - 11 классы

Решите пожалуйста задачу в паскаль?

Решите пожалуйста задачу в паскаль.

Найти все целые двузначные числа, сумма цифр в которых равна 8.

Viltoria 14 мар. 2020 г., 02:51:25 | 5 - 9 классы

Дано все двузначные числа?

Дано все двузначные числа.

Найти количество и сумму кратных 5 (Язык Паскаль).

Милашка2011 8 июн. 2020 г., 12:58:50 | 5 - 9 классы

Напишите программу, которая вычисляет сумму всех двузначных чисел, на ПАСКАЛЬ?

Напишите программу, которая вычисляет сумму всех двузначных чисел, на ПАСКАЛЬ.

Иванова4 2 нояб. 2020 г., 15:31:00 | 1 - 4 классы

Составить блок - схему алгоритма вычисления суммы всех двузначных чисел?

Составить блок - схему алгоритма вычисления суммы всех двузначных чисел.

На этой странице сайта вы найдете ответы на вопрос Дано целое двузначное число М?, относящийся к категории Информатика. Сложность вопроса соответствует базовым знаниям учеников 10 - 11 классов. Для получения дополнительной информации найдите другие вопросы, относящимися к данной тематике, с помощью поисковой системы. Или сформулируйте новый вопрос: нажмите кнопку вверху страницы, и задайте нужный запрос с помощью ключевых слов, отвечающих вашим критериям. Общайтесь с посетителями страницы, обсуждайте тему. Возможно, их ответы помогут найти нужную информацию.