Алгоритм и программа вычисления суммы 2 нечетных двузначных чисел пока сумма не станет 150 ?

Информатика | 5 - 9 классы

Алгоритм и программа вычисления суммы 2 нечетных двузначных чисел пока сумма не станет 150 .

Используя цикл с "параметром" "ДО".

Ответить на вопрос
Ответы (1)
Carine1 4 янв. 2020 г., 10:58:51

Как - то условие не очень понятно.

Если требуется найти сумму ДВУХ чисел, то программа может быть такой :

var a1, a2, s : integer ;

begin

a1 : = 11 ;

a2 : = 13 ;

repeat

a1 : = a2 ;

a2 : = a2 + 2 ;

s : = a1 + a2 ;

until s> ; = 150 ;

writeln(a1, ' + ', a2, ' = ', s) ;

end.

Результат работы программы :

75 + 77 = 152

Если нужно найти сумму 11 + 13 + 15 + .

, по ка не получится > ; = 150, то это можно сделать так :

var a, s : integer ;

begin

a : = 11 ;

s : = 0 ;

repeat

write(a, ' + ') ;

s : = s + a ;

a : = a + 2 ;

until s> ; = 150 ;

writeln(' = ', s) ;

end.

Результат :

11 + 13 + 15 + 17 + 19 + 21 + 23 + 25 + 27 + = 171.

Наталия210 21 янв. 2020 г., 02:34:11 | 10 - 11 классы

Составьте программу вычисления суммы всех двузначных чисел?

Составьте программу вычисления суммы всех двузначных чисел.

Для Паскаля.

Corut 23 нояб. 2020 г., 04:08:31 | 5 - 9 классы

Найти сумму всех двузначных чисел?

Найти сумму всех двузначных чисел.

Решить используя цикл с параметром.

(Паскаль).

Katyanikolaeva0465 13 февр. 2020 г., 03:12:16 | 10 - 11 классы

Дано целое двузначное число М?

Дано целое двузначное число М.

Разработайте схему алгоритма, который вычисляет сумму всех двузначных чисел, начиная с числа М.

Используйте цикл ПОКА.

Желательно на языке Паскаль.

SergeyTsetsko 12 июл. 2020 г., 05:59:46 | 5 - 9 классы

Народ, помгите?

Народ, помгите!

Составьте алгоритм нахождения суммы всех двухзначных чисел, кратных трем, используя цикл с параметром.

Пушиночка2004 13 окт. 2020 г., 13:50:11 | 5 - 9 классы

Дано n чисел составить программу для нахождения суммы этих чисел через цикл пока?

Дано n чисел составить программу для нахождения суммы этих чисел через цикл пока.

Виктория1384 7 мая 2020 г., 16:33:00 | 5 - 9 классы

Составте пожалуйста программу вычисления суммы всех двузначных чисел?

Составте пожалуйста программу вычисления суммы всех двузначных чисел.

Настя047 17 июн. 2020 г., 12:43:52 | 10 - 11 классы

Написать программу вычисления суммы факториалов всех нечетных чисел от 1 до 9?

Написать программу вычисления суммы факториалов всех нечетных чисел от 1 до 9.

С помощью функции.

Tiamatolga 10 дек. 2020 г., 15:25:09 | 5 - 9 классы

Написать программу вычисления суммы чисел двузначного числа?

Написать программу вычисления суммы чисел двузначного числа.

Иванова4 2 нояб. 2020 г., 15:31:00 | 1 - 4 классы

Составить блок - схему алгоритма вычисления суммы всех двузначных чисел?

Составить блок - схему алгоритма вычисления суммы всех двузначных чисел.

ЕленаГусакова 2 нояб. 2020 г., 20:18:49 | 5 - 9 классы

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром?

Написать программу нахождения суммы всех натуральных чисел от 1 до 99, используя цикл с параметром.

На этой странице находится вопрос Алгоритм и программа вычисления суммы 2 нечетных двузначных чисел пока сумма не станет 150 ?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 5 - 9 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.