Как преобразовать символ char в переменную int на языке с (не с + + )?

Информатика | 10 - 11 классы

Как преобразовать символ char в переменную int на языке с (не с + + )?

Например char c ; int x ; чтобы 'c' = x ; Спасибо заранее.

Ответить на вопрос
Ответы (1)
Romasey3000 24 сент. 2020 г., 07:03:23

Char c = 'c' ;

int x = (int)c ;

Лё8а 5 нояб. 2020 г., 07:42:59 | 10 - 11 классы

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * )?

Int * arr = (int * )malloc(N * sizeof(int)) ; выручайте, спросили что такое (int * ).

84193135 11 июн. 2020 г., 00:41:12 | 10 - 11 классы

Язык С?

Язык С.

Написать программу, которая печатает объем памяти занимаемый одной переменной для типов int, short int, long int, float и double.

Человек7 21 июн. 2020 г., 02:55:52 | 5 - 9 классы

Целочисленный тип данных называется ?

Целочисленный тип данных называется .

1)real 2)var 3)integer 4)program 5)char 6)int.

Amarasov1 27 мар. 2020 г., 12:12:57 | 10 - 11 классы

(Char)?

(Char).

Пользователь вводит символ.

Вывести на экран символ, последующий за ним в таблице кодов ASCII.

Natatalia09 16 авг. 2020 г., 18:13:27 | 10 - 11 классы

Даны следующие описания переменных : var A, B : set of char ; x : char ;Переменной B присвоить множество, полученное из A : а) добавлением элемента x ; б) удалением элемента x?

Даны следующие описания переменных : var A, B : set of char ; x : char ;

Переменной B присвоить множество, полученное из A : а) добавлением элемента x ; б) удалением элемента x.

TheDenJekov 31 янв. 2020 г., 07:20:19 | 10 - 11 классы

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false?

Напишите функцию bool f(int x, int y, int z), которая возвращает true, если x ^ 2 + y ^ 2 = z ^ 2 иначе возвращает false.

Задача в Visual Studio, язык c + +.

T0ny0 7 сент. 2020 г., 13:27:26 | 10 - 11 классы

Помогите?

Помогите!

Переменная А вводится с помощью описания : var A : set of char ; напишите функцию, которая возвращает количество символов в множестве А.

(МОЖНО ИСПОЛЬЗОВАТЬ STRING!

).

Птздочс 17 мар. 2020 г., 04:53:17 | 10 - 11 классы

Написать функцию, которая возвращает символ строки с самой высокой частотой встречаемости?

Написать функцию, которая возвращает символ строки с самой высокой частотой встречаемости.

Прототип функции char function_name (char * s).

Проверить работу функции на строке, введенной с клавиатуры.

Реализовать вывод результата.

Шмекер 31 окт. 2020 г., 19:39:12 | 10 - 11 классы

Вопрос по С + + Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4 - 8 символов) слов во всех строках текста То что придумал #include "stdafx?

Вопрос по С + + Надо было составить программу чтобы считывала текст из файла и выводила количество маленьких (4 - 8 символов) слов во всех строках текста То что придумал #include "stdafx.

H" #include #include #include #include using namespace std ; int main(int argc, _TCHAR * argv[]) { FILE * text ; char * filename = "C : \ \ Myfile.

Txt" ; char buf[101] = "" ; char commentStr[101] = "" ; if (!

(fopen_s(& ; text, filename, "r"))) { while (fgets(buf, 100 , text)) printf_s("%s", buf) ; char * pmin = NULL ; size_t pminlen = 0 ; char * head ; char * tail ; while ( * tail) { for (head = tail ; * head & ; & ; !

Isalnum( * head) ; + + head) { ; } for (tail = head ; * tail & ; & ; isalnum( * tail) ; + + tail) { ; } if (head < ; tail) { if ((pmin = = NULL) || (pminlen > ; tail - head)) ; { pmin = head ; pminlen = tail - head ; } } } if (pmin) { printf(" \ n") ; printf("min = %.

* s \ n", pminlen, pmin) ; } system("pause") ; return 0 ; } ничего не выдает в чем ошибка ( как мне кажется их тут дофига).

Полинка1547 12 дек. 2020 г., 05:06:46 | 5 - 9 классы

Умоляю , Пожалуйста ?

Умоляю , Пожалуйста !

Напишите функцию int min (int a, int b, int c, int d) (C / C + + ), static int min (int a, int b, int c, int d) (Java) function min (a, b, c, d : integer) : integer (Pascal), находящую наименьшее из четырех данных чисел.

Входные данные Вводится четыре числа.

Выходные данные Необходимо вывести наименьшее из 4 - х данных чисел.

На этой странице находится вопрос Как преобразовать символ char в переменную int на языке с (не с + + )?. Здесь же – ответы на него, и похожие вопросы в категории Информатика, которые можно найти с помощью простой в использовании поисковой системы. Уровень сложности вопроса соответствует уровню подготовки учащихся 10 - 11 классов. В комментариях, оставленных ниже, ознакомьтесь с вариантами ответов посетителей страницы. С ними можно обсудить тему вопроса в режиме on-line. Если ни один из предложенных ответов не устраивает, сформулируйте новый вопрос в поисковой строке, расположенной вверху, и нажмите кнопку.